Hot answers tagged

5 votes
Accepted

Images containing EXIF orientation tag are not rotated on upload

After some mail exchanges with Brad and Andris from Craft CMS, it turned out that there is an edge case where the image rotation on upload will not work if the EXIF extension is not installed (which ...
user avatar
  • 496
4 votes
Accepted

Upgraded to PHP 7.1 - GD or ImageMagick is required

You'll need to contact your hosting provider. There are any number of ways that this "PHP switching" can be implemented, but typically each major PHP version has its own separate modules/config files ...
user avatar
2 votes

Craft\Exception on saving entries having images

I'm going to go out on a limb and say you're trying to upload a file type that isn't allowed under that Asset fields "Restrict Allowed File Types?" section.
user avatar
  • 66.5k
2 votes

Animated GIFs not working in Craft with ImageMagick installed

I ended up applying this configuration to config > general.php so GIFs aren't transformed. 'transformGifs' => false https://docs.craftcms.com/v3/config/config-settings.html#transformgifs
user avatar
  • 153
1 vote

Why is Craft storing so much temporary files inside the server tmp folder?

Imagick uses the /tmp folder by default, but you can change it: https://github.com/ImageMagick/ImageMagick/issues/399#issuecomment-285793433
user avatar
  • 66.5k
1 vote

Assets are not loading anymore (maybe an update)

Solved the complete error with a reset of the imager config file.
user avatar
  • 53
1 vote

Uploading PDFs with Imagick extension enabled seems to rasterize and compress the PDFs

Got the same problem with Craft3 (3.0.0-beta.19). Had to change the imageDriver to GD. Add 'imageDriver' => 'gd', to config/general.php and replace/reupload the files in Craft.
user avatar
  • 19
1 vote

Imagick installation passed with warnings

Click on the "i" graphic and it will probably tell you that GD is installed, but Imagick isn't and it is recommended. You can verify that Imagick is installed and available to PHP/Craft by going to ...
user avatar
  • 66.5k
1 vote

Asset transform messing with color

Somehow, the images were created thinking Imagick wasn't installed. Clearing the cache forced the images to be recreated and seems to have fixed it.
user avatar
  • 3,061

Only top scored, non community-wiki answers of a minimum length are eligible