3

Instead of duplicating the entries, you could run your entries loop twice (or as many times as you want) maybe? {% for i in 0..1 %} {% for entry in entries %} {{ entry.title }} <br> {% endfor %} {% endfor %}


3

Try accessing the CP-Panel, in most cases this error occurs due to config files not being set correctly, thus not allowing craft to connect to the DB. If you get the installer page when accessing the CP-Pannel, that means it's most likely not able to access the DB with your current configs. Usually the URL would be my-host.com/backstage however this may ...


3

Cleared the log files found at /storage/logs/web.log. Tried to view an inner page on the website which threw a Craft "Internal Server Error". Inside the log, I saw "Twig\Error\SyntaxError: Unknown "dump" function". Googled that message and found the solution. For other newcomers, when you set devMode to true, the dump() function is available in your ...


2

I was able to fix this on my local MAMP installation by following the instructions for making MAMP play nicely with Craft in this guide, then executing the command chmod a+x craft from this tutorial.


2

I'm not sure I can tell you much more than the error messages are telling you, you need to update your twig code eg. in index.twig (line 6) where it says; getPurchasableId() change it to getId(). These errors are just warning you that a future version of Craft won't support them (I imagine it will be Craft 4, but could be sooner). Changing e-commerce ...


2

You should replace postCategories with whatever the handle of the category field is for your entry.


1

Errors for the users/save-user action are recorded against the user object, not the session object. If the user is logged-out, the object is named user but if they are logged-in you must use currentUser. Generally speaking you can retrieve errors from Yii objects in several ways, but for field-by-field errors, I prefer the simplicity of getFirstError() (You ...


1

Thank you Oli for helping with this simple quest. Here's the code that worked for me. ("decade" being the name of the field I'm using in the backend, putting out the category group!) {% for category in entry.decade.all() %} <a href="{{ category.url }}""> {{- category.title -}} </a> {% endfor %} {% endif %}


1

Sorted YAY! In case this is helpful to anyone, I tried deleting and reinstalling via composer then replacing the config and .env files but no luck there so I downloaded the latest version and updated just the vendor folder. It needed to update the database which it couldn't do for me so I took a manual backup and let it do it's thing and now it's all ...


1

This answer was contributed after troubleshooting in comments on the original question. This error can appear for a variety of reasons, but most commonly when Craft believes it isn't installed. The installation process begins at /admin/install, but is dependent upon the cpTrigger config value. That this page wasn't accessible (or, more specifically, ...


1

Have a look at your .env file on the production system and your config/db.php file your repo. Craft has changed the way db access data is stored and must now be provided as a DSN This is now config/db.php return [ 'dsn' => getenv('DB_DSN'), 'user' => getenv('DB_USER'), 'password' => getenv('DB_PASSWORD'), 'schema' => getenv('...


1

From Craft Support: Assuming the credentials in your .env are correct on that site, could you run ./craft clear-caches/all (or manually empty your web/cpresources and storage/runtime


1

But is the issue related to the size of the Matrix Field? Or overall the number of fields in the database? Neither. :) That error message isn't related to the linked Github issue (although I can see how you'd get them confused). It's coming from the Craft's Plain Text field type: https://github.com/craftcms/cms/blob/develop/src/fields/PlainText.php#L126-...


1

I ended up uploading the files to my own hosting environment where I updated it to the latest version of Craft and plugins etc. Then pulled down locally and it worked fine.


1

Solution Login to the server and access mysql and find your database. Select the fields table to locate the ID of the problem field. SELECT * FROM fields; Remove the field using the ID. DELETE from fields where id = '355';


1

Your web server doesn't have the PHP DOM extension installed and I'm guessing you're doing something in a template that requires it. (https://www.php.net/manual/en/book.dom.php). If you install that, the error should go away.


1

I am presuming Craft 3 because of composer, but you didn't say. To start with look in your craft templates folder. I would suggest that you simply don't have the template that Craft is looking for. If you visit the root of your site this is normally templates/index.twig make sure this is present and has no further includes in it (just until you get it ...


1

This worked well for me! Be sure to change directory out of the drive you want to unmount first! Just to keep it all together here is what you need to do - sudo nano /etc/wsl.conf Paste this into the open file - [automount] enabled=true options=metadata,uid=1000,gid=1000,umask=022 Then paste and enter these one at a time into Terminal - sudo rm /...


1

All fixed. The solution was to add these mount options to /etc/wsl.conf to allow metadata support. Also had to rename (or delete) /storage/cpresources and clear cache. [automount] enabled=true options=metadata,uid=1000,gid=1000,umask=022 From Microsoft on permissions in WSL: https://devblogs.microsoft.com/commandline/chmod-chown-wsl-improvements/


1

I ran into this issue recently updating a Craft 3.0.37 site to 3.2.x The issue turned out to be SuperTable plugin which also needed to be updated to more recent version.


Only top voted, non community-wiki answers of a minimum length are eligible