Skip to main content
7 votes
Accepted

No input file specified - [proxy_fcgi:error] Got error 'Unable to open primary script: [PATH]/html/index.php (No such file or directory)\n'

It turned out that the problem was from customizing the domain's document root in the userdata files and then the PHP-FPM configuration had not been rebuilt and the service not restarted. The ...
ylluminate's user avatar
6 votes
Accepted

After updating, getting "Could not resolve the subpath" error

If you're setting an dynamic upload folder location for an Assets field inside of a Matrix field, you need to preface things like {slug} with {owner.slug}. See the note about dynamic subfolders on an ...
Brad Bell's user avatar
  • 67.5k
6 votes
Accepted

How do I clear deprecation errors for looping through element queries?

What about using the all() function as well? Your field doesn't contain an array, it contains the same type of object like craft.entries provides. {% for flag in country.all() %} It doesn't appear ...
Robin Schambach's user avatar
5 votes
Accepted

Craft CMS 3.0 - Log file?

Based on the official documentation the log files are under /storage/logs and look for the web.log file especially. If you don't find anything check your webserver logs.
terdelyi's user avatar
5 votes
Accepted

How to duplicate entries and loop them without getting a Twig or deprecation error?

Instead of duplicating the entries, you could run your entries loop twice (or as many times as you want) maybe? {% for i in 0..1 %} {% for entry in entries %} {{ entry.title }} <br&...
Oli's user avatar
  • 7,495
4 votes

500 error on installation since version 2.3

In case it helps someone, my issue was the permissions for the root index.php file...It was 666 (writeable by group) and when I switched that file permissions to 644, the installation was able to move ...
glenn's user avatar
  • 61
4 votes

An unknown error occurred all the time

I too just had this problem - upon any action in the control panel flashed "An unknown error occurred". What I found in my craft web.log was: "ErrorException: ignore_user_abort() has been disabled ...
Will's user avatar
  • 91
4 votes
Accepted

Responsive Images Srcset and Sizes based on Image Transform

Merge operates on arrays or array-like things, and you probably handed it the string "card", which is why you got that error. I think what you want to do here is use the transform in the control ...
Marion Newlevant's user avatar
4 votes
Accepted

getPrev and getNext stop working after 100+ entries

In your criteria, you need to set the limit to null as by default Craft only returns up to 100 entries. See: Default Craft entry limit
Jeremy Daalder's user avatar
4 votes

Craft CMS . Service unavailable

The 503 error that is triggered from that log entry happens when Craft files are in place on the server, but it haven't been installed yet and someone loads the front-end of the website. Assuming you'...
Brad Bell's user avatar
  • 67.5k
4 votes

Issues upgrading Craft 2 to 3 - Keep seeing Install Screen not Update screen

If you've seeing any install screen instead of an update screen, that means that Craft can connect to the database server specified in craft/config/db.php file, but it either can't find the database ...
Brad Bell's user avatar
  • 67.5k
4 votes
Accepted

Best way to find a deprecation error with no location hint?

If you look in the list of file paths in the stack trace there will be one or more files in the storage/runtime/compiled_templates directory. In this particular case there is storage/runtime/...
Mike Pepper's user avatar
  • 4,391
4 votes

HTTP 503 – Service Unavailable error

Try accessing the CP-Panel, in most cases this error occurs due to config files not being set correctly, thus not allowing craft to connect to the DB. If you get the installer page when accessing the ...
Campiotti's user avatar
  • 313
4 votes

500 Internal Server Error when accessing admin

It turned out that RewriteBase / needed to be added to the htaccess
Andrew's user avatar
  • 748
3 votes
Accepted

Getting error "Your session has ended. Enter your password to log back in." every 30 seconds or so

Thanks for the troubleshooting help. It appears as though the issue was the cache and how Craft handles sessions. For those who use a cache/CDN and are having issues with control panel session ...
Ian O'Brien's user avatar
3 votes
Accepted

Migration Errors

As the link posted by Moto_Nomad indicated, it was an issue with MySQL strict mode GROUP_BY. In my case, I remedied this by using the following guide: https://serverpilot.io/community/articles/how-to-...
Dustin C's user avatar
  • 379
3 votes

Invalid asset source path

the general.php file was setup for a multi environment but was missing '*' => array( ), as per the notice here: https://craftcms.com/docs/multi-environment-configs {basePath}assets/images/ was ...
lucaslink's user avatar
3 votes

Class 'Craft\DbCommand' not found

Even thought this is an old thread, I recently ran in to the same problem. It turned out to be a PHP version issue. I was running MAMP with PHP 7.0.0, once I switched that host to 5.6.10 it worked ...
Tom's user avatar
  • 31
3 votes
Accepted

PHP Fatal error: Uncaught Error: Class 'Craft\DbConnection' not found

This project was missing the craft/app/etc/db/directory and all files within that directory (my .gitignore file had meant to ignore the project root db directory, but caught all directories named 'db')...
dace's user avatar
  • 241
3 votes

Unable to run console commands (Craft 3, MAMP)

I was able to fix this on my local MAMP installation by following the instructions for making MAMP play nicely with Craft in this guide, then executing the command chmod a+x craft from this tutorial.
kmgdev's user avatar
  • 1,199
3 votes

Unique URI error

Turns out the error was because {slug} was missing from the Section Setting: Entry URI Format
Pedro's user avatar
  • 171
3 votes

devMode false, Internal Server Error

Cleared the log files found at /storage/logs/web.log. Tried to view an inner page on the website which threw a Craft "Internal Server Error". Inside the log, I saw "Twig\Error\SyntaxError: Unknown "...
BrianMc's user avatar
  • 71
3 votes
Accepted

After transferring local to server, Twig Runtime Error: Impossible to invoke a method all() on an array

You can't call .all() twice. In myEntryQuery you have converted the result into an array, you are then trying to call .all() again, but at this point you have an array, so .all() can't be used as it's ...
James White's user avatar
  • 1,171
3 votes
Accepted

"Unable to verify your data submission" error when logging into Craft Control Panel

As part of my troubleshooting, I checked the Developer Console and saw a couple errors originating from Craft's javascript files that were stored in the /cpresources directory. As an attempted fix, I ...
Anna_MediaGirl's user avatar
2 votes

FastCGI error when accessing a local development site using MAMP Pro

I get this from time to time. I'm not sure of the specific errors in the logs as it hasn't happened for a while. But when it does then switching MAMP to use the same PHP for all hosts (so not FastCGI),...
foamcow's user avatar
  • 2,029
2 votes
Accepted

Odd error message when editing field settings (Variable "targetLocaleFieldHtml" does not exist)

This had me stumped for a while, but it turned out to be a custom fieldtype extending BaseElementFieldType, in which the settings attribute targetLocaleField apparently was renamed ...
Mats Mikkel Rummelhoff's user avatar
2 votes
Accepted

'An unknown error occurred.' when trying to add new custom widget

I feel quite embarrassed, but I have finally got this thing working. The error that I had made was within AdLister_AluWidget.php. I had written at line 4: class Adlister_AluWidget extends BaseWidget ...
SYPOMark's user avatar
  • 105
2 votes
Accepted

PHP mbstring extension isn't enabled? (WampServer)

As these things go, after I posted my question, I clicked "Refresh" in the Wamp menu and now my site works. I'm not sure what changed, especially since I already restarted the entire program several ...
Katie Fritz's user avatar
2 votes
Accepted

Failed to add a custom field in settings

You're getting that error message because your PHP environment is displaying PHP Strict mode error messages. By default, Craft will explicitly disable those if devMode is enabled (error_reporting(...
Brad Bell's user avatar
  • 67.5k
2 votes
Accepted

EntryModel::populateModels throws a 500 error

There's probably an error in craft/storage/runtime/logs/phperrors.log and there's a 99% chance the problem is you're hitting your php.ini file's memory_limit setting. Populating 5,000 models is going ...
Brad Bell's user avatar
  • 67.5k

Only top scored, non community-wiki answers of a minimum length are eligible