Hot answers tagged

4

That error will occur if the fileinfo extension or imagick (ImageMagick) extension are not configured with a comprehensive list of file MIME types (the "magic file", as they refer to it, I think), or the images you're uploading aren't really images despite their extensions. Regarding GIFs - you must use ImageMagick if you want to upload animated GIFs, as it'...


4

I don't know the specific rules Craft uses but I believe Craft auto appends the -1 when it tries to save an Element that has a matching URI in the craft_elements_i18n table. A few scenarios that I can think of that may behave like you describe: Somehow, there is an existing record in your database that matches the URI of your Entry using the cics-west-...


4

What you do, is this: Get 30 items from the database, ordered by showTime Then, you filter them with the if-attribute in the for-statement This means, that you could get anywhere from 0 to 30 results. What you want to do, is make sure the filtering happens within the element query. I did not test this (not sure about the time criteria part), but something ...


2

This bug was due to an issue with the Stringify library and was fixed in Craft 3.3.16.1, as stated by Brad Bell in his comment on the original question. Upgrading to Craft 3.3.16.1 fixes this issue. (I'm posting this as an answer in case anybody else runs into the same issue.)


1

If someone else happens to have the issue, here is what solved it for me: https://github.com/craftcms/cms/issues/1853#issuecomment-582353821


1

As far as I know the craft_info table should only have one row. This would mean that either: You have something installed / configured wrongly somewhere causing it to insert a 2nd row into the table Or it's actually a craft bug, I'd advise you to search through The CraftCMS Github Issues and check if there's any issue resembling yours, if not create an ...


1

Solved it. The problem was with this field: <input type="hidden" name="fields[gdprPermissionsList][permissionSales][fields][lastChangedDate][date]" value="{{ now|date("m/d/Y") }}"> The [date] part was to much and it saved the value in Craft as a literal string: {"date":"07\/11\/2018"} instead of the formatted date. In one of the Craft updates that ...


1

Sounds like your search indexes are corrupted. I’d try to run the “Rebuild Search Indexes” tool in CP > Settings.


1

If you have gzip compression enabled (either at the PHP or Apache level), try disabling that and see if helps. Obviously that's not a proper long-term solution, but if you leave it on and set the runTasksAutomatically config setting to false and setup a cron job as described in the docs, you can see if that helps as well.


Only top voted, non community-wiki answers of a minimum length are eligible