Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [ssl]

The tag has no usage guidance.

1
vote
1answer
250 views

Craft CMS 3 admin panel returns 404 with SSL

I'm using MAMP Pro for local development and was gong to set up my site with SSL this time around. I got a self-signed cert for local dev and I can go to my development site over https:// without any ...
0
votes
0answers
175 views

Craft 3 Admin not loading cpresources files over HTTPS

I have a Craft 3 install on my client's Windows machine running Apache, PHP and MySQL. We purchased an SSL certificate but the main Admin login page (on SSL) keeps loading cpresources assets over ...
1
vote
1answer
182 views

Force redirect from HTTP to HTTPS via htaccess with multisite installation

I'm using Craft CMS 3 multisite installation with more than 20 website based on subdomains. There are websites: website.com one.website.com two.website.com with identical url paths but different ...
2
votes
1answer
1k views

FeedMe SSL error - cURL error 35: SSL connect error

I'm getting an error when trying to access an endpoint over ssl in FeedMe. eg https://jsonplaceholder.typicode.com/posts The error is cURL error 35: SSL connect error Error reported in web.log is [...
2
votes
1answer
243 views

Can't update or install plugins locally, macOS

I'm unable to update or install plugins in Craft 3. Running in macOS via MAMP, PHP 7.0.8. Error: The "https://api.github.com/repos/php-fig/cache/zipball/d11b50ad223250cf17b86e38383413f5a6764bf8" file ...
1
vote
1answer
319 views

How do I force www in URL along with the Patrol plugin to force https

I'm using the Patrol plugin to force https in the domain, but I also need to force www into the URL. When I do that with some htaccess rewrite rules I found online I get an error when I try to load ...
1
vote
3answers
520 views

.dev local development

I'm getting SSL errors when developing using .dev as a domain name. I believe it's because browsers are now automatically forwarding these to HTTPS://. Any ideas how to get around this with Craft? I ...
1
vote
1answer
100 views

Optimizing With Http2 In Mind

My main config is Apache/Centos 7/WHM/Redis/OPCache/PHP7.1/MariaDb/PHP-fpm/Http2 and have optimized my server to a great degree. It's a 32GB dedicated HexaCore. I have worked really diligent to get ...
0
votes
1answer
272 views

CloudFlare Shared SSL certificate forbids CraftCMS control panel sign in

I am running a site using CraftCMS and have a shared CloudFlare SSL certificate in place. Based on my understanding, the content source (i.e. my website) is not safe, while the content delivered to ...
1
vote
0answers
246 views

Configuring CraftCMS on Arcustech with Cloudflare flexible SSL returns 521 error

I have installed CraftCMS on an Arcustech VPS and successfully added a domain name. Using the domain without the shared SSL works without any problems (e.g. www.example.com / example.com). However ...
0
votes
1answer
493 views

Problems Securing Database Connection Over SSL

I used to connect to my database over SSL by directly modifying the createDbConnection method in Craft's AppBehavior.php: $dbConnection = new DbConnection(); $dbConnection->connectionString = $...
3
votes
1answer
516 views

Craft site moved to HTTPS - now having issues

I have had a Craft install running for some time now, and it has come to the point where I want to run it securely over HTTPS. Using Laravel Forge, I have set up a Let's Encrypt certificate ...
2
votes
1answer
325 views

Does Craft CMS support MySQL over SSL?

Does Craft CMS support MySQL over SSL? Thanks!
1
vote
1answer
498 views

Ensuring Image transforms use https

I'm trying to get rid mix content warnings for https connection. The SSL certificate is installed and working fine but my image transforms are being requested over http hence the warning messages. ...
3
votes
2answers
2k views

Asset URLs not HTTPS

I'm currently redirecting all requests to https. I've updated the siteUrl variable and all of my entry links have been correctly updated but the image links are still http. When I go to the admin ...
0
votes
1answer
305 views

Control panel switches to HTTPS protocol on its own

On one Craft CMS site I have, all control panel URLs I call over HTTP are rewritten to HTTPS. E.g. the login page, as well as all its assets, are being served via https://www.mywebsite.com/admin/…. ...
3
votes
2answers
960 views

Using SSL for entire website on Arcustech server

I want to use SSL (https) for my entire website which is hosted on Arcustech. I came across two instructions, one on Craft's site which discusses forcing SSL on the CP and the other is from Arcustech'...
0
votes
0answers
77 views

Protocol agnostic image transform url's

I have one page under https:// how do I deliver the images there via https? Whith the whole site under https it's easy via environmentVariables but what if there is just one secure page? Is there a ...