Questions tagged [ssl]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
71 views

Local GraphQL requests failing due to SSL issues (unable to get local issuer certificate)

I have a local install of Craft 3 set up as a headless CMS and served via Nitro. I’m pulling in data to Next.js via Apollo GraphQL. I’m able to successfully query Craft for a list of entries from the ...
0 votes
0 answers
27 views

Admin CP requests Http rather than https so browser gives non secure and javascript doesn't load

I have a weird issue happening and looking for any advice or tricks to try. I currently have an AWS setup for my site but I don't have control of aws as that is handled by a different internal ...
1 vote
1 answer
79 views

Craft CMS SSL added to website correctly but says insecure for admin panel

I have 2 websites one in craft cms 2 and the other in craft cms 3. Everything works fine except the control panel always shows HTTPS insecure, for both the sites. Below is my .htacces file, <...
2 votes
3 answers
310 views

SSL certificate for Docker container in Nitro 2 has expired: what to do?

I created a Docker container 3 months ago. I’ve only just come back to it and find its SSL certificate has expired. I can find nothing on what is best to do. Is it best to reissue the certificate? If ...
1 vote
1 answer
151 views

Craft Setup 3.6.5.1 with MYSQL with SSL version 5.7.29

I'm trying to install Craft version 3.6.5.1 with MYSQL version 5.7.29 from Azure. While setup it fails with the following error Testing database credentials ... failed: SQLSTATE[HY000] [9002] SSL ...
0 votes
0 answers
139 views

Certificate problems when sending mail via smpt (tream_socket_enable_crypto(): SSL operation failed with code 1)

I know there were already a lot of these issues on this board, but none solved mine, unfortunately. Be assured that I searched quite a lot (for hours) but could not solve it. I hope I have not ...
  • 481
1 vote
1 answer
184 views

Incorrect canonical URLs and redirect chains

I have installed SEOMatic. However, I am getting incorrect canonical URLs. Here is an example: https://jenoffvanhulle.com/en/ The URL has a trailing slash, the canonical URL not A second problem is ...
  • 11
1 vote
1 answer
43 views

Loading assets cross-domain with SSL or non-SSL option

Here's a unique situation. I have three websites. All assets are stored at the domain of the first site: domain.com/files/* The first two sites run completely over SSL. No problem. The third site ...
  • 608
2 votes
2 answers
612 views

How to use SSL for local development with Nitro?

I've created a new Craft CMS project and installed Nitro to run everything in a VM. Now I'm wondering if it's possible to use SSL for the local domain? I didn't found anything in the documentation.
  • 123
1 vote
1 answer
31 views

Force SSL on sub folder

I'm having issues forcing an SSL on my website. I think the issue may be that my root folder is my 'web' folder. I've searched online and tried a few variations of htaccess but none of them seem to ...
0 votes
0 answers
39 views

404 on all pages but home after switch to https

I have an SSL certificate installed on the server. Now I want to switch to https:// instead of http:// as the site is showing as "not secure". I've updated the siteUrl and baseUrl in config/general....
1 vote
1 answer
295 views

SSL now CP unknown errors

I have a Craft 3 site that's been running on a production server. Recently we switched over to https but this has caused issues in the CP (multiple 'An unknown error occurred' red flags, can't view ...
1 vote
1 answer
2k views

Craft CMS 3 admin panel returns 404 with SSL

I'm using MAMP Pro for local development and was gong to set up my site with SSL this time around. I got a self-signed cert for local dev and I can go to my development site over https:// without any ...
2 votes
1 answer
1k views

Craft 3 Admin not loading cpresources files over HTTPS

I have a Craft 3 install on my client's Windows machine running Apache, PHP and MySQL. We purchased an SSL certificate but the main Admin login page (on SSL) keeps loading cpresources assets over ...
  • 641
1 vote
1 answer
584 views

Force redirect from HTTP to HTTPS via htaccess with multisite installation

I'm using Craft CMS 3 multisite installation with more than 20 website based on subdomains. There are websites: website.com one.website.com two.website.com with identical url paths but different ...
2 votes
1 answer
3k views

FeedMe SSL error - cURL error 35: SSL connect error

I'm getting an error when trying to access an endpoint over ssl in FeedMe. eg https://jsonplaceholder.typicode.com/posts The error is cURL error 35: SSL connect error Error reported in web.log is [...
2 votes
1 answer
474 views

Can't update or install plugins locally, macOS

I'm unable to update or install plugins in Craft 3. Running in macOS via MAMP, PHP 7.0.8. Error: The "https://api.github.com/repos/php-fig/cache/zipball/d11b50ad223250cf17b86e38383413f5a6764bf8" file ...
  • 1,369
1 vote
1 answer
514 views

How do I force www in URL along with the Patrol plugin to force https

I'm using the Patrol plugin to force https in the domain, but I also need to force www into the URL. When I do that with some htaccess rewrite rules I found online I get an error when I try to load ...
1 vote
3 answers
649 views

.dev local development

I'm getting SSL errors when developing using .dev as a domain name. I believe it's because browsers are now automatically forwarding these to HTTPS://. Any ideas how to get around this with Craft? I ...
  • 11
1 vote
1 answer
184 views

Optimizing With Http2 In Mind

My main config is Apache/Centos 7/WHM/Redis/OPCache/PHP7.1/MariaDb/PHP-fpm/Http2 and have optimized my server to a great degree. It's a 32GB dedicated HexaCore. I have worked really diligent to get ...
  • 373
0 votes
1 answer
443 views

CloudFlare Shared SSL certificate forbids CraftCMS control panel sign in

I am running a site using CraftCMS and have a shared CloudFlare SSL certificate in place. Based on my understanding, the content source (i.e. my website) is not safe, while the content delivered to ...
1 vote
0 answers
332 views

Configuring CraftCMS on Arcustech with Cloudflare flexible SSL returns 521 error

I have installed CraftCMS on an Arcustech VPS and successfully added a domain name. Using the domain without the shared SSL works without any problems (e.g. www.example.com / example.com). However ...
0 votes
1 answer
841 views

Problems Securing Database Connection Over SSL

I used to connect to my database over SSL by directly modifying the createDbConnection method in Craft's AppBehavior.php: $dbConnection = new DbConnection(); $dbConnection->connectionString = $...
2 votes
1 answer
749 views

Craft site moved to HTTPS - now having issues

I have had a Craft install running for some time now, and it has come to the point where I want to run it securely over HTTPS. Using Laravel Forge, I have set up a Let's Encrypt certificate ...
3 votes
1 answer
707 views

Does Craft CMS support MySQL over SSL?

Does Craft CMS support MySQL over SSL? Thanks!
  • 33
1 vote
1 answer
694 views

Ensuring Image transforms use https

I'm trying to get rid mix content warnings for https connection. The SSL certificate is installed and working fine but my image transforms are being requested over http hence the warning messages. ...
3 votes
2 answers
2k views

Asset URLs not HTTPS

I'm currently redirecting all requests to https. I've updated the siteUrl variable and all of my entry links have been correctly updated but the image links are still http. When I go to the admin ...
  • 345
0 votes
1 answer
444 views

Control panel switches to HTTPS protocol on its own

On one Craft CMS site I have, all control panel URLs I call over HTTP are rewritten to HTTPS. E.g. the login page, as well as all its assets, are being served via https://www.mywebsite.com/admin/…. ...
5 votes
2 answers
1k views

Using SSL for entire website on Arcustech server

I want to use SSL (https) for my entire website which is hosted on Arcustech. I came across two instructions, one on Craft's site which discusses forcing SSL on the CP and the other is from Arcustech'...
  • 846
0 votes
0 answers
78 views

Protocol agnostic image transform url's

I have one page under https:// how do I deliver the images there via https? Whith the whole site under https it's easy via environmentVariables but what if there is just one secure page? Is there a ...
  • 3,684