Questions tagged [server]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
29
votes
3answers
2k views

How do I configure Varnish to work with Craft?

Has anyone successfully used Varnish with a Craft build? I'm trying to set up Varnish on my server but I'm very new at this. Can anyone share their config file or point me in the right direction? We ...
19
votes
4answers
4k views

Can I run one Craft install on multiple domains and/or subdomains?

Is it possible to have one Craft install running multiple domains and/or subdomains? For example having the same Craft install running a blog Channel at blog.example.com and also an about Single at ...
17
votes
4answers
11k views

What is the recommended Nginx configuration for Craft?

I'm looking for the recommended way of how to configure Nginx server to run Craft. Currently, I use the following configuration, it works, but I don't know if it could be better: server { listen ...
10
votes
1answer
2k views

Are there any intentions to release multisite support for Craft?

We're currently using a single ExpressionEngine install with MultiSite Manager to serve up 11 total sites that share the same database. After investigating Craft, and asking questions via Twitter it ...
9
votes
4answers
5k views

Getting $craftPath error on server trying to get Craft running

Trying to get my Craft site running on my server for the first time. Getting the error Could not find your craft/ folder. Please ensure that $craftPath is set correctly in /var/www/dev.mysite.com/...
9
votes
2answers
2k views

Installation Error “1046 No database selected”

Summary I'm getting the following error when attempting to install a new Craft site locally: CDbCommand failed to execute the SQL statement: SQLSTATE[3D000]: Invalid catalog name: 1046 No database ...
7
votes
2answers
811 views

How do I redirect traffic from a legacy category URL to a new category URL?

Within Craft, I am renaming the top-level entry URL format for a section from legacy-subdirectory/{slug} to new-subdirectory/{slug}. How do I redirect traffic from the legacy URL to the new format ...
6
votes
4answers
4k views

All images uploading… except JPG files

No idea why but my local install of CraftCMS (in a MAMP environment) won't let me upload JPGs. PNG, GIF, even TIFF works (just for the heck of it). When I select the file in the browser dialog, it ...
6
votes
2answers
1k views

Can Craft easily be hosted across multiple servers?

We are looking at Craft as our CMS but would love to be able to scale the installation across multiple Amazon EC2 instances. Is this possible? Can all assets uploaded to Craft be pushed to S3? Is ...
6
votes
1answer
196 views

Craft sometimes takes several minutes to respond to a request

I have a pretty simple Craft site running a Digital Ocean Ubuntu droplet and for some reason it can sometimes take several minutes to save an entry. I think this might be something to do with ...
5
votes
2answers
1k views

What's the configuration to enable Craft for free CloudFlare and Railgun?

This is the host-installed version of CloudFlare/Railgun as offered very successfully at Arcustech. The arrangement is different from Railgun offered with the $200/month CloudFlare Business plan. It ...
5
votes
1answer
15k views

Adding cache headers to Nginx configuation file breaks the /admin area

When I add this to my Nginx Confirguration file: location ~* \.(js|css|png|jpg|jpeg|gif|ico)$ { expires 7d; add_header Pragma "public"; add_header Cache-Control "public, must-revalidate, ...
5
votes
1answer
741 views

Installing other PHP app in sub directory

My question is the opposite of this question: Installing Craft in sub directory I have a Craft website and I need to put a Laravel application in a sub directory, it almost works. I have made the ...
5
votes
1answer
3k views

Steps to publish a craft website from local to server

is there any resource that list all the steps to publish a local finished website to the final server? Thanks!
4
votes
2answers
658 views

Self-hosting requirements/scaling

Is there any reason the mySQL, CraftCMS, and assets/images/content can't all live on the same server, assuming the server is appropriately sized and backed up? Are there any sizing/scaling guidelines?...
4
votes
1answer
214 views

What are useful guidelines for Craft CMS security on VPS (virtual private servers)?

We have the choice of engaging services like Forge and ServerPilot, or rolling our own. Besides pricing, the opacity of what the services are actually providing can be a question -- just how well do ...
4
votes
1answer
912 views

Website taking 30+ seconds to load

One of my Craft websites is taking a long time (30+ seconds) to load. The /admin area also loads slowly. I have other installs of Craft on the same server that don't experience this problem. Are ...
4
votes
1answer
538 views

Craft hangs when updating entry

I've had this issue for a while now and have never been able to get it solved - even after chatting in Slack about it with some people. Basically whenever I go to update an entry, Craft hangs and ...
4
votes
2answers
541 views

Installation stops halfway. Files not found and internal server error 500

I've installed craft on some terrible hoster (I know, under force). Because of that I had to install craft in the public folder, next to the index.php file. I've set the path to ./craft and activated ...
4
votes
1answer
550 views

How to serve Craft with Caddy server

Caddy seems to be an easy to use alternative to established web servers. How does the Caddyfile look like for a Craft site?
4
votes
1answer
192 views

Can you run Craft CP on one webserver and serve the front end content on a separate one?

Much of my work is for a corporate organisation, and there is some resistance to having the CP of a CMS externally exposed. Is it possible to run the Craft CP on one internal (not available outside ...
4
votes
1answer
750 views

Hosting Craft on Heroku, problems with Asset uploads and thumbnail generation

Has anyone had success hosting Craft on Heroku? I got it up and running, but can't get file uploads to work. Also image thumbnails don't get generated. I am using Craft PRO and Assets are hosted on ...
4
votes
1answer
527 views

How can I time-profile the page load for a Craft request?

I would like to see how long plugins take to load, as well as other aspects of the page (loops and database requests). My webpage can take ~2-3 seconds to return the initial request. It seems high ...
3
votes
3answers
2k views

Can't get Craft running on a remote server

I have a Craft site that works great locally, but I can't get it running on a staging server. The virtual host is working and when I remove code from index.php in html it runs perfectly. Here is the ...
3
votes
1answer
560 views

Problems setting up a local site

I am running into problems with virtual hosts while trying to run Craft locally. My setup was working perfectly and after a restart of my mac I get error messages and I don't understand why. I am ...
3
votes
1answer
697 views

What does the Timezone in Settings -> General represent?

Should it be set to the timezone of the server Craft is installed on, or the timezone of the current user, or something else? I can find no documentation about these settings anywhere.
3
votes
2answers
906 views

Craft 3.0 - Recommended development environment for Windows?

I was wondering what people who are developing on Windows 10 are using as webserver environment in 2018? I have had ok results previously using ampps, but I'm having a lot of problems with Craft 3.0 ...
3
votes
1answer
1k views

PHP mbstring extension isn't enabled? (WampServer)

I'm using WampServer Version 3.0.4 64bit on Windows 10 to run a local dev site. It's been working fine for a few weeks, and I last opened the site about 5 days ago. Today when I go to my site, I'm ...
2
votes
2answers
459 views

Server respond is very long (25s). Is there a way to optimize the perfomance?

Normally I'm not working that much with craft and twig syntax, so first of all sorry if I'm not that much into that topic (normaly html,css,js,jquery). There is one site which need so much time to ...
2
votes
2answers
356 views

Running Craft alongside another CMS on the same domain

I've started working with a marketing team for a well established online ecommerce store. Their site is a custom ecommerce CMS build (handled by another third party), which works well technically, ...
2
votes
1answer
981 views

Mcrypt is required on Ubuntu 14.04

I am using Craft on Ubuntu 12.04 servers without problems, but when trying to run it on Ubuntu 14.04 (trusty) I always get the message Mcrypt is required. I installed it, however, via... apt-get ...
2
votes
2answers
5k views

Craft 3: 500 Internal Server Error when trying to install on server

For the last 3 days i've been trying to install Craft CMS 3 on my server. I'm using 1&1 internet, have FTP uploaded all the files, changed the permissions for the folders and files to the right ...
2
votes
3answers
2k views

HTTP ERROR 500 after move to live

I moved a site from staging to live. Prior to moving, I logged in to the Craft admin and cleared the caches. I copied the db to the new one and moved the folders like so… from… home/subdomains/craft ...
2
votes
1answer
512 views

Undefined index: siteSettings when updating entry types

I'm receiving an Undefined index: siteSettings when trying to save changes to entry types (both new and existing). Of course, this is only occurring on a production server - local server with up-to-...
2
votes
2answers
4k views

Login - Bad Request: The CSRF token could not be verified

I have just deployed an existing site to a new server. As the DNS is not pointing there yet, I have simply edited my /etc/hosts file on my Mac to point to the IP address for testing. Whilst checking ...
2
votes
1answer
1k views

Does Craft work with PHP 7?

I'm attempting to run Craft (2.4.2696) on a server with PHP 7 RC, and I'm seeing the following PHP warning: Declaration of Craft\DbCommand::addForeignKey($table, $columns, $refTable, $refColumns, $...
2
votes
1answer
121 views

How does the Craft CMS built-in web server works?

I just found this while using ./craft help in the Craft CMS command line utilities: - serve Runs the PHP built-in web server. serve/index (default) ...
2
votes
1answer
221 views

Do servers in a multi-server Craft setup need to share a storage directory?

We have a multi-server Craft setup, for redundancy and scaling. We've been using an shared NFS drive to to host Craft's storage directory, by setting CRAFT_STORAGE_PATH to a mounted /craft-data/ ...
2
votes
1answer
626 views

Craft site moved to HTTPS - now having issues

I have had a Craft install running for some time now, and it has come to the point where I want to run it securely over HTTPS. Using Laravel Forge, I have set up a Let's Encrypt certificate ...
2
votes
1answer
131 views

Is it possible to force Craft to recheck available sever modules?

One of our servers hosting a Craft site has recently had ImageMagick installed on it, as we noticed that transformed animated GIFs weren't animating. The 'Requirement Report' at /admin/utils/...
2
votes
2answers
861 views

500 error on PNG images

I'm uploading a PNG image into my assets folder and linking to it from my css file - standard stuff, nothing special. However the PNG image is returning with a 500 error in the console and not ...
2
votes
1answer
518 views

Best location for Craft development? Local or Server? Subfolder of production? [closed]

What's the best practice for development Craft installations? I think I would like to work on the production web server but in a hidden folder either upstream from my public HTML or as a subfolder. ...
2
votes
2answers
116 views

compiled_templates folder using up inodes on Ubuntu 14.04 Server

My server has gone down twice in the last 3 weeks because of an excessive number of files being created in the compiled_templates folder. This causes all of the inodes on our server to be used up ...
2
votes
1answer
2k views

Internal Server error during install

I've done a few installs of Craft and never had a problem. I'm currently trying to do an install on a new server under a subdmomain and getting the following results… This results in 404 http://...
2
votes
1answer
174 views

Sub-pages not loading on Windows server

I just moved a site over to a Windows server, and my homepage loads fine, but sub pages are not loading. I just get an error message that the connection was reset. Adding index.php to the url doesn't ...
2
votes
1answer
918 views

Internal Server Error

I am trying to edit fields. When I go to Settings->Fields and then click on a field, I get a message that reads: Internal Server Error Craft\Model and its behaviors do not have a method or ...
2
votes
1answer
914 views

Can't get Craft running on Heroku

I'm familiar with Heroku, but new to Craft CMS. In order to get a site running, I followed this tutorial: https://medium.com/@aj1215/craft-cms-on-heroku-79b991665b0b#.8b561b1b4 But the site isn't ...
2
votes
1answer
417 views

“Internal Server Error - Cannot find the target folder.” When trying to edit an article

Suddenly, when I try to enter an article to edit it, I get the error message "Internal Server Error - Cannot find the target folder." I can't seem to find the reason why this happens, or how to fix ...
2
votes
1answer
49 views

finding core dumps in public root

Am suddenly finding lots of core..xxx files dumped in the root of my site. In devMode cant see any issues. Assume this is serious issue and memory dump? Where to start? Logs have loads of stuff but ...
2
votes
1answer
249 views

Setting up Craft on Linode Using Ubuntu

I'm setting up a Craft site on a Linode server has anyone had any experience with this? I'm struggling with which owner and user to set the var/www/html folder to with chown and what chmod settings to ...