Questions tagged [server]

The tag has no usage guidance.

17 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1
vote
1answer
39 views

500 Error after Dreamhost server upgrade

Dreamhost upgraded my VPS overnight and I immediately got a 500 error. The site currently works on another Dreamhost VPS (the original below) and an Arcustech server. After checking the error logs I'm ...
1
vote
1answer
37 views

Directories and files being created by “root” user, inaccessible to CMS

I'm new to Craft and have been asked to support a live site that is running on it. I've run into a problem that seems to be due to files on the server being created by the wrong user. The vast ...
1
vote
1answer
217 views

Craft CMS not working on server

I had my Craft CMS site working on my local hosting. I then moved it over to bluehost VPS. I moved the database and uploaded the files to the server. I've put the database user information in the .env ...
1
vote
0answers
174 views

An unknown error occurred message, only on live server

Please can anyone give me some pointers. Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. ...
1
vote
0answers
49 views

How to remove domain from paginate.nextUrl?

What makes a site's domain appear within the output of paginate.nextUrl? I am experiencing a situation where it is not there in my local dev environment, but IS there on production server. I'm sure it'...
1
vote
0answers
237 views

Two domains, one server with Craft installed

I already have Craft running on a single domain name successfully. For my client, we've bought a second domain name for a mini site for SEO purposes, some of which we'd like to use Craft on. What ...
1
vote
0answers
240 views

Optimization on GridServer (gs)

How anyone have any server or database optimization recommendations for running Craft CMS on MediaTemple's GridServer (gs)? Since it's a shared server, I know there's not as much as you could do with ...
1
vote
0answers
3k views

How to Fix Error 403 Attempting to Access Craft Admin Page Using XAMPP

I'm using XAMPP for the very first time and am also new to Craft so any help with this issue would be very much appreciated. I'm attempting to set-up a local dev environment through XAMPP and then be ...
0
votes
0answers
22 views

How to configure Craft to work with Redis replicas?

We have an existing load balanced / HA deployment of Craft 3.4, to which I want to add support for the redis replica we have available, but I can't work out how to correctly configure this in config/...
0
votes
0answers
75 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
0
votes
0answers
30 views

Craft CMS Multisites with 100++ Sites

We're lookin for someone having experience with having A LOT OF MULTISITES in a Craft CMS installation? A project of ours has currently 68 Multisites, but approx. 50 more to come. We're looking for ...
0
votes
0answers
46 views

Intermittent internal server error

I'm experiencing a very intermittent internal server error on a Craft site running 3.3.7. The message "An internal server error occurred" appears every now and then when trying to load a page. The ...
0
votes
0answers
22 views

Homepage shows but everything else puts out 404 errors

My homepage template is loading but everything else puts out a 404 error (server error). Can't access the control panel or any other sites. I have transferred my my project from a local server to a ...
0
votes
0answers
143 views

404 shows “Internal Server Error” only on staging environment

Might be a duplicate, but couldn't find this exact question here. I have a pretty basic 404.twig template that should be catching things, as described here: https://docs.craftcms.com/v3/routing.html ...
0
votes
0answers
38 views

Nginx config - cachebusting rewrite for multiple server blocks/domains?

So I have a Craft CMS multi-site setup on a Forge-managed VPS... (and oh boy I wish there was more documentation on setting this up, huge thanks to Philip for helping me get to this point) The ...
0
votes
0answers
32 views

Windows permissions error

Anyone experienced with issues setting up Craft on Windows server - getting phperror logs within Craft stating: The directory is not writable by the Web process for cpresources I have got the hosts ...
0
votes
0answers
226 views

Large file upload, 500 server error

We've a Craft 3 site hosted with Digital Ocean (Serverpilot set-up) with the DNS routed through Cloudflare. The client has experienced issues uploading large ZIP files to (c140MB), returning a 413 ...