Questions tagged [server]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
108 views

500 Error after Dreamhost server upgrade

Dreamhost upgraded my VPS overnight and I immediately got a 500 error. The site currently works on another Dreamhost VPS (the original below) and an Arcustech server. After checking the error logs I'm ...
1
vote
1answer
48 views

Server down (timeout) when optimize bundle of image (Image Optimize Plugin)

I try to use the Image Optimize plugin to optimize the image with default Craft Transform. There are lots of images to be optimized at the same time, I keep having the issue of server down. Here is ...
1
vote
2answers
54 views

What server settings would be responsible to debug "The process has been signaled with signal 9" errors?

We're running Craft in an AWS environment that is configured using CentOS 7, Apache 2.4.x, PHP 7.4.x, PHP-FPM and we've noticed many of our queued tasks fail (sometimes only 8-10 minutes into the ...
2
votes
2answers
480 views

Craft CMS not working on server

I had my Craft CMS site working on my local hosting. I then moved it over to bluehost VPS. I moved the database and uploaded the files to the server. I've put the database user information in the .env ...
1
vote
1answer
69 views

MySQL error when sync database using Craft Script from Craft Nitro

I'm trying to sync the database from staging to local (Craft Nitro) using the craft-script as per the article. Here is the error message, Usage: mysqldump [OPTIONS] database [tables] OR mysqldump [...
0
votes
0answers
42 views

SyncDB with Nitro Fail to sync database from local to staging

I'm trying to sync the database for my local Craft Nitro to the staging environment using SyncDB. Here is the error, [2021-06-04T15:49:51.623536+08:00] sync.NOTICE: Starting database sync [] [] [2021-...
0
votes
0answers
30 views

A server error occurred on drag and drop of entries

I am getting 'A server error occurred' at the top of the screen when trying to drag and drop entries in a structure. It happens only on my live site, local site works fine. I have tried to change the ...
1
vote
1answer
42 views

Configure path craft uses for composer and php

Is it possible to configure the PATH to composer that craft is using? In a shared hosting (our server, lots of sites) php isn't available by default. It's provided via redhat software collections. ...
3
votes
4answers
1k views

Craft 3 - Recommended development environment for Windows?

I was wondering what people who are developing on Windows 10 are using as webserver environment in 2018? I have had ok results previously using ampps, but I'm having a lot of problems with Craft 3 as ...
1
vote
4answers
632 views

Less complicated local development w/Craft 3, is it possible?

I do not really care for WordPress, but one thing that it has going for is a dead simple local development environment. In fact, it free software called "Local". It took all of five minutes to get ...
0
votes
0answers
62 views

WebP transform >> AssetTransformException: Failed to generate transform with id of X

I'm trying to transform some images on my site from JPG to WebP. However, I am having a problem to do so on my production site. I get this error: 2021-01-27 16:13:40 [-][-][-][error][craft\errors\...
0
votes
0answers
58 views

Internal Server Error when updating slug

I'm getting an internal server error when I try to update the my entry's slug on prod, but not on dev or locally. It's happening across entries, it doesn't seem to be specific to a certain entry. Any ...
0
votes
0answers
42 views

Certificate problems when sending mail via smpt (tream_socket_enable_crypto(): SSL operation failed with code 1)

I know there were already a lot of these issues on this board, but none solved mine, unfortunately. Be assured that I searched quite a lot (for hours) but could not solve it. I hope I have not ...
1
vote
1answer
58 views

Directories and files being created by "root" user, inaccessible to CMS

I'm new to Craft and have been asked to support a live site that is running on it. I've run into a problem that seems to be due to files on the server being created by the wrong user. The vast ...
1
vote
1answer
209 views

500 Internal Server Error when accessing admin

I just get a server error when trying to access /admin, or any other URL. This is a completely new installation on a staging server. The 'Welcome' page shows OK. I'm guessing this is a .htaccess ...
2
votes
2answers
4k views

Login - Bad Request: The CSRF token could not be verified

I have just deployed an existing site to a new server. As the DNS is not pointing there yet, I have simply edited my /etc/hosts file on my Mac to point to the IP address for testing. Whilst checking ...
0
votes
0answers
190 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
2
votes
1answer
1k views

Undefined index: siteSettings when updating entry types

I'm receiving an Undefined index: siteSettings when trying to save changes to entry types (both new and existing). Of course, this is only occurring on a production server - local server with up-to-...
1
vote
1answer
136 views

Why is Craft storing so much temporary files inside the server tmp folder?

For several websites (Craft CMS 2 & 3), servers ran out ot storage even if these websites were not storing a lot of assets. After looking for why, I ended up in the temporary (tmp/) folder of ...
2
votes
1answer
199 views

How does the Craft CMS built-in web server works?

I just found this while using ./craft help in the Craft CMS command line utilities: - serve Runs the PHP built-in web server. serve/index (default) ...
0
votes
0answers
243 views

404 shows "Internal Server Error" only on staging environment

Might be a duplicate, but couldn't find this exact question here. I have a pretty basic 404.twig template that should be catching things, as described here: https://docs.craftcms.com/v3/routing.html ...
1
vote
1answer
16 views

layout file changes get deleted overnight

I've had a problem for a few weeks whereby any changes to a layout.html file get deleted overnight on a server. As a sanity check I just want to make sure there isn't anyway this can be done by Craft? ...
1
vote
1answer
181 views

Craft 3 Upload To Bluehost - Index.php outside root issue

I'm having issues uploading my craft3 site to Bluehost. I've uploaded all the files, ran composer install and it does actually work. However when I go to my domain it shows the raw files/folders and ...
3
votes
2answers
7k views

Craft 3: 500 Internal Server Error when trying to install on server

For the last 3 days i've been trying to install Craft CMS 3 on my server. I'm using 1&1 internet, have FTP uploaded all the files, changed the permissions for the folders and files to the right ...
1
vote
2answers
286 views

Updating Asset Indexes Fails with TemplatesController Not Found Error in Craft Logs

Client wants to be able to upload a 90MB .mp4 file to a local asset folder, that understandably throws a 'General error: 2006 MySQL server has gone away'. I uploaded the file directly to the server ...
1
vote
0answers
281 views

An unknown error occurred message, only on live server

Please can anyone give me some pointers. Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. ...
0
votes
0answers
46 views

Windows permissions error

Anyone experienced with issues setting up Craft on Windows server - getting phperror logs within Craft stating: The directory is not writable by the Web process for cpresources I have got the hosts ...
2
votes
1answer
739 views

Migrating Server - Craft isn't installed yet

I've set up a new Forge server and connected the repo to my site. I've also uploaded the database and copied over the db credentials to the dotenv file. However when I visit the site control panel ...
0
votes
0answers
275 views

Large file upload, 500 server error

We've a Craft 3 site hosted with Digital Ocean (Serverpilot set-up) with the DNS routed through Cloudflare. The client has experienced issues uploading large ZIP files to (c140MB), returning a 413 ...
1
vote
1answer
1k views

Internal Server Error for admin login and dashboard

I deployed a Craft 3 site and the site is fine, however when I try and go to /admin to login I get a Craft "Internal Server Error - Server Error" message and can't access the dashboard. Any ideas ...
1
vote
1answer
478 views

When saving an Entry, I receive a JSON response rather than returning to the Entry's edit page

Craft Version: 3.0.4 Web Server: Apache + Nginx proxy Recently I've been working on a couple of Craft 3 projects for deployment on my institution's web servers. In the past, I've successfully ...
19
votes
4answers
4k views

Can I run one Craft install on multiple domains and/or subdomains?

Is it possible to have one Craft install running multiple domains and/or subdomains? For example having the same Craft install running a blog Channel at blog.example.com and also an about Single at ...
1
vote
1answer
2k views

Get "Internal Server Error Undefined index: handle"

Hi I was trying to save the matrix field and got the error: "Internal Server Error Undefined index: handle" I checked out all fields' handles and they are all in place. Is there any reason causing ...
6
votes
4answers
4k views

All images uploading... except JPG files

No idea why but my local install of CraftCMS (in a MAMP environment) won't let me upload JPGs. PNG, GIF, even TIFF works (just for the heck of it). When I select the file in the browser dialog, it ...
1
vote
1answer
2k views

Excessive resource usage / virtual memory size

Our server is generating lots of emails that follow this template: subject: lfd on host.foo.com: Excessive resource usage: foo (24056 (Parent PID:16356)) body: Time: Wed Jan 31 11:31:20 ...
1
vote
1answer
95 views

Making a base url without /public

I'm creating a site that works now at www.mysite.com/public/ I would love to get to drop the /public off the url so it is: www.mysite.com Does anyone know how to do this? Thank you!
0
votes
1answer
228 views

Code shows instead of homepage

A website I built frequently throws up the following code instead of the homepage: <?php // Path to your craft/ folder $craftPath = '../craft'; // Do not edit below this line $path = rtrim($...
3
votes
1answer
605 views

Problems setting up a local site

I am running into problems with virtual hosts while trying to run Craft locally. My setup was working perfectly and after a restart of my mac I get error messages and I don't understand why. I am ...
2
votes
1answer
2k views

Internal Server error during install

I've done a few installs of Craft and never had a problem. I'm currently trying to do an install on a new server under a subdmomain and getting the following results… This results in 404 http://...
9
votes
4answers
5k views

Getting $craftPath error on server trying to get Craft running

Trying to get my Craft site running on my server for the first time. Getting the error Could not find your craft/ folder. Please ensure that $craftPath is set correctly in /var/www/dev.mysite.com/...
1
vote
1answer
85 views

Visitor drop off since moving over to Craft CMS

Hi I've been managing my clients Wordpress site for over 7 years now and redesigned it a few times. Recently, I convinced my client to move over to Craft CMS and 4 months ago we went live with a new ...
1
vote
1answer
159 views

Optimizing With Http2 In Mind

My main config is Apache/Centos 7/WHM/Redis/OPCache/PHP7.1/MariaDb/PHP-fpm/Http2 and have optimized my server to a great degree. It's a 32GB dedicated HexaCore. I have worked really diligent to get ...
2
votes
2answers
148 views

compiled_templates folder using up inodes on Ubuntu 14.04 Server

My server has gone down twice in the last 3 weeks because of an excessive number of files being created in the compiled_templates folder. This causes all of the inodes on our server to be used up ...
2
votes
3answers
3k views

HTTP ERROR 500 after move to live

I moved a site from staging to live. Prior to moving, I logged in to the Craft admin and cleared the caches. I copied the db to the new one and moved the folders like so… from… home/subdomains/craft ...
1
vote
1answer
504 views

Updated the PHP on server. Getting this error: Please ensure that $craftPath is set correctly

I am running Amazon Ec2 instance and tried updating the PHP on the site using this guide: http://brianshim.com/webtricks/update-amazon-ami-php5-3-to-php5-4/ And now this is the error I am receiving: ...
1
vote
1answer
162 views

Installing Moodle to a Craft CMS server

I was wondering if anyone had any experience in installing Moodle to a server that already had a CraftCMS website installed onto it? I've followed the instructions on the Moodle Installation Guide (I ...
2
votes
1answer
198 views

Sub-pages not loading on Windows server

I just moved a site over to a Windows server, and my homepage loads fine, but sub pages are not loading. I just get an error message that the connection was reset. Adding index.php to the url doesn't ...
2
votes
1answer
50 views

finding core dumps in public root

Am suddenly finding lots of core..xxx files dumped in the root of my site. In devMode cant see any issues. Assume this is serious issue and memory dump? Where to start? Logs have loads of stuff but ...
4
votes
2answers
692 views

Self-hosting requirements/scaling

Is there any reason the mySQL, CraftCMS, and assets/images/content can't all live on the same server, assuming the server is appropriately sized and backed up? Are there any sizing/scaling guidelines?...
2
votes
1answer
284 views

Setting up Craft on Linode Using Ubuntu

I'm setting up a Craft site on a Linode server has anyone had any experience with this? I'm struggling with which owner and user to set the var/www/html folder to with chown and what chmod settings to ...