Skip to main content

Questions tagged [nitro]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2 votes
1 answer
81 views

Can't upgrade to v4.x after migrating from nitro to ddev – db connection weirdness

I've been through the following steps on a local instance of a Craft 3.x project: Followed Migrating from Craft Nitro to DDEV and got the instance running on DDEV Updated to latest version of Craft 3:...
Jonathan Schofield's user avatar
1 vote
2 answers
103 views

Class not found when migrating to DDEV from Nitro

I'm migrating from Nitro to DDEV, and on this particular project I'm running im some problems with a custom module. I'm getting this error: Error Class "modules\bcsmodule\services\TimeslotService&...
wesley's user avatar
  • 51
2 votes
2 answers
178 views

Nitro: how risky is it to dev using MariaDB and then go live with MySQL?

Nitro does not support MySQL for Apple Silicon, but you can use MariaDB interchangeably. I'm using an Apple Silicon computer, and my server run with MySQL only. However, as read in the Craft Database ...
Romain P.'s user avatar
  • 1,852
2 votes
1 answer
182 views

500 Internal error on admin - session related

I am working on trying to get a local copy of a site working, but ran into an issue where the front end is working, but the admin page is not responding when I try to login. This site is Craft 3.7.44 ...
Rodney Little's user avatar
3 votes
1 answer
492 views

DevMode set to true, but doesn't appear to work locally

I'm having trouble getting DevMode to work locally. I'm using nitro. I have this set in my .env file... ENVIRONMENT=dev ... and my general.php file looks like... <?php /** * General Configuration ...
cringe002's user avatar
1 vote
1 answer
66 views

Nitro unable to init or start after Docker update

I did an update of Docker and to my surprise all my containers/images/etc were gone. So I figured I simply needed to init and start nitro again. When attempting to start or init it keeps resulting in ...
cballenar's user avatar
  • 1,409
2 votes
1 answer
396 views

Local craftCMS is running extremely slow on Windows with WSL2

I am running CraftCMS locally but it's extremely slow. What does extremely slow mean: login takes 10-15 seconds clicking any admin screen takes 10-15 seconds viewing an entry takes 10-15 seconds ... ...
Álvaro Franz's user avatar
0 votes
0 answers
27 views

Modifying webroot in Nitro

I've just changed the webroot for one of my Craft Nitro sites. After running nitro apply and it completing. I'm getting 404 - Not Found Nginx Am I doing something wrong here? Is there a command I'm ...
JMKelley's user avatar
  • 1,416
1 vote
1 answer
83 views

Getting 503 error when setting up a site with CraftCMS nitro

I am experimenting with Nitro and getting the 503 db error when trying to connect db. I am able to connect to my GUI (Sequel Ace) but not get the browser connecting. My db.php is as follows: return [ ...
peco60052's user avatar
1 vote
1 answer
200 views

Deploy Craft CMS site to VPS for the first time

I'm completely new to deploying a Craft CMS to a web server and don't know where to start. I have self taught experience in front-end development but I'm lost when it comes to anything deployment/...
Sam's user avatar
  • 11
5 votes
1 answer
234 views

How to use Browsersync within Craft Nitro

I have a Craft CMS site running locally, using Craft Nitro. I want to use the nitro node container, rather than my own, which works beautifully except with regard to browsersync, and I'm not sure what ...
Clara B's user avatar
  • 151
1 vote
1 answer
112 views

Nitro / Docker: containers missing

Posting this as a problem and then answering it in case it helps someone else. The sequence of events: I had 3 sites running under Craft Nitro 2 and Docker 3.x I became aware that Docker had moved to ...
Jonathan Schofield's user avatar
2 votes
1 answer
327 views

Redactor not working: Unable to find component class ''craft\redactor\Field''

I duplicated an existing site, and mostly everything is working, but I'm having a hard time with the Redactor plugin. In any field that uses it, Redactor is not enabled, and there's this message: ...
mauricio's user avatar
  • 187
1 vote
1 answer
368 views

Why do Postgres schemas different from "public" sometimes not work with Craft (DDEV / Nitro)

Due to limits in the production environment of our website, we can not use Postgres' standard schema public. Therefore we configured something different (craftcms) in .env: DB_DRIVER=pgsql DB_SERVER=&...
Matthias Redl-Mann's user avatar
0 votes
0 answers
158 views

Disable php-redis in Nitro

Due to a limitation at a Client's server environment (they do not have php-redis enabled) I need to imitate that setup with Nitro. I want to disable PHP's redis extension (C) and use https://github....
Matthias Redl-Mann's user avatar
2 votes
3 answers
406 views

SSL certificate for Docker container in Nitro 2 has expired: what to do?

I created a Docker container 3 months ago. I’ve only just come back to it and find its SSL certificate has expired. I can find nothing on what is best to do. Is it best to reissue the certificate? If ...
Jonathan Schofield's user avatar
2 votes
3 answers
264 views

Enupal Snapshot: Fail to save setting for Craft Nitro with status code '127'

I keep having issues when trying to save the settings for Enupal Snapshot at Craft Nitro, Below is the error message I found at the log file, [enupal\snapshot\Snapshot::error] Something went wrong ...
Lee's user avatar
  • 139
1 vote
1 answer
196 views

MySQL error when sync database using Craft Script from Craft Nitro

I'm trying to sync the database from staging to local (Craft Nitro) using the craft-script as per the article. Here is the error message, Usage: mysqldump [OPTIONS] database [tables] OR mysqldump [...
Lee's user avatar
  • 139
0 votes
0 answers
59 views

SyncDB with Nitro Fail to sync database from local to staging

I'm trying to sync the database for my local Craft Nitro to the staging environment using SyncDB. Here is the error, [2021-06-04T15:49:51.623536+08:00] sync.NOTICE: Starting database sync [] [] [2021-...
Lee's user avatar
  • 139
0 votes
0 answers
266 views

When Using Nitro Add and it gets to the choose database engine question, the choices arent there and typing in doesn't work

I'm totally new at craft cms and nitro and I'm having trouble adding a new site. When I get to the part where it asks you which database engine to use there's no options there to choose from and ...
Claire Browne's user avatar
0 votes
0 answers
263 views

Template and other files do not update with nitro

I am using nitro for the time. Sometimes some templates or other files do not update after saving. It feels very random and I cannot exactly reproduce it. At some point they just don't update. I can ...
Philip's user avatar
  • 21
1 vote
1 answer
909 views

First steps with Craft Nitro: hostname not working after successful install

I installed Docker and Nitro and successfully used nitro create <folder-name>, and ended up with the 'Welcome to Craft CMS!' message. I cded into the new folder and invoked ./craft setup, which ...
Jonathan Schofield's user avatar
3 votes
1 answer
667 views

Invalid Configuration Error in Craft CMS 3 using Nitro 2

I'm getting into Nitro 2 and so far loving it. I decided to create a scaffolding project to jump start other projects. Along the way, I ran into this error: Invalid Configuration – yii\base\...
cbad's user avatar
  • 135
2 votes
1 answer
713 views

Folder Permissions denied with Nitro

I’m getting this error when accessing/writing images. It’s only just come along suddenly after one or a couple of updates. League\Flysystem\Exception Impossible to create the root directory "/...
Simon Clayson's user avatar
0 votes
0 answers
47 views

Initialisation, failed to determine IP address

Thought I'd give Nitro a whirl but can't get past initialisation. Initialize the primary machine now? [yes] How many CPU cores? [2] How much memory? [4G] How much disk space? [40G] Which version of ...
Ian Ebden's user avatar
  • 894
1 vote
1 answer
201 views

There are no sites in the config file on nitro add

When i try nitro add command to they return "There are no sites in the config file" what should i do? Unable to locate a webroot, setting to web. Enter the webroot [web] web Added tutorial....
Pedro's user avatar
  • 11
1 vote
0 answers
82 views

nitro Error: stat no such file or directory

I've gone over the way to set up Nitro over and over again but I keep running into the same problem. I even destroyed nitro and deleted everything and restarted to see if I just did something wrong. ...
Darryl Hardin's user avatar
2 votes
1 answer
440 views

Craft Nitro PHP extension ext-zip * is missing

I'm not particularly tech minded so MAMP has served me well for a good while. However I more recently decided to give Craft Nitro a try. I got everything (Multipass and Nitro) set up really easy. I ...
Martin's user avatar
  • 1,203
2 votes
2 answers
969 views

How to use SSL for local development with Nitro?

I've created a new Craft CMS project and installed Nitro to run everything in a VM. Now I'm wondering if it's possible to use SSL for the local domain? I didn't found anything in the documentation.
Slevin's user avatar
  • 123