Questions tagged [mysql]

The tag has no usage guidance.

28 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2
votes
1answer
198 views

Running Craft CMS 2 on MySQL 8.0+ (Any major considerations?)

Yes, that's not a typo. This is for a Craft 2 site (long story). Because MySQL 5.6 is EOL in a few weeks, I am validating how feasible it can be to run under MySQL 8.0, there's not really any option ...
1
vote
0answers
27 views

Order element query by number of related categories

I'm building an entry template that displays related entries to the current entry. To be related, an entry needs to be the same type as the current entry and share at least one category in one of two ...
1
vote
0answers
21 views

Building a yii query for Connect plugin

I'm using the Connect plugin by Andrew Welch to get some data from an external database. Somewhere in the data, I need data from another related table. The way I'm doing this now is like this: {% set ...
1
vote
0answers
72 views

Craft warning: Tried to release a savepoint, but it does not exist

I'm working on a plug-in for Craft 3. For this plug-in is a migration is needed. When this migration runs and adds the entries, fields, and groups then the following warning occurs in the logs. [...
1
vote
1answer
32 views

Database driver & version after server upgrade

The server I'm running Craft installations on just got an upgrade to Ubuntu 20 with MariaDB 10.5 Before MySql 5.7 was used. When I look at the System Report in the Craft CP, it says: Database driver &...
1
vote
1answer
57 views

Craft Setup 3.6.5.1 with MYSQL with SSL version 5.7.29

I'm trying to install Craft version 3.6.5.1 with MYSQL version 5.7.29 from Azure. While setup it fails with the following error Testing database credentials ... failed: SQLSTATE[HY000] [9002] SSL ...
1
vote
0answers
24 views

Craft cannot backup - Azure

When attempting to backup with Craft, the system returns the following error: The shell command "mysqldump --defaults-extra-file="D:\local\Temp\my.cnf" --add-drop-table --comments --...
1
vote
1answer
692 views

ERROR 1370 (42000) alter routine command denied to user

I am trying to upload my DB using MySQL Workbench but am getting this error: ERROR 1370 (42000) at line 4534: alter routine command denied to user 'detectalocal'@'%' for routine 'detectalocal....
1
vote
1answer
400 views

Can't Backup Database - "Failed with exit code 1" (WAMP Server)

I'm running Craft 3 on a local windows machine, but every time I try to update certain plugins (or Craft itself) I get a message "Couldn't back up the database. How would you like to proceed". The ...
1
vote
0answers
115 views

Database Query in debugger consistently showing over 2000ms

In trying to optimize my Craft 3 site, I have discovered that it's apparently taking longer than expected to query my database. The duration for the apparent culprit is typically between 1900 and ...
1
vote
0answers
29 views

Paginate entries based on related status

So, let's assume I have two channels. events and movies, being events the screening time of each movie. In the admin, in the event entry, you can select one movie. The movie could be disabled. The ...
1
vote
0answers
79 views

Creating coupon using Charge 2 plugin

I just updated the Charge 2 plugin to latest (version 2.2.1) and when I try to create a new coupon, I get this error: CDbException CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: ...
1
vote
0answers
102 views

Problems while setting up a cross region Craft website in AWS

In order to create a cross region setup for my craft website, I've created a read-only replica of my RDS DB from North Virginia region to Canada Central region. I'm facing the internal server error ...
1
vote
0answers
291 views

Error while sending QUERY packet in continuously running process

I'm using php-resque + Redis to get queues/workers into Craft, and so far I've managed to get it all running. My test worker looks something like this: <?php namespace Craft; class JobHandler { ...
0
votes
0answers
30 views

Error trying to push Craftcms DB from staging to Production

I am having a problem trying to use command php craft copy/db/up prod, when craft starts to push the DB to the production stage it stops at halfway and the website goes down! the error in MySQL is ...
0
votes
0answers
12 views

Craft 2 cannot connect to db after pw reset

This is a MySql/Craft question. I recently had difficulty in gaining access to MySql Workbench (which I use to access the MySql database to which my CraftCMS app connects). After numerous attempts, ...
0
votes
0answers
28 views

SQL Queries Performing Full Table Scan

Per the title, our application's db query has from time to time pegged our CPU to the max and taken down the site. Our site has gotten quite large in terms of content and trying to figure out how best ...
0
votes
0answers
37 views

Certain Queries Pegging CPU and Causing Production Site to go Down

I read these two posts MySQL CPU pegged on specific query Poor performance on midsized site / Queries without index? and and am in a similar situation although for us it actually breaks our site and ...
0
votes
0answers
42 views

SyncDB with Nitro Fail to sync database from local to staging

I'm trying to sync the database for my local Craft Nitro to the staging environment using SyncDB. Here is the error, [2021-06-04T15:49:51.623536+08:00] sync.NOTICE: Starting database sync [] [] [2021-...
0
votes
0answers
38 views

Very slow `INSERT` transactions on the resourcepaths table

After a recent update (Craft 3.4.x to 3.5.x) I'm seeing some suspiciously slow response times in relation to INSERT actions on the resourcepaths table. Some in the upwards of a half second for a ...
0
votes
0answers
26 views

Possible to clean up elements_sites?

We have a website that has around 80k users per month and we're updating around 1k entries per night due to stock updates. The site's been live for almost 2 years and the CMS has become really slow ...
0
votes
0answers
30 views

Saving to db with devMode true works, but not when false

// Upload and save as temp file $request = Craft::$app->request; $file = UploadedFile::getInstanceByName('file'); $tempPath = $file->saveAsTempFile(); // Create as permanent asset $folder = ...
0
votes
1answer
57 views

How do I upgrade the MYSQL database from Craft 2 to Craft 3 on GoDaddy

How do I upgrade my MySQL DB for a Craft 2 site to Craft 3. I don't have access to the SSH server or use of Composer, so I have to move files via FTP and do everything manually. My client is on ...
0
votes
0answers
318 views

Control panel - Entry indexes very slow

Craft CMS 3.3.15 PHP 7.1.3 MySQL 5.5.42 I have a structure with 360 entries. Right now in the CP it takes 3.5 - 10 seconds to load the first 50. And another 3.5 - 10 seconds for every additional ...
0
votes
0answers
89 views

Unable to delete Entry: Numeric value out of range

I have a Structure section that I converted to a Channel. I then tried to delete an Entry Type from the Control Panel and get the following error: {"error":"SQLSTATE[22003]: Numeric value out of ...
0
votes
0answers
106 views

Emojis on Craft 3 front office

I'm making a blog. I have a wheelform comments input type that needs to be stored as utf8mb4 in the local database. My MySQL database version 5.6 is configured to utf8mb4 in the database, tables, ...
0
votes
1answer
679 views

ERR_EMPTY_RESPONSE when accessing order data (MAMP)

I've got a local installation of Craft 3.0.37 and Craft Commerce 2.0.0-beta.15 running on MAMP. When completing an order, an empty response is given by the browser. The same thing happens when trying ...
0
votes
0answers
321 views

Setting up Craft 3 database backup command for a remote database server

I have my Craft 3 database on a separate server than my Craft webserver (load balancing) and when I use the download database backup function in Craft 3, it doesn't know where to look. I haven't ...