Questions tagged [multi-site]

The tag has no usage guidance.

27 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1
vote
0answers
14 views

How to auto disable “Enabled for Site” for certain sites (or groups) when creating a new entry

We have a mutli-country/language website with Craft 3 for many countries/languages. When we create an entry (ecommerce product to be exact) in the English sites we dont want to enable it for other ...
1
vote
0answers
44 views

Craft 3 multisite: site specific config

I'm trying to do something like this in general.php config for a multi-site setup: // ... 'production' => array( 'myVariable' => array( 'site1Handle' => '111', '...
1
vote
0answers
67 views

Copy Content from original site to new site (multi-site)

I have an English site with content, but now I need to create another site in French. So I'm setting up a multisite for my Craft install. I want to copy over all my English content over to my new site ...
1
vote
1answer
39 views

Add field to /settings/sites/new (multi-site)

I would like to add some fields to the site creation on the control panel settings. I know you can add globals for each site, but I think it would be a better process if I could add additional fields. ...
1
vote
0answers
65 views

Multi site live preview not working on index page

I'm on Craft 3.1.17.2 My multisite setup is using different domains. If I'm on a.com, I can Live Preview everything on b.com fine, except the homepage. I get the error Access to XMLHttpRequest at '...
1
vote
0answers
90 views

Craft 3 language switcher with same domain

Is it possible to create a multi language website in same domain? In the admin settings, I created a second site with the same domain, but with a different site language. templates/ ├── index.twig ...
1
vote
0answers
55 views

Correct Multisite MultiLanguage Approach

I am having a website with 4 languages and has two main sections B2B and B2C. So the final URLs will look like this: @web/b2b/de @web/b2b/ @web/de (b2c uses no indication in the link - is default) @...
1
vote
0answers
25 views

Route manipulating - set regioncode before language-code

I just finished the structure of a new site, now I am faced with the problem: "regions". I thought I can use categories for routing. Because I need: example.com/REGION/LANGUAGE/about-us or ...
1
vote
0answers
94 views

How can I create a section or category in Craft 3 that shares its entries (i.e. not multi-site)?

Is it currently possible to create a section or category that shares the same entries across multiple sites? I can currently create a section, and once I save an entry, it is propagated to all sites. ...
1
vote
0answers
488 views

Craft 3 Multisite: Template not found

I'm trying to set up a multisite with Craft 3, and the client wants a set up with URLs that look like foo.client.com, with foo.client.com/2018 and foo.client.com/2019. Right now, my index.php file ...
0
votes
0answers
51 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
0
votes
0answers
23 views

Super Table fields in Matrix blocks not automatically propagating content across sites

Please bear with me as I try to explain what's going on. Feel free to ask for more details if needed. Simply put, Super Table fields in Matrix blocks are giving me trouble for multi-site. I am ...
0
votes
0answers
17 views

Entry query in Twig setGlobals() not populating custom field data

I am using a custom Twig extension to add global variables: class MyGlobals extends \Twig_Extension implements \Twig_Extension_GlobalsInterface { public function getGlobals() { // This ...
0
votes
0answers
13 views

At what point is siteId set for orders?

I have an adjuster I am trying to get to work, but the order has to come from a specific site in order for the adjuster to be applied. The siteId is 2, but when I try to get the siteId from the Order ...
0
votes
0answers
15 views

Automatically replace strings in different language

We have sites for Germany and Switzerland that are pretty much identical but would like to cater to the spelling differences in Switzerland (namely replacing "ß" with "ss"). Is there any way to run ...
0
votes
0answers
41 views

How can i get the current applied route in CraftCMS?

I'm using a dynamic route that loads a template. I'm on a multisite setup with a language switch in the header menu. To be able to switch between sites or languages, the dynamic routes need to have ...
0
votes
0answers
34 views

Nginx config - cachebusting rewrite for multiple server blocks/domains?

So I have a Craft CMS multi-site setup on a Forge-managed VPS... (and oh boy I wish there was more documentation on setting this up, huge thanks to Philip for helping me get to this point) The ...
0
votes
0answers
16 views

How to create other sites entries with same data, when “Save blocks to other sites in the same group” is used

We have fields, including a matrix field, that is set to "Save blocks to other sites in the same group". This means when we edit our English group, only sites in that group are edited, so they all ...
0
votes
0answers
28 views

New locale showing content from default/main site (Craft 2)

I have a Craft 2 site I've inherited that is using locales for multiple sites (each with their own domains). When I set things up initially, I got all the locales working without issue. I've been ...
0
votes
0answers
24 views

Craft 3 Multi-site with no “default” site AND where control panel login route remains intact and additional directories not necessary

Maybe one of you can help me out? I've tried setting up a multi-language site with no "default site" as per Craft 3 Multi-site with no "default" site. So far so good, except the control ...
0
votes
0answers
22 views

How to use category page after setup multi-site

What is the category posting page, see the image. I created multi-site ex) affinity designer and affinity photo, but when I post any items on the category page. When I select affinity design or ...
0
votes
0answers
35 views

How can i filter on site and locale in the element API

I have multiple sites and locales enabled. How can filter on entries only from a given site and locale? Here's what I have. As you can see I already have a the $site and $locale variables, but I don'...
0
votes
0answers
150 views

Queue “Failed”, with Attempting to save an element in an unsupported site

I have many sites for different countries and languages. They are grouped by language. I have a matrix field setup to "Save sites to other sites in the same site group". We imported all the sites ...
0
votes
0answers
68 views

Setting “enabled for site” from a plugin

I have entries that propagate across multiple sites. Default value is enabled in general but disabled for all sites. I want it to be enabled for the site to which it was originally added (while ...
0
votes
0answers
15 views

How to set product types to only be available in the site they were created in?

We have many sites and several sites are order by groups. For Entries, we have setup Sections to "Save entries to all sites enabled for this section", so every Site has the same entries, and we can ...
0
votes
0answers
27 views

Subsites not found when running Craft 3 on shared hosting

On most shared hosting, you can't set the webroot. As an alternative, a rewriterule to the web folder can do this. Could be something like RewriteRule ^(.*)$ web/$1 [L]. This works on main sites in ...
0
votes
0answers
36 views

Bad request on form submissions

Could my sudden bad requests on form submissions be linked to defaultCookieDomain and multi site use with separate add on domain? We added defaultCookieDomain as live preview wasn't working - didnt ...