Questions tagged [multi-site]

The tag has no usage guidance.

30 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1
vote
0answers
8 views

How to auto disable “Enabled for Site” for certain sites (or groups) when creating a new entry

We have a mutli-country/language website with Craft 3 for many countries/languages. When we create an entry (ecommerce product to be exact) in the English sites we dont want to enable it for other ...
1
vote
0answers
32 views

Craft 3 multisite: site specific config

I'm trying to do something like this in general.php config for a multi-site setup: // ... 'production' => array( 'myVariable' => array( 'site1Handle' => '111', '...
1
vote
0answers
45 views

Copy Content from original site to new site (multi-site)

I have an English site with content, but now I need to create another site in French. So I'm setting up a multisite for my Craft install. I want to copy over all my English content over to my new site ...
1
vote
1answer
30 views

Add field to /settings/sites/new (multi-site)

I would like to add some fields to the site creation on the control panel settings. I know you can add globals for each site, but I think it would be a better process if I could add additional fields. ...
1
vote
0answers
54 views

Multi site live preview not working on index page

I'm on Craft 3.1.17.2 My multisite setup is using different domains. If I'm on a.com, I can Live Preview everything on b.com fine, except the homepage. I get the error Access to XMLHttpRequest at '...
1
vote
0answers
82 views

Craft 3 language switcher with same domain

Is it possible to create a multi language website in same domain? In the admin settings, I created a second site with the same domain, but with a different site language. templates/ ├── index.twig ...
1
vote
0answers
46 views

Correct Multisite MultiLanguage Approach

I am having a website with 4 languages and has two main sections B2B and B2C. So the final URLs will look like this: @web/b2b/de @web/b2b/ @web/de (b2c uses no indication in the link - is default) @...
1
vote
0answers
23 views

Route manipulating - set regioncode before language-code

I just finished the structure of a new site, now I am faced with the problem: "regions". I thought I can use categories for routing. Because I need: example.com/REGION/LANGUAGE/about-us or ...
1
vote
0answers
94 views

How can I create a section or category in Craft 3 that shares its entries (i.e. not multi-site)?

Is it currently possible to create a section or category that shares the same entries across multiple sites? I can currently create a section, and once I save an entry, it is propagated to all sites. ...
1
vote
0answers
456 views

Craft 3 Multisite: Template not found

I'm trying to set up a multisite with Craft 3, and the client wants a set up with URLs that look like foo.client.com, with foo.client.com/2018 and foo.client.com/2019. Right now, my index.php file ...
0
votes
1answer
20 views

Is there a way to avoid content duplication on multi site setup?

I have just crated a multi site according to the instructions on Crafts page. Lets just say I have: siteone.com with template forlder templates/siteone sitetwo.com with template forlder templates/...
0
votes
0answers
31 views

How can i get the current applied route in CraftCMS?

I'm using a dynamic route that loads a template. I'm on a multisite setup with a language switch in the header menu. To be able to switch between sites or languages, the dynamic routes need to have ...
0
votes
0answers
18 views

Nginx config - cachebusting rewrite for multiple server blocks/domains?

So I have a Craft CMS multi-site setup on a Forge-managed VPS... (and oh boy I wish there was more documentation on setting this up, huge thanks to Philip for helping me get to this point) The ...
0
votes
0answers
9 views

How to create other sites entries with same data, when “Save blocks to other sites in the same group” is used

We have fields, including a matrix field, that is set to "Save blocks to other sites in the same group". This means when we edit our English group, only sites in that group are edited, so they all ...
0
votes
0answers
26 views

New locale showing content from default/main site (Craft 2)

I have a Craft 2 site I've inherited that is using locales for multiple sites (each with their own domains). When I set things up initially, I got all the locales working without issue. I've been ...
0
votes
0answers
20 views

Craft 3 Multi-site with no “default” site AND where control panel login route remains intact and additional directories not necessary

Maybe one of you can help me out? I've tried setting up a multi-language site with no "default site" as per Craft 3 Multi-site with no "default" site. So far so good, except the control ...
0
votes
0answers
21 views

How to use category page after setup multi-site

What is the category posting page, see the image. I created multi-site ex) affinity designer and affinity photo, but when I post any items on the category page. When I select affinity design or ...
0
votes
0answers
19 views

How can i filter on site and locale in the element API

I have multiple sites and locales enabled. How can filter on entries only from a given site and locale? Here's what I have. As you can see I already have a the $site and $locale variables, but I don'...
0
votes
0answers
60 views

Queue “Failed”, with Attempting to save an element in an unsupported site

I have many sites for different countries and languages. They are grouped by language. I have a matrix field setup to "Save sites to other sites in the same site group". We imported all the sites ...
0
votes
0answers
61 views

Setting “enabled for site” from a plugin

I have entries that propagate across multiple sites. Default value is enabled in general but disabled for all sites. I want it to be enabled for the site to which it was originally added (while ...
0
votes
0answers
14 views

How to set product types to only be available in the site they were created in?

We have many sites and several sites are order by groups. For Entries, we have setup Sections to "Save entries to all sites enabled for this section", so every Site has the same entries, and we can ...
0
votes
0answers
17 views

How can I upload assets assigned to a specific site?

I have 2 sites, site A and site B. When I upload an asset to site A, the asset is also visible in site B. How can I upload an image to only site A or site B? I am looking for a similar behavior like ...
0
votes
0answers
21 views

Subsites not found when running Craft 3 on shared hosting

On most shared hosting, you can't set the webroot. As an alternative, a rewriterule to the web folder can do this. Could be something like RewriteRule ^(.*)$ web/$1 [L]. This works on main sites in ...
0
votes
0answers
57 views

How to sync/propagate entry titles in a site group?

I have created several site groups, e.g. English, Spanish and German. Within these are several sites and the fields are to translate per group. So within Spanish for example, all the content is the ...
0
votes
0answers
46 views

Craft 3 multi site random 404 error on other sites (localisation) except default

I'm having trouble with my multi site setup. The issue can be seen here As you can see, the page sometimes gives a 404 and sometimes shows the page. Most of the times it's the 404, but sometimes the ...
0
votes
0answers
19 views

Saving globals slow with lots of sites

I'm working on a craft site that has 188 locations. Each location has its own site. Normally I would create a channel entry for Locations, but each location (site) needs its own blog and pages. I ...
0
votes
0answers
20 views

Access all entries when selecting an entry on multisite setup

I have a Craft 3 multi site setup. For example: - Site A - Site B - Site C Only Site B has a blog (channel). So the channel 'Blog' is disabled for Site A and site C. Now, I want to link to a specific ...
0
votes
0answers
48 views

How can I copy the content of a site (multi-site)

I want to be able to copy the content of a site (within multi-site) to create another site with the same content. It looks like if I create a new site, I have to recreate all fields. I do want the ...
0
votes
0answers
32 views

Bad request on form submissions

Could my sudden bad requests on form submissions be linked to defaultCookieDomain and multi site use with separate add on domain? We added defaultCookieDomain as live preview wasn't working - didnt ...
0
votes
0answers
88 views

Multi-site throwing a 404 — but only on staging server

I inherited a site and upgraded it from 2 » 3.1. The site is in both EN and ES. There's a button to toggle between languages and it works fine on my dev environment. site.co/en serves up English and ...