People who code: we want your input. Take the Survey

Questions tagged [mcrypt]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
1answer
1k views

Can’t run Craft CMS on my local machine, keep getting message “The Mcrypt extension is required”

I try to run Craft on my local Windows server and I keep getting message: Can’t run Craft CMS :( Your server doesn’t meet the following requirements to run Craft CMS: The Mcrypt extension is ...
0
votes
0answers
1k views

Why doesn't Craft think the Mcrypt extension is installed?

I am running the latest version of Homestead, and have installed Mcrypt, but I am getting an error that it is not installed while trying to update a site. php7.0-mcrypt is already the newest version (...
0
votes
1answer
947 views

Laravel Homestead installation nightmare

I'm running Vagrant/Virtual Box on a Windows 10 host. I originally installed Craft on a Vagrant Scotch Box (https://box.scotch.io/). The admin panel was running a little slow so I tried installing in ...
1
vote
1answer
96 views

Mcrypt in Red Hat Enterprise

I'm working at a large organization, where the servers are managed by an IT department. I want to migrate some websites to Craft and asked the IT department to install Craft on a server. The IT ...
3
votes
1answer
364 views

Craft CMS on LEMP Stack (mcrypt not detected)

I have a LEMP droplet on digitalocean that I am trying to get working with Craft CMS. Strangely it does not seem to play nice with NGINX. Or maybe it's just me. After installation I am receiving the ...
1
vote
1answer
873 views

Mcrypt not recognized [closed]

I have nginx and PHP up and running. phpinfo() shows that mcrypt is installed and enabled. I was sure to sudo php5enmod mcrypt. However, Craft is still complaining the mcrypt isn't installed. What ...
0
votes
1answer
1k views

Your server doesn’t meet the following requirements to run Craft

Here's the error I get: "You have an insecure version of crypt installed. Please update PHP to 5.3.7 or later". I have PHP Version 5.3.2 installed on my Ubuntu server and cannot switch to a new ...
2
votes
2answers
1k views

Craft with the PHP Built-in server?

With PHP 5.4+ we get a built-in webserver, http://php.net/manual/en/features.commandline.webserver.php Has anyone had luck setting this up with Craft? It seems like it could be pretty straightforward,...