Questions tagged [image]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
24
votes
3answers
6k views

How can I automatically generate responsive images from a single hi-res asset?

I want to be able to upload a single high resolution image, and output a <picture> element that outputs it with a few different sizes and resolutions automatically (using Picturefill to sort out ...
4
votes
1answer
3k views

Image asset url is not being output

After going through the documentation I believe that this is the correct code to output the url for the asset field but its not working and I have no idea why. Please help! {% nav program in craft....
9
votes
2answers
5k views

Looping through images in a Asset field type

Sorry, this is kind of a newbie question, but I can't figure out how to loop trough all images in one image asset field supporting multiple images. The only way I have been able to output anything ...
4
votes
3answers
423 views

Can't resize image in Rich Text field since 2.5 update

after upgrade to 2.5, it seems it's not possible to click on the inserted image and resize it in the Rich Text Field. If you click it now, you directly get a popup to give in the Title, link or select ...
9
votes
1answer
553 views

Is there a way to find out if images (assets) are landscape or portrait?

In a current project we will list entries in a masonry-style grid view where the entry’s respective cover image should be styled differently based on their image format. Landscape vs. portrait and -- ...
3
votes
2answers
212 views

Using Image Transform as another custom field

I've created a section with a thumbnail image and also a dropdown to allow the user to select the transformation to apply to that image. I've pre-created all the asset transformations ready and this ...
3
votes
1answer
713 views

GIF animations garbled and static

When I upload animated gif assets to a Craft site, they end up static and corrupted, as so: (Original here.) My guess is that what's displayed is the last frame of the animation (which only contains ...
0
votes
1answer
173 views

Auto add Images to entry after ftp to server

I have a potential client (car dealership) where in their existing 12 year old site they daily upload an Excel file to add/update/delete vehicles in stock. One file for new vehicles and one for used. ...
6
votes
1answer
513 views

Is 'real crop' a possibility?

Ok, this is the first time I need this, but here's my question: If crop is selected for a transition, what you get is a scaleAndCrop. Is there a way to do a 'real' crop, so no resizing before ...
3
votes
1answer
307 views

Using the Redactor rich text field, how can I dynamically wrap my images with a fancyBox link (with attributes as parameters)?

I'm using fancyBox (from fancyApps, http://fancyapps.com/fancybox/), and I need to wrap my images added within the Redactor rich text field with a link that had an href to the image source + some ...
3
votes
3answers
4k views

Assets (images) return a 404 on the front-end

I have the following issue which I can't seem to wrap my head around. All images assets uploaded to Craft return a 404 not found on the front-end. Everything works fine in the admin CP though (...
2
votes
2answers
365 views

Using Focuspoint with eager loading

I'm using eager loading for retrieving some images for my gallery: {% set employments = craft.entries({ section: 'employments', with: ['photo] }) %} This works fine and I can see all images on my ...
2
votes
1answer
826 views

403 Forbidden Assets

I can't for the life of me figure out what's going on. When assets are added, they upload fine but when I add them to entries or try to view them in the browser, they won't display and show a 403 ...
1
vote
2answers
881 views

Is there any way to prevent Craft from doing anything with uploaded GIF assets?

I'm having an issue where Craft seems to change (significantly slowing down) the framerate of animated GIF assets on upload (this doesn't seem to be an image transform problem: if I add the file as an ...
1
vote
2answers
1k views

Image Transforms - Image not processed until second page refresh

I'm new to Craft, and am not sure whether I've got something weird happening or if what I'm experiencing is expected behavior. I notice that when I add new entries containing image assets that get ...