Skip to main content

Questions tagged [error]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
4 votes
1 answer
661 views

Locked out of my Account, how to get back in?

This really stressing me out! When trying to log back in to Craft CMS today after som time my password wouldn´t work. I have not changed it and when trying to reset the password I´m only getting: "...
jandersson's user avatar
4 votes
1 answer
175 views

Moving to another database: "Specified key was too long"

I am attempting to move the database from my local machine running MySQL 5.5.38 to my webhost running 5.1.70. However when I do so I get the following error on at least two tables. I am using a MySQL ...
Jack McKenzie's user avatar
3 votes
3 answers
2k views

unserialize(): Error at offset 0 of 60695 bytes

Hey guys I am getting this error: unserialize(): Error at offset 0 of 60695 bytes when i push a backup of my local db to my staging environment. I am using craft 3. Any ideas? Clearing the /storage/...
Lara Hilal's user avatar
3 votes
3 answers
4k views

HTTP ERROR 500 after move to live

I moved a site from staging to live. Prior to moving, I logged in to the Craft admin and cleared the caches. I copied the db to the new one and moved the folders like so… from… home/subdomains/craft ...
Howard Theriot's user avatar
3 votes
3 answers
1k views

cannot update Craft CMS - composer errors

I'm upgrading a site to 3.0.41.1 (not ready to go to 3.1) and when I do I get the following error. How do I resolve this? composer update craftcms/cms Loading composer repositories with package ...
CreateSean's user avatar
  • 1,983
3 votes
1 answer
831 views

Nesting level too deep when looping through matrix blocks

I'm running into a nesting level error when looping through matrix blocks, and I can't quite figure out what the problem is. The problem arises when I use a variable to track the type of the previous ...
Nick F's user avatar
  • 1,215
3 votes
1 answer
2k views

Returning errors into templates

When working with a custom form that posts to a plugin function - what's the best way to return errors that would be displayed like the forgot password code example below {% if errors is defined %...
Adam McCombs's user avatar
  • 1,695
3 votes
1 answer
271 views

Error: min/max value in number fields

Is there any reason why min/max value are limited to the following? [9999999999999] - Min is too big (maximum is 2147483647) I need to add ISBN numbers which are 13-digits. Is there a reason for ...
Rob's user avatar
  • 865
2 votes
2 answers
2k views

“Request missing required body param” error when creating entry on front end

I get an Request missing required body param error when trying to create a new entry on the front end. All required fields are being filled. Nothing changed except the craft version. Craft version is ...
Marcus Scheller's user avatar
2 votes
1 answer
456 views

Get 404 Error When Going to mydomain.com/news

Craft newbie here. I have been playing with craft now for a few weeks and built out a couple of pages. I am really liking it this CMS. The one small problem that I just noticed however, is when I ...
Vince M.'s user avatar
2 votes
2 answers
2k views

Control Panel or admin dashboard not found

I have installed craftcms 3 on my localhost. It got installed and the following screen appeared: If I click on Control Panel I see the following screen
falcon's user avatar
  • 23
2 votes
2 answers
2k views

Action URLs from CP to a Craft 3 plugin controller

I'm working on my first Craft 3 plugin and want to add some buttons to my plugin's control panel section which post form data to a controller. My plugin is called 'myplugin', the controller I wish to ...
foamcow's user avatar
  • 2,029
2 votes
1 answer
4k views

Service Unavaliable

I downloaded Lamp and am trying to install Craft CMS, but I keep getting a "Service Unavailable- Our site is temporarily unavailable. Please try again later." In the log file it printed the following: ...
user2997606's user avatar
2 votes
2 answers
5k views

My website isn't working: "Craft does not support backtracking to this version. Please upload Craft 2750 or later."

I have been unable to access both my website and my login page. What's going on?
PaHoua's user avatar
  • 21
2 votes
1 answer
408 views

Can I disable logging 404 errors in my craft.log file?

I want to get a better understanding of some issues in production surrounding timeouts but as its a high traffic site the craft logs get replaced about every 15 minutes due to the amount of 404's that ...
Seán O'Grady's user avatar
2 votes
1 answer
135 views

Security test generated large compiled_templates directory, site outage

We just moved an installation of one of our sites to a new server. Previously, it was on a machine where the versions of Ubuntu / PHP prevented us from upgrading the Craft core version from 2.3.x to 2....
TJ Nicolaides's user avatar
2 votes
1 answer
3k views

Invalid asset source path

After setting an asset resource I am receiving the "your source ' ' appears to be invalid." on the update indexes, and Error uploading the file: The file system path '{basePath}/assets/images/' set ...
lucaslink's user avatar
2 votes
1 answer
625 views

Blank white pages after moving index.php

I was developing a site on my server. Craft was living at ~/mysite.com/craft/, the webroot was ~/mysite.com/www/, and the URL was dev.mysite.com. Now I want to deploy the site to www.mysite.com, but ...
Sandwich's user avatar
  • 636
2 votes
1 answer
277 views

Issue trying to use function from DateTimeHelper class: "timeAgoInWords() is not defined"

Not quite sure how to use functions defined in Helper classes in my templates. For example, trying to use "timeAgoInWords" on an entry's dateCreated attribute. I get an internal server error and a "...
jeraldjuice's user avatar
2 votes
1 answer
2k views

403 Forbidden Assets

I can't for the life of me figure out what's going on. When assets are added, they upload fine but when I add them to entries or try to view them in the browser, they won't display and show a 403 ...
Caleb Durham's user avatar
2 votes
1 answer
5k views

"Error: Unknown package has no name defined" when updating Craft 3

I'm getting "Error: Unknown package has no name defined" when updating a site from 3.0.41.1 to 3.5.15.1 I had read a reinstall of composer had fixed this for someone else, but hasn't for me. ...
Jaytrix's user avatar
  • 337
2 votes
1 answer
1k views

Database Exception: Column not found: 1054 Unknown column 'position' in 'order clause'

I deployed the project from the git repository on hosting. When trying to open the homepage I get the following error: Database Exception SQLSTATE[42S22]: Column not found: 1054 Unknown column '...
EvgeniaM's user avatar
2 votes
1 answer
377 views

Check for errors (any) on guest entry form (Craft 3)

I have a guest entry form that's working fine. I'm using Craft-supplied code: {% macro errorList(errors) %} {% if errors %} {% for error in errors %} {{ error }}{% if not loop.last %}, {% ...
4midori's user avatar
  • 656
2 votes
1 answer
298 views

Asset upload fails with progress bar at full, but images in tempuploads folder

I can’t for the life of me get images to upload. Neither on my local server or on the live server. The progress bar goes to the end, and then … nothing. From what I can see online, I’m not the only ...
KSP's user avatar
  • 849
2 votes
1 answer
2k views

Internal Server error during install

I've done a few installs of Craft and never had a problem. I'm currently trying to do an install on a new server under a subdmomain and getting the following results… This results in 404 http://...
Howard Theriot's user avatar
2 votes
2 answers
1k views

500 Internal Server Error in OpenShift install

I'm running into a 500 Internal Server Error when trying to install craft (on openshift). Environment: Platform: OpenShift (nginx-php7 cartridge: https://github.com/pinodex/openshift-cartridge-nginx-...
Colin's user avatar
  • 31
2 votes
2 answers
265 views

Error on homepage of local server no changes made since last working?

I have just gone back to a site I am working on locally to continue working on it. 2 days ago it was working fine and I have made no changes. I now have this error when I load the homepage. ...
Lettie's user avatar
  • 2,033
2 votes
1 answer
1k views

Internal Server Error

I am trying to edit fields. When I go to Settings->Fields and then click on a field, I get a message that reads: Internal Server Error Craft\Model and its behaviors do not have a method or ...
Jennifer Grant's user avatar
2 votes
1 answer
345 views

Craft CMS and LiteSpeed (403 error on login)

When trying to login to the administration section on a server running LiteSpeed, half the time LiteSpeed triggers a 403 Forbidden message and locks that computer out of the entire server Craft is ...
Ben Fleming's user avatar
2 votes
1 answer
423 views

"Internal Server Error - Cannot find the target folder." When trying to edit an article

Suddenly, when I try to enter an article to edit it, I get the error message "Internal Server Error - Cannot find the target folder." I can't seem to find the reason why this happens, or how to fix ...
Ole's user avatar
  • 245
2 votes
1 answer
188 views

How can I handle exceptions on the front end

So I have some exceptions being caught in a plugin, and have to assume that in some cases a 500 error is going to occur at some point. How can we set up Craft so that a server error displays a ...
Russ Back's user avatar
  • 1,503
2 votes
1 answer
73 views

Variable entry does not exist on blog post

We just installed the CMS and like it very much. On the other hand while following the basic tutorial we seem to get the error "Variable "entry" does not exist." on the most simple ...
Ron Cooper's user avatar
2 votes
1 answer
172 views

Error on functions in queue: "Session does not exist in a console request."

I get the following error on multiple order mails from Craft Commerce. The error points out to the lines where a macro is called: Email template parse error for email “New order”. Order: “e35f244”. ...
chlsydkysr's user avatar
2 votes
1 answer
126 views

"Field Limit is too big for your chosen Column Type" error on already existing fields when updating matrix

I'm getting the following error when I'm trying to update a matrix: "Field Limit is too big for your chosen Column Type."" I'm trying to add a new block type but this error keeps getting up on ...
valley's user avatar
  • 65
2 votes
1 answer
120 views

P&T Contact Form not submitting Craft 2

I'm working on a site that I did not build. The first party contact form stopped submitting so I updated Craft and all plugins. All went smoothly but the form is still not submitting. Checked the ...
CreateSean's user avatar
  • 1,983
2 votes
1 answer
270 views

Structure unable to find _entry template

I have a Structure named "pages" which is set to use the template named "_entry". When trying to visit one of the pages I’m just getting a blank screen. The Craft log shows an error in the template ...
foamcow's user avatar
  • 2,029
2 votes
1 answer
2k views

Image Transform Internal Server Error (500 code) after Craft CMS update

I just updated an "older" Craft site (version 2.4.2702) to the newest update (version 2.6.2958). But now all my image thumbnails in the back-end are missing and if I upload any new assets, the ...
Tom De Smet's user avatar
  • 1,456
2 votes
1 answer
598 views

Error: "Tried to read the folder contents...but could not"

I'm stumped on this one, for the longest time when I clicked the "Clear Caches" button in the CP, everything seemed to be ok. But I recently checked the craft.log after noticing things didn't seem to ...
S.Jang's user avatar
  • 43
2 votes
2 answers
946 views

Control Panel URLs being rewritten to use index.php?p=admin/

All of our control panel URLs are being rewritten to show index.php?p=admin/*** While this isn't a problem in itself we can't determine why it's happening when the frontend of the website itself is ...
Boxhead's user avatar
  • 33
2 votes
1 answer
238 views

Password should fail on front-end registration form

Update For anyone else having a braindead moment, registration form errors only display for password when logged out. If you're logged in as admin they won't display. User posted even though using an ...
Rob's user avatar
  • 865
2 votes
2 answers
261 views

Remove $_SERVER and DB Queries from logs in 3.4+

How can we disable Craft from logging MySQL queries and $_SERVER object into the logs? For our team, this creates additional noise that's not needed for us to debug issues. Thanks :)
owenmelbz's user avatar
  • 149
2 votes
0 answers
918 views

Does Craft expose PHP errors when not in devMode? [closed]

I'm seeing a lot of tasks hanging in Craft. Specifically, DeleteStaleTemplateCaches and GeneratePendingTransforms. I've followed the advice and instructions at https://craftcms.com/support/stuck-tasks ...
Matt's user avatar
  • 21
2 votes
1 answer
561 views

CDbException after updating field type

I've just changed a rich text field to a number field and am now unable to bring up either the front-end or the dashboard because of multiple CDbException errors. When trying to access /admin, here's ...
plaintxt's user avatar
  • 488
1 vote
2 answers
3k views

An unknown error occurred all the time

When creating, editing or deleting anything in CP the notification with "An unknown error occurred" is appended at the top. I check the console and I get a 500 on these: /index.php/admin/actions/...
Tim's user avatar
  • 11
1 vote
2 answers
1k views

An error occurred when rendering a template

I have an odd problem. When I render a simple HTML template without any link to the Control Panel, I get the following message on random pages: An error occurred when rendering a template ...
SeeklesBodil's user avatar
1 vote
1 answer
558 views

Basic 404 setup not working

I look at past Q & A about this, but am still perplexed. Not logged in to CP or frontend I have a simple template called 404.twig which resides in the templates folder I can access the template ...
4midori's user avatar
  • 656
1 vote
1 answer
574 views

Feed me plugin, cURL error 60

This is my first time using the Feed Me import plugin (craft 3.5.15.1). I'm pointing the feed URL to a file in the public root, e.g. http://dev.mydomain.com/import.csv. When executing the import, I ...
Mosswalker's user avatar
1 vote
1 answer
112 views

Best way to find a deprecation error with no location hint?

I'm getting a deprecation error about looping through element queries, but in my markup all my loops are being setup with the .all() method, so I'm struggling to find this. And it's one that is ...
Jay's user avatar
  • 1,042
1 vote
3 answers
3k views

Installing Craft 3 - Internal server error

Using Ampps on Windows, I'm trying to install a fresh Craft 3.0 and I've followed the steps and everything seems to be working. Until the very last step, where Craft says "Oops something went wrong". ...
Kenny Bones's user avatar
1 vote
2 answers
275 views

Calling plugin controller externally fails with 500 error

UPDATE: Question edited to be clearer. I had an issue where it seems calling a plugin’s controller via an URL caused the site itself to throw a 500 error (i.e. not being accessible at all). The ...
KSP's user avatar
  • 849

1
2 3 4 5