Skip to main content

Questions tagged [error]

The tag has no usage guidance.

42 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2 votes
2 answers
260 views

Remove $_SERVER and DB Queries from logs in 3.4+

How can we disable Craft from logging MySQL queries and $_SERVER object into the logs? For our team, this creates additional noise that's not needed for us to debug issues. Thanks :)
owenmelbz's user avatar
  • 149
1 vote
0 answers
74 views

Displaying errors on frontend profile form

I have a user profile form on the frontend that doesn't display errors for a URL field. The field handle is 'website'. This is my code: {% macro errorList(errors) %} {% if errors %} {{ ul(errors, {...
LessMore Creative Studio's user avatar
1 vote
0 answers
57 views

Internal server error - Cannot serve directory

Randomly a couple of times a day my website throws an Internal Server Error that fixes itself within minutes. Checking the logs (have replaced my username with 'username') it looks like a server issue ...
otb's user avatar
  • 11
1 vote
0 answers
397 views

HTTP 404 – Not Found – yii\web\NotFoundHttpException

New to Craft and following the tutorial to Create the blog. When trying to browse the created blog page get 404 error below. HTTP 404 – Not Found – yii\web\NotFoundHttpException Template not found: ...
Senthil's user avatar
  • 111
1 vote
1 answer
119 views

Updates always error out

Every time I try to run an update, I get these errors. Installing plugins won't work either. I'm using Media Temple / Grid server hosting. I've increased the file size limits in php.ini as well. But I'...
Noah Yamen's user avatar
1 vote
1 answer
221 views

500 Error after Dreamhost server upgrade

Dreamhost upgraded my VPS overnight and I immediately got a 500 error. The site currently works on another Dreamhost VPS (the original below) and an Arcustech server. After checking the error logs I'm ...
Brandon's user avatar
  • 11
1 vote
0 answers
780 views

Internal Server Error - The file does not appear to be an image

On a live environment I'm hitting an error when uploading some jpg images, which wasn't a problem on dev or production. I can get around it by re-exporting the image out and keeping it under 1mb, but ...
sarah3585's user avatar
  • 899
1 vote
0 answers
53 views

Account Verification or Password Reset Error

Craft 2.6 I have a site that's been running for some time and now when trying to do a password reset or account verification error I get the following message. I found this stack exchange thread ...
CreateSean's user avatar
  • 1,983
1 vote
1 answer
648 views

send e-mails via smtp without authentification

I try to send e-mails via SMTP without authentification and I'm getting the following error: There was an error testing your email settings. I checked my setup on https://www.smtper.net/. No ...
rttmax's user avatar
  • 111
1 vote
0 answers
471 views

Strange Redactor Config error when importing colleague's database

Description I am getting this error after importing a database supplied from my colleague. I have deleted the vendors directory and composer lock file in an attempt to re-install Redactor. I have ...
Jay's user avatar
  • 1,042
1 vote
1 answer
1k views

Craft 3: admin is showing "500 Internal Server Error" (apache) after fresh install

Just successfully installed a fresh copy of Craft CMS via web browser method under: http://kultursprung.org Frontend is visible but the admin is showing raw Apache error 500 after fresh install: http:...
Axel Hebenstreit's user avatar
1 vote
0 answers
140 views

Some orders recieve double amount of products

I have a pretty critical issue with one of my clients websites. The site, running Craft CMS 2.7.2 and craft commerce 1.2.1364, uses a event/tickets plugin and uses Mollie as the payment provider. ...
Mosh's user avatar
  • 153
1 vote
0 answers
619 views

Cannot add more fields - SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large

I've been bumping into a field limit when attempting to mirgrate fields in, which is a massive limitation for the way the site was originally set up. I've read a bunch of other threads where it's ...
Jammooka's user avatar
1 vote
0 answers
261 views

Copying asset by insertFileByLocalPath() results in fopen:()failed to open stream error

EDIT: Updated code (issue remains) I'm trying to implement functionality in a plugin that, when saving an entry with a lightswitch enabled, takes the asset at index 0 from an assetfield called ...
justussimon91's user avatar
1 vote
0 answers
37 views

Can't save work/edits to Craft,

We're developing a new site using Craft. When I'm at work I can save all the work I have done on the site fine. But when I'm at home (using BT broadband), my ability to save any edits I make to the ...
Matthew Sanders's user avatar
1 vote
0 answers
64 views

Language Cookies Issues

Scenario 1: A language other than English is selected. New website.com visits will be in that language. Even after switching back to English, websites will continue to load in the previous language. ...
FrankHJ's user avatar
  • 11
1 vote
0 answers
361 views

Configuring CraftCMS on Arcustech with Cloudflare flexible SSL returns 521 error

I have installed CraftCMS on an Arcustech VPS and successfully added a domain name. Using the domain without the shared SSL works without any problems (e.g. www.example.com / example.com). However ...
Harvey Eckstein's user avatar
1 vote
0 answers
1k views

var_export does not handle circular references” when devMode = true and logDumpMethod = print_r

Here is a similar question that was asked but doesn't resolve my issue Question has changed, see UPDATE below I'm new here so I couldn't just tag a comment onto this post asking this question: I ...
Atom145's user avatar
  • 111
1 vote
0 answers
219 views

Admin Forcing Logout

I'm having an issue where the admin is kicking a user out after an indefinite period of time. The corresponding error message is Tried to restore session from a cookie, but the given hashed database ...
triplethreat23's user avatar
1 vote
0 answers
2k views

500 Internal Server Error on trying to install

Probably something really silly I'm missing here but I'm trying to test out Craft with a look at purchasing but can't even get to a first step in installing it :-( As far as I can tell the server ...
Mark Bowen's user avatar
1 vote
0 answers
3k views

How to Fix Error 403 Attempting to Access Craft Admin Page Using XAMPP

I'm using XAMPP for the very first time and am also new to Craft so any help with this issue would be very much appreciated. I'm attempting to set-up a local dev environment through XAMPP and then be ...
Dan's user avatar
  • 11
0 votes
1 answer
27 views

Internal Server Error on Save / Dashboard

A client's site is producing Internal Server Errors randomly in the Craft backend (3.7.53.1). The Dashboard produces an error. Saving certain entries produces an error (especially when enabling ...
Document Services's user avatar
0 votes
0 answers
113 views

SQLSTATE[HY000]: General error: 5 Out of memory (Needed 418490224 bytes)

I'm building a webtoon with CraftCMS 4 but facing this issue: SQLSTATE[HY000]: General error: 5 Out of memory (Needed 418490224 bytes) Screenshot: https://i.sstatic.net/oMKud.png All entries are a ...
Alex's user avatar
  • 1
0 votes
0 answers
321 views

Can someone help me solve for this error message: "Craft can't connect to the database with the credentials...."

Can someone help me solve for this error message: An exception has been thrown during the rendering of a template ("Craft can't connect to the database with the credentials in craft/config/db.php....
Cait H.'s user avatar
0 votes
0 answers
69 views

Update following site import leads to fatal error

Today, I have moved a fully up-to-date installation to a new server, and three times now on a seemingly successful installation, after going to update to the latest version (the existing install is up ...
Emma Swann's user avatar
0 votes
0 answers
215 views

internal server error when creating new field

whenever i try to save a new field I get an internal server error in the backend of craft 3. This happens whenever i want to create or modify a field that has an input like date, plain text, reactor......
user12636's user avatar
0 votes
0 answers
86 views

404 accessing the admin site - not rewrite related

I'm struggling with a downloaded copy of a clients Craft 3 based website. I've downloaded the entire project, and have tweaked the .env file and .htaccess for my local mac's setup. The site itself ...
steve's user avatar
  • 131
0 votes
0 answers
79 views

Need help: multiple request throttling

I have an issue in the CraftCMS back office when I try to export all entries. When I try to export all the entries in expanded mode it takes ~1min but every minute the back office send another ...
Antoine Maillard's user avatar
0 votes
0 answers
69 views

Craft is not installed yet with a REDIS error

Our website is on the latest version of Craft 3.4, using REDIS (redis_version: 4.0.9) for Sessions and Caching. Today the website stopped working with the well-known "Craft is not installed yet&...
Matthias Redl-Mann's user avatar
0 votes
0 answers
66 views

All URLs changed path after upgrading to 3.6?

I'm not sure exactly what has changed here. All links are directing to "site.test/admin/site.test/blog/{slug}", when clicking on the link from the entry page. Before they would be "site....
Thurc1996's user avatar
0 votes
0 answers
189 views

Internal Server Error when updating slug

I'm getting an internal server error when I try to update the my entry's slug on prod, but not on dev or locally. It's happening across entries, it doesn't seem to be specific to a certain entry. Any ...
Lisa's user avatar
  • 1
0 votes
0 answers
174 views

Undefined property: DOMElement::$tagName

When I am logged into the admin control panel and I go to "Settings", I receive the error "Undefined property: DOMElement::$tagName". Here is the Stack Trace: yii\base\...
Darthrizen's user avatar
0 votes
0 answers
229 views

Error when setting field length on global

I have set up several globals to store the URLs of a company’s social media accounts. Each one is a plain text field, and each one is limited to 254 characters. This works fine with three of them, but ...
mitrol's user avatar
  • 262
0 votes
0 answers
142 views

Website Stuck on Load after few requests

I'm facing a weird issue here. I'm developing a CraftCMS based website and all seem to be working fine, until after a few requests (clicking around 4 ~ 5 requests) the website seem to keep loading and ...
TechMafioso's user avatar
0 votes
0 answers
24 views

spinning wheels on dashboard columns - can't edit site - unknown error

I'm getting constantly spinning wheels on columns on dashboard and can't edit the site - https://timetoshineleeds.org/ - but live site is fine. Got 'error unknown' message when going into dashboard. ...
Rob's user avatar
  • 11
0 votes
1 answer
199 views

Craft CMS Content has Disappeared?

My content within all of my pages has disappeared. The website is only displaying the header and footer on each page. When I try to restore the internal page to it's previous version to get the ...
Angie's user avatar
  • 1
0 votes
0 answers
125 views

CP login error for (only) one user in particular

One of our client logins has stopped working. When you try to login there's a spinner and then Failed to load resource: the server responded with a status of 504 () error on index.php:1 Sometimes ...
James Greig's user avatar
0 votes
0 answers
657 views

Installing Craft CMS 3 on hosting - Unsupported DB driver value

i am trying to instal Craft CMS 3 on hosting and everytime it is going to fall on: 2019-07-05 16:33:55 [-][-][-][error][craft\base\ApplicationTrait::getIsDbConnectionValid] There was a problem ...
Ondrej's user avatar
  • 1
0 votes
1 answer
250 views

An unknown error has occurred in asset reindex

I am getting the error: An unknown error occurred for each file in a folder when I try Update Asset Indexes. The folder is a local folder that is outside of webroot. The files just contain json data....
Trevor Orr's user avatar
0 votes
0 answers
379 views

Large file upload, 500 server error

We've a Craft 3 site hosted with Digital Ocean (Serverpilot set-up) with the DNS routed through Cloudflare. The client has experienced issues uploading large ZIP files to (c140MB), returning a 413 ...
Cole Henley's user avatar
  • 1,741
0 votes
0 answers
516 views

Commerce - Live Environment - "Trying to get property of non-object"

I have a site and been tested locally and on staging server and it checks out fine. I have moved it to the clients live server (Windows 2016) but when I hit the pay button via dummy gateway or ...
mmc501's user avatar
  • 1,789
0 votes
0 answers
258 views

Property "Craft\SessionRecord.token" is not defined

I'm trying to log in to the admin area of an local install but all that happens is the page refreshes and nothing happens. Digging deeper I found this in the log: 2016/03/09 09:16:38 [error] [...
Alec Ritson's user avatar
  • 4,539