Skip to main content

Questions tagged [error]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2 votes
1 answer
172 views

Error on functions in queue: "Session does not exist in a console request."

I get the following error on multiple order mails from Craft Commerce. The error points out to the lines where a macro is called: Email template parse error for email “New order”. Order: “e35f244”. ...
chlsydkysr's user avatar
1 vote
1 answer
578 views

Getting to grips with errors and flash messages

As a newbie to Craft and Craft Commerce. I wondered if someone could explain the difference between all these error codes that I have seen either in the docs, this forum or the templates and when they ...
Terry Upton's user avatar
  • 1,894
3 votes
1 answer
831 views

Nesting level too deep when looping through matrix blocks

I'm running into a nesting level error when looping through matrix blocks, and I can't quite figure out what the problem is. The problem arises when I use a variable to track the type of the previous ...
Nick F's user avatar
  • 1,215
2 votes
1 answer
135 views

Security test generated large compiled_templates directory, site outage

We just moved an installation of one of our sites to a new server. Previously, it was on a machine where the versions of Ubuntu / PHP prevented us from upgrading the Craft core version from 2.3.x to 2....
TJ Nicolaides's user avatar
2 votes
2 answers
5k views

My website isn't working: "Craft does not support backtracking to this version. Please upload Craft 2750 or later."

I have been unable to access both my website and my login page. What's going on?
PaHoua's user avatar
  • 21
2 votes
1 answer
5k views

"Error: Unknown package has no name defined" when updating Craft 3

I'm getting "Error: Unknown package has no name defined" when updating a site from 3.0.41.1 to 3.5.15.1 I had read a reinstall of composer had fixed this for someone else, but hasn't for me. ...
Jaytrix's user avatar
  • 337
2 votes
1 answer
2k views

403 Forbidden Assets

I can't for the life of me figure out what's going on. When assets are added, they upload fine but when I add them to entries or try to view them in the browser, they won't display and show a 403 ...
Caleb Durham's user avatar
1 vote
3 answers
3k views

Installing Craft 3 - Internal server error

Using Ampps on Windows, I'm trying to install a fresh Craft 3.0 and I've followed the steps and everything seems to be working. Until the very last step, where Craft says "Oops something went wrong". ...
Kenny Bones's user avatar
1 vote
1 answer
102 views

Matrix field entry link corrupted

Some of my links coming from a matrix field with entry became corrupted. Anyone had this before and knows how to fix it?
aren's user avatar
  • 79
1 vote
1 answer
106 views

Website transfer places /web in all urls, cs and js not loaded when moved up directory

I just transfered my website from one server to one.com. Now nothing works anymore cuz apparently one.com wants the index.php in the root directory but my index.php is in the "web" directory....
Masary's user avatar
  • 11
1 vote
1 answer
227 views

Error on functions in queue: “Session does not exist in a console request.”

I already experienced this same problem with Craft Commerce a while ago (Error on functions in queue: "Session does not exist in a console request.") and got a solution that solved the ...
chlsydkysr's user avatar
1 vote
1 answer
2k views

S3 Asset uploading hangs

I am having an issue with uploading assets to S3 from Craft. So far I have taken the following steps: Create permission policy and attached to group containing craft user: { "Version": "2012-10-...
tplassman's user avatar
1 vote
1 answer
654 views

Assets Transform returns "Image cannot be found."

I have two assets sources, Slideshow and Products. I have six Image Transforms. On the home page I'm using a structure channel to play a simple slideshow and I'm using 3 transforms and all is working ...
Dimitrios Vogiatzis's user avatar
1 vote
2 answers
3k views

An unknown error occurred all the time

When creating, editing or deleting anything in CP the notification with "An unknown error occurred" is appended at the top. I check the console and I get a 500 on these: /index.php/admin/actions/...
Tim's user avatar
  • 11
1 vote
1 answer
1k views

404 page redirect to homepage

Is it possible to set up a 404 page, and after x amount of time redirecting to the homepage? {% extends "_layout/_layout" %} {% set metaTitle = "404" %} {% set bodyId = "404" %} {% set ...
Johannes Lamers's user avatar
1 vote
2 answers
675 views

Content / fields of newly created single don't show up

After a fresh install of Craft on my localhost, two problems occur: 1) The modal window to upgrade Craft only says "An unknown error occured." 2) Newly created singles are not editable, the edit ...
Matthias Ott's user avatar
1 vote
1 answer
423 views

craft.request.getParam('entryId') returns null on edit page of an entry

I have a plugin that's loaded on the edit page of an entry. Whenever I open the entry edit page, I would like to retrieve the id of this particular entry. I've tried this: {% set someId = craft....
iNalgiev's user avatar
1 vote
1 answer
145 views

permissions userphotos "an unknown error occurred"

On my production server, each time I try to change or upload a user photo I get the "an unknown error occurred" message. If I check the logs, the error says it couldn't delete the folder of the ...
Jan Van Echelpoel's user avatar
1 vote
1 answer
577 views

Unknown error occurs on every AJAX call in CP

I was working on a plugin with a hook on onBeforeSaveEntry in my dev environment (which is configured exactly like my live environment). I had a var_dump with an exit in the hook to check output of ...
John Ripmeester's user avatar
0 votes
1 answer
502 views

Admin entries 404'ing

I've transferred a Craft site (I didn't build it) from staging to production. All the existing content is showing up on the front end but when I try to edit entries that aren't static pages, the edit ...
Mike's user avatar
  • 101
0 votes
2 answers
291 views

PHP error after one click update [closed]

I updated Craft to version 2.6.2798. Since then I'm getting a PHP error: Parse error: syntax error, unexpected '[' in /craft/app/fieldtypes/BaseElementFieldType.php on line 428 PHP version on the ...
seteriel's user avatar