Questions tagged [craft3]

For use with questions relating to the Craft 3 version of Craft CMS, including the Beta and RC releases.

331 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
0
votes
0answers
19 views

Category’s group (1) is not enabled for site (1). when moving site?

I've moved my site over, importing from the previous one using the project folder. When trying to do a feedme import I'm getting the following error with Categories: Category’s group (1) is not ...
0
votes
0answers
41 views

Craft not using correct URL on Entries' list link button

I'm using Craft as a headless CMS and when I click on the entry link at the entries' list it uses the Craft Server URL instead of the correct frontend URL (See images). For example: https://craft-...
0
votes
0answers
20 views

Commerce Shipping/Tax Estimates

Within the checkout flow, I am looking to offer an up to date 'shipping/tax' estimation. Looking through the Craft Commerce docs, I found the 'Estimate Cart Addresses' (https://craftcms.com/docs/...
0
votes
0answers
13 views

Images get stuck as temporary when uploaded to an Asset Field in a Matrix Block where the storage path contains the block ID

I'm facing an issue, and possibly a bug or an un-fixable kind of logical issue, where I have a Matrix Block with an Assets Field inside of it. The storage path for the Assets field is pointing to a ...
0
votes
0answers
15 views

How to change site propagation for channels without duplicating all entries over all sites

We currently have setup a template and quite a few sites for the same template up and running using the multi site manager. For all sites the base entries are the same so we first used the setting on ...
0
votes
0answers
40 views

Localization for "Home" site (eg https://example.com/de" results in 403 — Forbidden

I have set up a multilingual site in Craft CMS and the localization (via url-slug eg. .../de/...) works on all pages. However, on the home site (index.twig) this leads to an error message "403 - ...
0
votes
1answer
56 views

Regular Expression replace not working within Twig Template

I'm attempting to capture 4 attributes of an Attributes of an tag and injecting inline styles to the style attribute. Craft CMS and Twig templates are being used to generate HTML emails here, hence ...
0
votes
0answers
19 views

Unable to save/edit system messages due to "a sever error occured"

I am trying to send the user activation email to registered users, however the email sent is blank and in the email settings of the backend I cannot edit or save the System Messages. On the backend it ...
0
votes
0answers
22 views

How can I add a new event from the front end to a solspace calendar event field added to the user profile

I am trying to add a new event from the front end to a solspace calendar event field I added to the user profile. I created a calendar event field then added it to the user profiles. I can add an ...
0
votes
0answers
25 views

Migrate one entry with content from local to server

I want to migrate 1 entry with content (Matrix Block) from locally to the server? How do I do that? In wordpress it is pretty simple, but here I don't find an option. I tried the Migration Assistant ...
0
votes
0answers
12 views

Error when making CSV file from craft commerce orders

So I have a _export.csv file that contains code like this: {% spaceless %} {% set slug = craft.request.getSegment(2) %} {% set product = craft.products.status(null).slug(slug).one() %} {% ...
0
votes
0answers
10 views

Query date field, timezone not taken into consideration

I'm trying to query a custom table on a DATETIME field. My timezone is UTC+2 and the dates stored in the database are UTC. shiftEnd in database: note that the shifts ends at 08:35 UTC, in my timezone ...
0
votes
0answers
8 views

Sales not applying to products

I'm having trouble getting sales to apply to products. I'm running craft 3.7.2 and Commerce 3.3.5.1. The product I'm attempting to apply the sale to is marked as promotable. As far as the sale, I've ...
0
votes
0answers
20 views

Multisite shareable content issue

I need to create a multisite with 12 websites, all 12 websites have 2 languages, country default and english. I want to share the content between these websites. I can duplicate the pages and ...
0
votes
0answers
22 views

Craft CMS Freeform unable to override value of invisible/hidden field

In my control panel, I have a hidden field type with name 'Payment Amount' and handle name 'paymentAmount'. I am trying to modify its value to be the same as another field of the same form called '...
0
votes
0answers
13 views

User mapping with Socializer plugin

I'm currently working on Instagram login part of my project with Socializer plugin for Craft CMS. I went through docs and did everything that was described there. I have app on facebook for developers,...
0
votes
0answers
34 views

craft commerce "Invalid payment or order. Please Review." on hasFlash('error')

Just trying to make a merchandise web shop with Craft CMS 3 and Craft Commerce 3. However, whenever payment is attempted to be made for merchandise on checkout page with commerce/payments/pay, there ...
0
votes
0answers
33 views

How to print variables inside a PHP Event?

I'm trying to work with the Sprout Forms events to grab a variable from the form and add it to a filename also uploaded through the same form. I am extremely stuck and so far I can't even confirm ...
0
votes
0answers
17 views

Importing fields from ExpressionEngine 2 to Craft

sorry if this is posted somewhere. I couldn't find it. I'm trying to export a site from EE2 to Craft 3. All the tutorials I've found only export/import the pages and it seems like you have to create ...
0
votes
0answers
50 views

Locale URL /en not working - No such file or directory (/public)

Some values have been anonimized and are marked with %value% I followed the steps for setting up a local Craft CMS using composer and have the default site running on %domain%.test. Now I've made a ...
0
votes
0answers
30 views

Failed to publish entry when the autosave is not yet complete

When I publish an entry with that has Neo field, after I editing the Neo field and I click publish before the autosave is complete, the publish will take very long time and even gateway time out. This ...
0
votes
0answers
17 views

Redactor plugin: breakline is added double

I have a simple field, with this config: { "buttons": [ "bold", "italic", "link" ], "breakline": true } What I want is to just ...
0
votes
0answers
19 views

Searching a Maps field inside Matrix

I have a bunch of entries, each one with a Matrix field, consisting of a "Location" block type, with "Map" field (Ether Maps). I need to output some JSON, following a keyword ...
0
votes
0answers
13 views

Is it possible when using the DateTime field in Freeform to block dates AND times?

I'm using the freeform plugin for a reservation system. The enduser can book a date and time (30 min intervals). Blocking dates seem straightforward but I don't know if it's possible to block a ...
0
votes
0answers
25 views

SEOMatic Entries not rendering SEO Options Tab

Following an upgrade from Craft 2.6 to 3.6, the SEOMatic plugin is not rendering the SEO Tab for the entries. Any ideas on why this would be? I've updated the settings in the SEO Content in the ...
0
votes
0answers
40 views

Join multiple tables in element-api

My problem is the following: I have a website with products which contains ratings. I have an element-api endpoint to get the products. I want to sort the products based on the average rating or the ...
0
votes
0answers
34 views

Automatic Asset Cache Clear

I have a large website that various users need to upload important documents (assets) to frequently. I need to have the Craft asset cache clear every time a new asset is uploaded. The other option I'...
0
votes
0answers
41 views

craft cms how to modify redactor image upload path

So for my assets field types, I have the Asset Location (Where selected assets should be stored.) set to: {owner.type.name}/{owner.slug} this neatly puts all the files I upload via the asset field ...
0
votes
0answers
54 views

Internal Server Error after upgrading from craftcms 2 to 3

I just upgraded from Craft 2 to 3.6.14 (latest). I was able to successfully to the upgrade. I am able to get into the admin and was even able to install the feed-me plugin. I ported over all the files ...
0
votes
0answers
50 views

Variable "entry" does not exist - error on homepage single entry

Relatively new to CraftCMS and getting Twig error "Variable "entry" does not exist" on my home page. Noticed another post said to leave URI blank which should fix but didn't. Just ...
0
votes
0answers
43 views

Why does a cart get added with no Order Number?

Sometimes, the cart gets added without the id as below. Any ideas, please? (Craft Commerce version is 2.2.19)
0
votes
0answers
98 views

Get categories with the number of entries

I would like to retrieve the categories of a group, the name and their fields, but with each one the number of entries that have this category assigned. It's like this question but I'm not using twig ...
0
votes
0answers
56 views

Complex Autocomplete

I want to write a more complex autocomplete search for a craft site. I know there are already some posts here that go in that direction. As they also tried, I approach this problem first by using the ...
0
votes
0answers
105 views

Nitro 2 on WSL craft failed permission change in cpresources

I get the following yii exception after installing and adding a Nitro2 site to WSL. Failed to change permissions for directory "/app/web/cpresources/1453c57f": chmod(): Operation not ...
0
votes
0answers
37 views

Mailer Service Error when sending notifications emails on Freeform Pro

Can anyone give me a bit more insight into why I'm getting a "Mailer Service" error when trying to send an Admin Notification with Freeform Pro? I get an error like this: Unexpected end of ...
0
votes
0answers
66 views

Changing URL format in craft commerce products error 502

I have more than 150k products on craft commerce, and i need to do some changes in the URL format, but when i click save, the server returns a 502 error. I think that is because craft is trying yo re-...
0
votes
0answers
171 views

Barba.js (with gsap) 'leave' and 'enter' hooks not working in Craft 3 - same code works in WordPress

The below code (Barba/gsap) works as expected in WordPress, but in Craft 3 only the 'once' (i.e. not the 'leave' and 'enter') hooks fire. There are no errors or anything unusual in the Barba debug ...
0
votes
0answers
15 views

Different unix users for Craft config and Craft process

I want to configure Craft to run as user craftcms and have configuration owner craftowner. The purpose is to make configuration read-only to craftcms, so that there can be no changes to the ...
0
votes
0answers
35 views

Triggering different webhook when product is updated by Feed Me

I have two different webhooks that need to run when a product is saved. Webhook 1 should only run after manually saving the product Webhook 2 should only run after Feed Me saves the product Is ...
0
votes
0answers
11 views

Batch check date and alter entries

Good Evening. Im looking for a way to regularly check a full section of entries to see if a date has been passed. If it has I want to place a checkbox marker within that entry. Has anyone come ...
0
votes
0answers
28 views

Using Element API to pull child categories

On Craft, I can assign categories to my different customers: a customer might be "Cloud", "Software" or "Energy". I have set it up so that you can also choose ...
0
votes
0answers
43 views

Searching for specific MatrixBlocks with either GraphQL or PHP

I'm building a search for my Craft site right now. Finding entries is fine. I usually have the structure that one entry is one site in the frontend. I sadly also have entries that are way longer. So ...
0
votes
0answers
33 views

File Upload Validation in a Front End form

Good Evening. I have a front end form that allows users to upload up to 4 images to an asset field, however the file chooser allows for more than 4. This causing an issue with any further updates at ...
0
votes
0answers
117 views

Why is my base installation of Craft 3 so slow on Azure App Services?

I am evaluating a few different CMS solutions for my company's new website. Everything about Craft looks great according to my research. After installing version 3 onto an Azure App Service Linux ...
0
votes
0answers
33 views

CSS and JS tags with custom version parameter

When using {% css '/path/to/file.css' %} craft adds a v= query parameter by itself so that it comes out like this: <link href="/path/to/file.css?v=1612895916" rel="stylesheet"&...
0
votes
0answers
74 views

Cache not working

I'm having troubles with my site being super slow. It seems like caching isn't working. When I upload the site to a different server, everything seems fine. When I empty the template cache and load ...
0
votes
0answers
39 views

Users creating their own custom subscription or bundle in the frontend?

I am trying to add a feature to a store (using Craft Commerce 3) that allows users to create their own subscription or bundle by selecting which products they want to buy and choosing the frequency. ...
0
votes
0answers
22 views

Need to populate new field based on existing data

Say I have a section called "Stores" that has an existing field called "Store Hours". The client has populated the store hours for 1000 some stores. Now, however, it seems what the ...
0
votes
0answers
41 views

Url Helper does not create a usable url

When I create a cpUrl like that: UrlHelper::cpUrl($this->entry->cpEditUrl) I get something like that: https://hegi.test/admin/entries/article/7707-test But that don't work inside of the browser. ...
0
votes
0answers
73 views

Internal Server Error when updating slug

I'm getting an internal server error when I try to update the my entry's slug on prod, but not on dev or locally. It's happening across entries, it doesn't seem to be specific to a certain entry. Any ...

1
3 4
5
6 7