People who code: we want your input. Take the Survey

Questions tagged [control-panel]

Questions having to do with Craft's control panel.

Filter by
Sorted by
Tagged with
0
votes
1answer
36 views

How to properly change / add to CP HTML

I'm making a change to the CP so that clicking an asset thumbnail from the asset preview HUD will open the asset in a new tab. Specifically, I'm changing line 1685 of craftcms/cms/src/elements/Asset....
0
votes
1answer
435 views

you cannot access the CP with that account

New user has activated account but is getting this message when trying to log in: "you cannot access the CP with that account"
0
votes
1answer
378 views

404 Error on Image Transforms

Transformed Images are failing to load with a 404 error For example: http://mysite.com/index.php?p=cpresources/transforms/382&x=v0nGRK3Qr This happened after I swapped the db. So, everything ...
0
votes
2answers
1k views

How can I force a slug to update on save

I'm using the auto generate entry titles from custom fields option, eg {eventVenue}-{seriesName}-{eventDate} But sometimes the eventVenue isn't known at the time of creating the entry, so you can ...
0
votes
1answer
57 views

Navigation position in Control Panel Craft CMS 2.5

The new position of the Control Panel navigation on the left side in Craft CMS 2.5 needs so much space and looks kind of wrong to me. Is there any way to position it on the top like in pre 2.5 ...
0
votes
1answer
110 views

Show larger images in control panel entries

Is there a way to show the images in the control panel entries (both in the detail of the entry and in the overview list using the new customisable columns in 2.5). The standard preview of the images ...
0
votes
1answer
77 views

Can we hide version number in control panel for certain user groups?

Usecase: the site I'm building has public registration, the publicly registered users have access to only their own specific entry in the back-end (which makes use of many complex fields, such as ...
0
votes
1answer
163 views

Default to only showing 'Live' entries in CP?

I'm finding that the structures view in CP is really slow with the amount of entries I have in it. The vast majority of these will be in draft for some time yet, however. I've had a look through the ...
0
votes
1answer
49 views

$this->renderTemplate() breaks the CP navigation

I'm locally working on a Craft Plugin with a Page in the Control Panel where I have a form that posts to a controller. <form action="/actions/import-products/product/create" method="...
0
votes
1answer
225 views

404 errors on cpresources images [closed]

i'm facing 404 errors for images related files in the control panel like users photo, Login Page Logo, site Icon... etc... for user photo for example i can edit the image, and i see it normally, but ...
0
votes
1answer
790 views

Can not login in the control panel: Internal Server Error 500

The website ist working, but I can not login in the control panel. In the console: 500 Internal Server Error - .../resources/lib/jquery-2.2.4.min.js?d=1493300895 setcookie() expects parameter 3 to ...
0
votes
1answer
98 views

Headings Not Shown When Adding Custom Source

When adding custom sources as per the docs https://craftcms.com/docs/plugins/hooks-reference#modifyEntrySources like so: foreach($this->regions as $region) { $sources[] = ['heading' => $...
0
votes
1answer
20 views

Move Icon Disappears from Categories editor

The move symbol - the one that allows you to move a category in the list up or down, etc. -- is gone from one of my category groups. It's the one that appears just after the checkbox to select a ...
0
votes
2answers
73 views

How to allow Asset removal in the Control Panel for an Entry

I've installed Craft Personal 2.5.2763, and have set up my own simple blog. For each Entry in the Blog Channel, I've set up an Asset Field, which is used for the header image displayed on the blog ...
0
votes
1answer
184 views

DeleteStaleTemplateCaches/tasks error

I've got the ol’ DeleteStaleTemplateCaches issue breaking the Craft task manager/process. I've tried switching the offending task over to error from running but is still stuck. Any thoughts on ...
0
votes
2answers
270 views

Craft News Feed not working after 2.5 Update

Not a major thing but I just noticed the Craft News Feed on the dashboard is not showing. It is still looking for https://craftcms.com/news.rss. Any ideas what is up with that?
0
votes
1answer
399 views

Control panel switches to HTTPS protocol on its own

On one Craft CMS site I have, all control panel URLs I call over HTTP are rewritten to HTTPS. E.g. the login page, as well as all its assets, are being served via https://www.mywebsite.com/admin/…. ...
0
votes
1answer
117 views

Issues accessing Control Panel with iPad on iOS 7 [closed]

I'm having issues accessing the Control Panel using an iPad on iOS 7.0.4. When loading the Dashboard and any subsequent pages, 6 popup alerts will appear with the message: Safari cannot open this ...
0
votes
1answer
202 views

Order of draggable entries and assets won't save [closed]

Hello Craft Community, I have a site which has just over 300 entries but most entries have several asset fields, entry fields, or complex matrices. My problem is that when on an existing entry, I ...
0
votes
1answer
144 views

Date picker broken? [closed]

I just tried adding a date field to the bone stock Craft news template to try out the Live Preview and I'm getting a jQuery error: TypeError: undefined is not an object (evaluating 'a.currentDay=e("...
0
votes
1answer
94 views

Strange Font Issue with Control Panel [closed]

There seems to be an issue with HelveticaNeue in chrome, on Windows 7. If I manually edit the fontface using dev tools I can get the text to display in the default font. Doing a bit of searching ...
0
votes
2answers
99 views

Concurrent actions in admin

I have a plugin the imports data from an external database. This is more of a onetime action. But what I've noticed is that when this process runs, I cannot do anything in the admin section anymore. (...
0
votes
0answers
10 views

Use the edited field label instead of the default label in the table headings

^ This is what I've edited the label to be ^ This is what shows as the table heading - Can it not show as 'Telephone'?
0
votes
0answers
21 views

Admin Panel For Page Only Shows Disabled Matrix Blocks

I'm a Craft novice trying to help some people who have taken over a Craft 3 website. There is a Single Page where the Main Content is a series of Matrix blocks. The problem is the admin Control Panel ...
0
votes
0answers
17 views

Sort by entry type in admin?

I want the list of entries in admin to allow sorting by entry type. It can sort by any arbitrary field, but not entry type or author (for some weird reason). Is there any way to modify that without ...
0
votes
0answers
15 views

Can control panel date display always be numeric?

I understand the display of entries' postDate, etc., in the control panel can be localized, but I'm wondering if it's possible to get rid of the "yesterday" and "today" designators,...
0
votes
0answers
16 views

Super table field in the element index table page (defineTableAttributes)

I've built a Custom Element called Contact and I've defined almost all the functions it needs including Contact::defineTableAttributes(). My question is two folds: How can I have my plugin install ...
0
votes
0answers
29 views

Url Helper does not create a usable url

When I create a cpUrl like that: UrlHelper::cpUrl($this->entry->cpEditUrl) I get something like that: https://hegi.test/admin/entries/article/7707-test But that don't work inside of the browser. ...
0
votes
0answers
63 views

Craft 3: Debug Toolbar is 404ing and won't display on multi-site setup

When I am logged in as an admin and I have both of these options enabled on the user preferences: ... the Yii debug toolbar still does not display and there is a 404 error that appears in console, ...
0
votes
0answers
24 views

Trouble getting the CP url to work correctly with a proxy server

Background: My client is using a proxy server to point to the production environment of the project. So for example their deployment is at https://messyurl.com, but their proxy server is routed to ...
0
votes
0answers
22 views

Empty Entry Field on CP

Is there a way to search for entries which do not have content in an entry field property on the CP? I've tried -field:* which doesn't return anything, but if I remove this there are entries which ...
0
votes
0answers
19 views

Control Panel: Order search results from a structure?

A client of mine asked how he can sort entries tied to a specific category in a structure. I thought to myself that this is easy, so I went and did a search myself: category_field_name:...
0
votes
0answers
42 views

Add new translation app.php file in Craft

I'm trying to add a new language file in Craft Control Panel admin site. I have created app.php inside translations/vi folder like this: -my app folder |-- translations |----- vi |-------- app.php ...
0
votes
0answers
17 views

When creating a new entry, what controls field focus?

When I create a new entry, I noticed that the focus jumps to a field within the first matrix block. This is not something I explicitly set, I can't find anything in the documentation about what ...
0
votes
0answers
14 views

Leave search term active in control panel

i have to edit entries with the same titles. That's why i search for these titles in the search bar of the control panel, edit the first entry, save it and then search again for the same titles and ...
0
votes
0answers
25 views

How to access CurrentUser variable in JS file

I'm using control panel js plugin to add some javascript in users page inside control panel, to hide some data based on current logged in user role, but I'm unable to access the {{currentUser}} ...
0
votes
0answers
48 views

Still no way to filter by category in Control Panel?

I'm wondering if, with the release of Craft 3.5, there is a way to filter by category in the control panel. I see this request goes back several years. The only workaround I can find is to use a ...
0
votes
0answers
38 views

Multiple (dev) sites running locally; session seemingly randomly times out

I've got multiple sites running on XAMPP (I'm on Windows 10). Each has its own domain (eg. dev.example.local, dev.otherexample.local, etc). When I try to have more than one site CP page open in the ...
0
votes
1answer
86 views

How do I change the /web directory?

I'm extremely new to Craft CMS - I'm trying to install it on to a Cpanel as a test, upon downloading the CMS is gives you all the folders for craft, and then a separate /web folder. If you move the ...
0
votes
0answers
267 views

Control panel - Entry indexes very slow

Craft CMS 3.3.15 PHP 7.1.3 MySQL 5.5.42 I have a structure with 360 entries. Right now in the CP it takes 3.5 - 10 seconds to load the first 50. And another 3.5 - 10 seconds for every additional ...
0
votes
0answers
90 views

Logging into CP doesn't set authentication cookie

Trying to debug an issue where in a dev environment logging into the cp it doesn't set the CP Authentication Cookie (the hash with the _identity) at the end of it. I believe this is the root cause of ...
0
votes
0answers
78 views

My new pages appear with Sorry, we couldn't find the page you were looking for

I am adding new entries to my site and following the exact same blueprint as the rest of my pages. However I cannot make any edits to the the new pages and when I attempt to preview them it appears: ...
0
votes
0answers
308 views

Setting up Craft 3 database backup command for a remote database server

I have my Craft 3 database on a separate server than my Craft webserver (load balancing) and when I use the download database backup function in Craft 3, it doesn't know where to look. I haven't ...
0
votes
0answers
44 views

Charge Plugin - Subscribers have access to the Control Panel and any other subscribers personal information

We bought the Charge Plugin and got it up and running for a subscription service and the website has just gone live. We just realised any new user (subscriber) has access to all other users details ...
0
votes
0answers
28 views

What's wrong when entries appear again after save?

Entries should be live and say so in the CP, but they where gone in a listing in the frontend. But after saving entry by entry they appear again. What could be wrong?
0
votes
0answers
83 views

Displaying Pending users within CP users field (in plugin template)

I'm displaying a Users field within a template within a CP plugin, but when editing the entry, only Users that are active are being shown. Here is my field: {{ forms.elementSelect({ id: '...
0
votes
0answers
332 views

Change the current locale

Can I change the current locale? I've set up a standard site, using CRAFT client version (one language). Apparently Craft installs the en_us as the primary language. Content is added (in Dutch) and ...
0
votes
1answer
135 views

cp panel entry assets element sorting

Is it possible to add an element to the existing assets list and make it sortable i need it because i have made some modifications that allow to group 2 assets together so generally i now have a ...

1
4 5 6 7
8