Skip to main content

Questions tagged [config]

Craft configuration and settings.

Filter by
Sorted by
Tagged with
3 votes
1 answer
314 views

How can I set the "activateAccountSuccessPath" for users with Control Panel access?

I have a site that allows public registration, and I want to be able to control where users are redirected to after activating their account. However the default user group has access to the Control ...
Brandon Kelly's user avatar
1 vote
1 answer
145 views

Craft Cache Config - Remote Support?

Is there a way to configure Craft further beyond just settings like 'cacheMethod' => 'redis',? I'm exploring the possibility of using Redis outside of the server Craft CMS is running on, and am ...
taylor's user avatar
  • 1,128
0 votes
1 answer
259 views

Some paths and settings being ignored in config

I've tried to set some things in my general.php config file but they're being ignored. I have the following but all are being ignored. For example, when the user receives the activation email, upon ...
richardpixel's user avatar
0 votes
1 answer
40 views

Hide the Week Start Day

Is it possible to hide the week start day on the 'Account' tab? I'm about to import 400+ members and don't want to confuse them with this unnecessary setting (from their perspective). Thanks in ...
Adam Menczykowski's user avatar
1 vote
1 answer
132 views

Locale case sensititvity on AWS instance

I have a multilingual Craft CMS site working perfectly on my local instance, OS X 10.10.5 running Apache 2.4.16, and so I moved the site to AWS, Amazon Linux 4.1.13-18.26.amzn1.x86_64 also running ...
graney's user avatar
  • 173
0 votes
1 answer
144 views

How do I set up same site to use two different subdomains?

I have to set a the same site on two different subdomains. I have the two subdomains included in the config.php. But that doesn't seem to work. Is there any other configurations I need to set? // ...
julzmon's user avatar
  • 941
1 vote
1 answer
500 views

CP not loading on Forge Server with PHP 7

I uploaded a working install of Craft Pro 2.5.2754 to a brand new Laravel Forge server and I'm having issues with the control panel. More precisely, it returns an error 500 when I try to access it. ...
Thierry Fortier's user avatar
2 votes
1 answer
243 views

Plugin Multi-Environment config not working

I have set up the plugin's multi-environment configuration as outlined in this answer. The config.php file for the plugin is as follows: <?php return array( // All '*' => array( ),...
acarbonaro's user avatar
0 votes
1 answer
138 views

Show larger images in control panel entries

Is there a way to show the images in the control panel entries (both in the detail of the entry and in the overview list using the new customisable columns in 2.5). The standard preview of the images ...
Tim Bertens's user avatar
1 vote
1 answer
918 views

Why would Craft produce a template loader error (TemplateLoaderException) when rendering its default error pages?

I'm getting a Template Loader Exception when I hit a 404 on my site: Craft\TemplateLoaderException Unable to find the template “error”. (/craft/app/etc/templating/twigextensions/TemplateLoader.php:...
Michael Rog's user avatar
  • 3,420
2 votes
1 answer
47 views

Sub domain install options

How can I setup sub domains on a single domain to allow development of multiple Craft client sites. I tried dev1.domain.com and dev2.domain.com and it tells me I need to upgrade license since I need ...
Bryan Garrant's user avatar
2 votes
1 answer
254 views

Is it possible to install Craft on a cPanel temp user URL?

When you create an account in cpanel you can use a URL to access it like http://ip/%7Eusername/, which is basically http://ip/~username/. Since the client is not ready to take down their old site and ...
Bryan Garrant's user avatar
1 vote
0 answers
51 views

Wrong siteUrl chosen in multi-environment config [duplicate]

I have following setup for my site urls (after other testing domains): return [ '*' => [ 'omitScriptNameInUrls' => true, 'usePathInfo' => true, '...
exophunk's user avatar
  • 383
1 vote
1 answer
68 views

Craft internal error exposing sensitive data

I have a craft installation and recently my server had issues and on the page rendering mysql and other errors were shown. Of course this creates security implications. Is there a way to restrict ...
paptom's user avatar
  • 11
1 vote
3 answers
187 views

Craft pieces accessed by people on domain only

How would you make portions of Craft available to only people that are "on the domain" and then let the rest of it be public facing? Would you need two instances of craft on 2 servers? One which is ...
Exziled's user avatar
  • 293
2 votes
1 answer
529 views

Laravel Homestead & Craft: Craft can’t connect to the database with the credentials in craft/config/db.php

I'm following these instructions to Setting up a local dev environment for Craft CMS with Laravel Homestead. When I go to http://my-craft-site.dev/admin, I get: Craft can’t connect to the database ...
komplexb's user avatar
3 votes
1 answer
674 views

Custom Environmental Settings

Is it possible to use custom environmental settings with Craft? I have separate web services that I use in production and development environments. I would like to programmatically point to the ...
Kevin's user avatar
  • 73
4 votes
3 answers
3k views

How do i get variables from general.php

Within the config folder there is a general.php file with various vars which are site specific. how do i get at these from within a plugin? Thanks for your help.
garyconstable's user avatar
6 votes
3 answers
1k views

Multi-locale pages 404 on subdirectories

I'm developing and running a Craft site locally through Laravel Homestead and am having issues with pages 404'ing in a multi-locale setup. I've followed this guide closely: https://craftcms.com/docs/...
Tyler's user avatar
  • 61
3 votes
2 answers
555 views

Localized Environment Variables Based On siteUrl?

I am setting up a multi-language site so far so good - everything is pretty obvious what to do. I am curious if there is a way/best practice to have the environmentVariables array configured so that ...
Damon's user avatar
  • 4,706
3 votes
1 answer
282 views

Is it possible to override the default session notices?

I couldn't find anything on here about this. Maybe I'm the only one, but for example when you log in there is a session notice with the message "Logged in.", but I want it to display something like "...
Alec Ritson's user avatar
  • 4,539
3 votes
2 answers
3k views

File robots.txt needed in Craft package?

I dont understand why we need the robots.txtfile in the Craft CMS package. I think it is confusing. (I had a problem with Google indexing one of my BETA hidden website because of that.) Reason : When ...
Miguel Bocquier's user avatar
1 vote
1 answer
129 views

Using Composer to Manage Site-Level Dependencies

I would like to use Composer to manage dependencies for my site, like Twitter's Bootstrap. Is there a recommended way to integrate Composer with Craft to support managing this type of Global ...
Jay Haase's user avatar
  • 265
6 votes
1 answer
2k views

Getting environmental variable via plugin

A similar question was answered before, but I was wonder how I might be able to return the same query from within a plugin (php)? Convert this: {{ craft.config.environmentVariables.baseUrl }} To ...
Mark Notton's user avatar
  • 2,337
1 vote
1 answer
42 views

Is it possible to configure the FileLogRoute?

I am trying to debug a "clean template cache" task that gets stuck. However, it only happens intermittently, and whenever I notice any errors has already been rotated out of the log files. Is there ...
gromgull's user avatar
  • 631
2 votes
1 answer
1k views

Home page won't load without 'index.php'

On a fresh install of Craft 2.3.2644, using the hostname alone, example.com returns an error, "The page cannot be displayed because an internal server error has occurred". If I include /index.php (...
Philip Jones's user avatar
0 votes
0 answers
276 views

Multi-environment config SERVER_NAME not working

I have a problem with multi-environment variables. I have used this before on a site and it worked perfectly, but now I'm on a different host and it seems that my SERVER_NAME isn't checked. Every ...
Tom De Smet's user avatar
  • 1,456
1 vote
2 answers
726 views

Solution to default template with all possible fields and determine position

Banging my head on this one and have not been able to come up with a solution to this. I'm wanting to create a default template for all single entries that checks for all of the fields I have created ...
Bowenac's user avatar
  • 811
1 vote
2 answers
821 views

Any plugins to add drop down for selecting template?

One of my biggest issues with craft so far is having to type out which template file a section is using, I don't understand why we don't have a location to enter all our possible templates, which ...
Bowenac's user avatar
  • 811
1 vote
1 answer
446 views

Receiving 'template loader exception' when trying to view asset (image) after upload

Anyone ever encounter this error when trying to view an asset (image) after upload? I'm working in homestead and everything appears to be compiling correctly, however the images don't render in the ...
Ryan Fleming's user avatar
0 votes
1 answer
2k views

Problem with @font-face url 500 server error craft style

So not sure what the problem is really have tried a few ways but I can't get font-files to work. I have placed my font files in root/craft/templates/assets/fonts/bootstrap Here is an example of @...
Bowenac's user avatar
  • 811
7 votes
1 answer
1k views

Do I need the web.config file in the craft root directory?

I'm working off of a linux machine (Apache) I don't use the web.config that's found in /public/web.config. I will use the .htaccess file. I am curious if I can remove the web.config file from /craft/ ...
Damon's user avatar
  • 4,706
1 vote
1 answer
238 views

Craft-Multi-Environment-Config redirects to dev url on admin login

I'm using the Barrel Stength Craft-Multi-Environment-Config to have a dev and live site configuration. On my local dev install, under Settings > General I've changed to Site URL to {siteURL}. On ...
Leah's user avatar
  • 441
2 votes
1 answer
1k views

omitScriptNameInUrls is not working

I think I've just about hit my wits end here. I'm trying to get set up on a new Rackspace server and I can't seem to get my URL rewriting to work properly. Here's what I got so far: My Craft install ...
Jon's user avatar
  • 345
0 votes
1 answer
335 views

How is appID used in caching?

I want to ensure that cache is set per domain at a config level. So rather than saying something like this in the template: {% cache using key craft.config.getHostInfo ~ '.' ~ entry.slug ~ '....
Russ Back's user avatar
  • 1,503
2 votes
1 answer
886 views

Using an IP address in config/db.php

I'm trying to set up multi-environment configs. I have specific db settings I want to change depending on environment. I am using localhost and my Digital Ocean server IP address in my db.php file. &...
Nick's user avatar
  • 217
8 votes
1 answer
1k views

Query table in a different database

I'm writing another plugin for my craft app, this time I'm attempting to reuse a MySQL table that's used by other applications as well. I've a class extending the BaseRecord, and getTableName() will ...
charmeleon's user avatar
2 votes
1 answer
545 views

Replacing core services

I'm relatively new to CraftCMS, so feel free to smack me upside the head if I'm missing something obvious. We have an ElasticSearch provider that I'd like to use instead of Craft's default search. ...
ninjascript's user avatar
1 vote
1 answer
122 views

Language link not working for me

I've tried the LanguageLink and the last solution described here: How can I build a language switcher? but it never returns any URI. I'm not using translated slugs. As setup I've used: http://...
imnotsure's user avatar
  • 199
0 votes
1 answer
2k views

Using relative paths for assets for heroku deployment

I cant quite wrap my head around the way the way the heroku file system works, so I'd like to use relative paths for my asset File System Paths. Is that even possible? I've tried to use ...
kenyabob's user avatar
  • 121
2 votes
1 answer
149 views

$craftPath multiple enviroments

I am new to Craft and am trying to figure out what the best way to set the $craftPath PHP variable to something like the other configurations for multi-environments. Locally I have it set up the ...
nerdology's user avatar
9 votes
1 answer
2k views

How do you set up Craft CMS to back up your site automatically?

I am considering having my site moved from WordPress to Craft CMS (feel free, by all means, to weigh in on this consideration), and wondered how one goes about setting up automatic backups within ...
Gina's user avatar
  • 101
3 votes
1 answer
480 views

Errors with Craft 2.3, Imagine and Imagick

Does anyone else have the same issue? Post the recent Craft 2.3 update all image transforms on my server (about 6 craft sites now) are throwing errors on new transforms. Specifically write errors ...
Tom Carwardine's user avatar
2 votes
1 answer
1k views

How to configure Craft to use a Proxy?

I have a Craft application in an intranet behind a proxy. I'm struggling to find a way of configuring the application so it can access the internet via the proxy, in particular for the auto updating ...
SierraRomeo's user avatar
4 votes
2 answers
3k views

General Settings > logo in the template

I have uploaded a logo in the General Settings, which I understand changes the logo on the login page. I was wondering if there was anyway to display this same logo in the site's template? I know I ...
Andy H's user avatar
  • 41
1 vote
1 answer
376 views

User activation success path not working (Craft v2.3.2621)

I'm at a loss. I've set up a font-end user activation workflow that looks like this: User registers via a front end form based on Craft's example form User is redirected to a page informing them that ...
Adam Snetman's user avatar
2 votes
1 answer
1k views

Multi-Environment Config using port in database server

I'm in the process of creating a multi-environment config and my client has set up a staging server with non-standard ports for the mysql server. I am unsure how to add the port number in the config ...
RhealPoirier's user avatar
1 vote
1 answer
193 views

Something went wrong when processing the logo

I've just installed Craft on a new Laravel Homestead environment and all seems to be running fine, with the exception of being able to upload a logo in the General settings. The logo uploads and ...
Russ Back's user avatar
  • 1,503
2 votes
1 answer
599 views

Subdomain database configuration picking up root domain config

So I have this example database config setup $customDbConfig = array( '*' => array( 'tablePrefix' => 'craft', ), 'test1.foo.com' => array( 'server' => '...
Iain Urquhart's user avatar
1 vote
2 answers
412 views

Pass URL parameter through General Config file

This may sound a little odd so let me explain what's going on. In my current setup I have allowed new users to sign up. I want these users to follow this flow: Fill up sign up form and submit Gets ...
cballenar's user avatar
  • 1,409