Questions tagged [config]

Craft configuration and settings.

17 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
103 views

Can you make Craft 2 Stateless?

So we are moving to Google App Engine Flexible which means we cannot store sessions on files. So I wanted to know if anyone has been able to make Craft 2 Stateless and how was it accomplished? Thanks....
2
votes
0answers
231 views

baseUrl and trailing slash Craft 3

Despite setting baseUrl alias with trailing slash it appears it gets stripped off in Craft 3. CRAFTENV_BASE_URL="https://domain.test/" 'aliases' => [ '@siteUrl' => getenv('...
1
vote
0answers
38 views

Redirect to frontend login form after receiving email verification mail from CMS?

I'm working on a site with public registration and a manual approval flow for new users. The following settings for user accounts are active: Verify email addresses, Allow public registration, Suspend ...
1
vote
0answers
92 views

Craft 3 multisite: site specific config

I'm trying to do something like this in general.php config for a multi-site setup: // ... 'production' => array( 'myVariable' => array( 'site1Handle' => '111', '...
1
vote
0answers
173 views

How do I get Craft custom settings from inside a module?

Additional settings added to config/general.php are placed in _customSettings private object. This means they cannot be retrieved using Craft::$app->config->general->someCustomSetting. How ...
1
vote
0answers
408 views

Strange Redactor Config error when importing colleague's database

Description I am getting this error after importing a database supplied from my colleague. I have deleted the vendors directory and composer lock file in an attempt to re-install Redactor. I have ...
1
vote
1answer
88 views

Allowing CRAFT_TEMPLATE_PATH in index.php from .env variable

It appears on Craft 3.1.8 that I can't set the CRAFT_TEMPLATE_PATH from .env without throwing a PHP notice error. This appears to be because the .env is loaded after the defines and I want to access ...
1
vote
0answers
390 views

HTML Purifier Allow <script

I understand the implications of having a script tag in my redactor field. But I am importing approx. 5k articles in to a Redactor field, some of which have various tags from embedded Podcasts, ...
0
votes
0answers
38 views

baseCpUrl doesn't seem to work as I'd expect

We have a couple of different repos doing various things all on the same URL. All of these have a web folder equivalent and want to be above the root. With that in mind, I've set up the following ...
0
votes
0answers
16 views

Can control panel date display always be numeric?

I understand the display of entries' postDate, etc., in the control panel can be localized, but I'm wondering if it's possible to get rid of the "yesterday" and "today" designators,...
0
votes
0answers
73 views

Config baseUrl / assetBasePath

I've been away from using Craft (and web development in general) for a while now. I'm having trouble getting the assets paths working for a site in my config, I gather things have changed since I last ...
0
votes
0answers
15 views

Different unix users for Craft config and Craft process

I want to configure Craft to run as user craftcms and have configuration owner craftowner. The purpose is to make configuration read-only to craftcms, so that there can be no changes to the ...
0
votes
0answers
25 views

Updating user email does not update username when useEmailAsUsername is set

When the config setting useEmailAsUsername is set, I would expect updating a users' email address to also update the username field when saving the element. However, this does not occur unless you ...
0
votes
0answers
195 views

Multisite with unique domains not working with Forge config

I have a live install with a primary domain of https://marketing.vessul.co/ which works great. When I've added another site to this install and it's location is another folder such as /extra-site it ...
0
votes
0answers
28 views

Copy Live to a Test site on same domain?

I have copied my Craft 2.6 live site directory, and created a test directory on our webserver in an effort to create a test site. Also duplicated the db and changed the configure files to point to the ...
0
votes
0answers
1k views

Craft can’t connect to the database with the credentials in craft/config/db.php

I'm trying to upgrade from 2.7.10 to Craft 3. I follow the instructions/ docs to the letter, go to https://###.com/admin and am greeted with the above can't connect to database message. So far, I ...
0
votes
0answers
259 views

Multi-environment config SERVER_NAME not working

I have a problem with multi-environment variables. I have used this before on a site and it worked perfectly, but now I'm on a different host and it seems that my SERVER_NAME isn't checked. Every ...