Questions tagged [composer]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
1answer
89 views

Where exactly to update the composer.json to install an older version of Craft 3?

I'm trying to install a non-current version of Craft 3, and several pointers on using composer to do this say to "update the composer.json" line with the version you want. Can someone please ...
8
votes
7answers
17k views

"Unknown package has no name defined" composer error on upgrade

Upgrading from Craft 3.4.20 running Composer 1.10.17 on PHP 7.2. Running ./craft update all returns the following error: error: Unknown package has no name defined. [followed by JSON object related to ...
0
votes
0answers
16 views

Craft Publisher: composer.json: command not found when set up cron job at Craft Nitro

I'm trying to install the plugin Publisher at my local (Craft Nitro), when I try to set up the cron job, based on the documentation, I keep getting the error 'composer.json: command not found' It ...
1
vote
1answer
91 views

Weird issue with craft/setup command

I have been trying to install Craft CMS on Windows. I tried composer: composer create-project craftcms/craft d:\temp\craft After that when I try to craft setup there is a loop on the console which ...
1
vote
1answer
42 views

Configure path craft uses for composer and php

Is it possible to configure the PATH to composer that craft is using? In a shared hosting (our server, lots of sites) php isn't available by default. It's provided via redhat software collections. ...
1
vote
1answer
89 views

Error when trying to update Craft or install any plugin

When I try to update Craft, or install any plugin from the plugin store, I get the following error): Composer was unable to install the updates. Error: The url supplied for the path (plugins/redactor)...
1
vote
1answer
21 views

Class '...SiteModuleService' not found when used inside scout.php

I have a custom SiteModule that is used inside scout.php to deliver indexing data to Algolia. I have followed CraftQuest's tutorial on creating a custom SiteModule for handling the indicies. The setup ...
2
votes
1answer
190 views

What is the correct way to update a production site with composer?

I disable admin updates on production sites, and update Craft and its plugins by updating in the development environment, and then deploying to production using Git. My basic process starts like this: ...
2
votes
1answer
100 views

Error with Craft CMS set up and composer: failed: SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: YES)

Hi I am trying to set up craft CMS with composer. I am using MAMP on a mac and I just cannot get it to connect. I get this error even though I know the password is correct. failed: SQLSTATE[HY000] [...
1
vote
1answer
56 views

Why does Bootup.php run with PHP 5.4.16 from with Craft script but PHP 7.4.10 from the terminal command line?

This is a problem encountered apparently by a lot of users when installing from the Craft setup/install files from the Craft web site. PHP Warning: Unsupported declare 'strict_types' in /var/craft/...
1
vote
1answer
215 views

"Could not find composer.json file" error in CraftCMS 3

I recently updated my CraftCMS 3 with the help of Composer. When I try to install a plugin with the plugin store, I get an error saying that Craft couldn't find my composer.json file. He proposes me ...
1
vote
1answer
92 views

Testing database credentials Craft 3 Setup

When i try setup db in craft 3 at windows with composer using php craft setup/db command it give me Which database driver are you using? [mysql,pgsql,?]: pgsql Database server name or IP address: [127....
1
vote
1answer
82 views

There are no sites in the config file on nitro add

When i try nitro add command to they return "There are no sites in the config file" what should i do? Unable to locate a webroot, setting to web. Enter the webroot [web] web Added tutorial....
1
vote
1answer
3k views

"Error: Unknown package has no name defined" when updating Craft 3

I'm getting "Error: Unknown package has no name defined" when updating a site from 3.0.41.1 to 3.5.15.1 I had read a reinstall of composer had fixed this for someone else, but hasn't for me. ...
1
vote
1answer
47 views

Can't install Transcoder plugin

Not sure whether I should be posting this here or as a Github issue, but when trying to install NY Studio's Transcoder plugin, I get: Composer output: Package "craftcms/vue-asset" listed ...
1
vote
1answer
22 views

dev- branch plugin forks being prompted for update

I'm currently using a fork of a plugin for my site, and using a "dev-[branch-name]" version specification in the composer "require" block, with a "vcs" repository ...
1
vote
1answer
23 views

Craftnet API package query

Does querying composer packages via the Craftnet API need authentication? Ref https://docs.api.craftcms.com/packages.html Querying the Craft CMS package itself is fine, eg https://api.craftcms.com/v1/...
1
vote
1answer
587 views

Craft CMS issue with Composer V2

We have a website built in Craft 3.4.14 and we are moving it to a hosting company with CentOS 7, using Plesk Obsidian 18.0.5. The hosting company has told us that they have upgraded Composer from ...
4
votes
2answers
4k views

"Craft isn't installed yet" error after updating to Craft 3.1

I just updated to Craft 3.1 and logged into the admin to make the required updates to the database and this all worked fine. However, when I use the new ./craft update CLI feature, it responds with "...
2
votes
1answer
7k views

composer update missing zip extension (ext-zip) on MacOS

When doing a composer update in a Craft project on MacOS Catalina, I suddenly get the following error: ***** requires ext-zip * -> the requested PHP extension zip is missing from your system. Any ...
0
votes
0answers
52 views

How to move a plugin from dev to prod?

I have a plugin that I developed in a symlinked folder locally. I now want to deploy it to production. But when I do composer require namespace/pluginhandle it gets symlinked. What I want is to ...
1
vote
3answers
1k views

How do I get past this MySQL error installing Craft 3 using CLI

I am using https://box.scotch.io/ (vagrant). I'm trying to install Craft 3 with the cli, but can't get past these errors: Connection refused No such file or directory One or the other error shows ...
5
votes
5answers
18k views

Carbon 1 is deprecated - migrate to Carbon 2

Is anyone getting this when running a composer update command? Local install: Craft CMS 3.1.31 update --no-interaction --ansi  Loading composer repositories with package information  Updating ...
1
vote
1answer
787 views

Allowed memory size of 1610612736 bytes exhausted when updating via CLI on OS X

This one has been bugging me for months. My development environment is running on MAMP on OS X. It's worked absolutely find for ages but for no reason that I can identify all my Craft sites now ...
2
votes
1answer
481 views

PS-4 Autloading custom module

I have created a module in modules/Core.php which works great and I can reference it using modules\Core::class. But I want to re-organise my modules. I'm not super familiar with PSR-4 loading but I ...
2
votes
1answer
303 views

How to manage breakpoint releases when updating Craft via composer

When logged in to Craft, the "Utilities" tab will show you all the latest releases you can update to. In some cases, it will report that you have reached a breakpoint release: You’ve reached a ...
1
vote
1answer
59 views

Update issues on local laravel valet

When I update any plugins ( and I mean any not specific) the vendor package vlucas (Php DotEnv) is removed and the site subsequently breaks complaining it cannot find the DOT env file. Manual update ...
1
vote
1answer
600 views

composer.json file not updating when plugins are updated

My composer.json file doesn't update to the latest plugin versions when I update my plugins via the Craft CP or command line.
1
vote
1answer
31 views

Faceted navigation plugin problem installing

I get the errors below in the Command Prompt when trying to install. helloswish/craft-faceted-navigation Does anyone know why this is not working? [InvalidArgumentException] Could not find a ...
3
votes
1answer
169 views

Composer require looking to craft/plugins/[plugin] directory but throws runtime error?

I've got Craft 3.1.32 up and running on dev machines and we're ready to get it into our test/stage enviromnments, which are built through a GitLab CI/CD. While doing this, we noticed some plugins ...
3
votes
3answers
940 views

cannot update Craft CMS - composer errors

I'm upgrading a site to 3.0.41.1 (not ready to go to 3.1) and when I do I get the following error. How do I resolve this? composer update craftcms/cms Loading composer repositories with package ...
6
votes
4answers
4k views

Craft 3 Command setup failing

I've installed Craft 3 through composer and I'm attempting to work through the setup process within terminal: MacBook-Pro:~ jamie$ ~/Documents/repos/__craft-3-beta/craft setup Which database driver ...
1
vote
1answer
2k views

Getting my head round installing plugins from the command line

My command line skills are limited but I’m trying to be better. I’ve been using composer successfully for a while to initiate Craft installs, but then subsequently using the Craft web GUI to install ...
2
votes
1answer
42 views

Possible to reflect changes to a plugin's composer.json without uninstall/reinstall?

When working on a plugin recently, I decided to add a CP section: composer.json { ... "extra": ... "hasCpSection": true ... } The only way that I was able to have this ...
1
vote
1answer
449 views

upgrade issue Yii Framework from version 2.0.15.1 to 2.0.16.1

I tried installing a site I developed on my work mac (high sierra), pushed to its repo, pulled it down at home on my mac (mojave)and on running composer update get this displayed in my terminal: ...
1
vote
0answers
242 views

Every time I perform updates on Craft 3, I get errors

What is going on in Craft 3, seems like Composer has caused more problems than good. Every time I have had to update a dev/staging environment I run into issues and have to go and manually update the ...
1
vote
1answer
3k views

How do I resolve dependency conflicts in Composer?

I'm new to using Composer and I'm having trouble deploying to Laravel Forge. I am getting an error message that says: Your requirements could not be resolved to an installable set of packages. ...
1
vote
2answers
501 views

Getting fatal error when installing new plugin by hitting memory_limit

I am trying to locally install Craft Typed Link Field from the plugin store and I'm getting this PHP error. I have already upped my memory_limit to 256M within my php.ini file, yet this is claiming ...
1
vote
1answer
826 views

Install Zoho CRM SDK (or any SDK for that matter)

For a client I need to connect a rather complex contact form with the Zoho CRM. They're offering a PHP SDK which sounds great, but I can't get it to work. It's very likely that I'm just stupid, ...
1
vote
0answers
65 views

Installing module via composer

I followed this question like: ... "repositories": [{ "type": "vcs", "url": "git@bitbucket.org:jorgeanzola/mymodule.git" } ], ... "require": { "craftcms/cms": "^3.0.0", ... "...
1
vote
1answer
49 views

Error running any Composer command

I am working on a project with multiple developers and another member of the team is getting on with a Plugin to assist with some CraftCommerce integrations. As it's not a publicly available plugin, ...
1
vote
1answer
299 views

InvalidArgumentException with composer

I need your help, please. At https://docs.craftcms.com/v3/installation.html#step-1-download-craft I have this instruction: "To create a new Craft project, run this command (substituting with the ...
1
vote
1answer
200 views

How to Prevent Composer from Updating Plugin?

I have a plugin installed from a well known Craft developer. I have made significant tweaks and changes to the plugin and need to prevent it from updating. Is there an easy line of code to add to the ...
1
vote
2answers
791 views

Problem setting security key when installing Craft 3

I'm new to Composer and am using a Mac along with MAMP as a local web server. I've installed Composer but it's referencing an old PHP 5 version that must be the default on my Mac. I was able to ...
1
vote
1answer
760 views

Composer conflict when installing craftcms/plugin-installer

I have installed composer successfully but when I try to add: composer require craftcms/plugin-installer I get the following: Your requirements could not be resolved to an installable set of ...
1
vote
2answers
321 views

How can I install Craft Commerce 2 alpha release?

I tried following the installation instructions here: https://docs.craftcms.com/commerce/v2/installation.html When I run composer install craftcms/commerce, it says: Invalid argument craftcms/...
1
vote
1answer
938 views

Migrate path from 2 to 3?

Anyone have experience updating a CraftCMS site from 2.* to the 3-beta? I'm not in dire need of this at the moment, but can't seem to find it in the developer resources. EDIT: Found the upgrade guide ...
1
vote
2answers
219 views

Craft CMS module composer dependancy

After some research surrounding this I can't seem to fix this issue. So for a project I made a simple module with some variables that simply has to make an OAuth1 call and return some data. The ...
1
vote
1answer
272 views

Install suggestions?

This happens on every install (see below suggestions) via Composer on a MAMP Pro stack, running PHP 7.1, Mysql 5.7 & Composer 1.7.2. Albeit suggestions, could this affect the performance or ...
1
vote
1answer
111 views

Issues with Redactor on Local Install

I loaded redactor. When I try to run the install command ./craft install/plugin redactor I get an error back that says craft is a directory. It appears the plugin may already be installed. But I do ...