Questions tagged [404]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
1answer
99 views

Security test generated large compiled_templates directory, site outage

We just moved an installation of one of our sites to a new server. Previously, it was on a machine where the versions of Ubuntu / PHP prevented us from upgrading the Craft core version from 2.3.x to 2....
2
votes
2answers
4k views

Craft not loading custom 404 template for errors

Whenever I hit a non-existent page on a dev site, I only get Craft's native 404 page, not the one I have at /craft/templates/404.html. The site has no routes. Any ideas why this might be?
5
votes
2answers
2k views

Craft 3 404 and 503 pages in devMode

Is there any way to get Craft 3 to display 404.html and 503.html for the 404 and 503 pages while in devMode, as it did in Craft 2, rather than returning the entire Yii 2 error stack? Sometimes, we ...
5
votes
3answers
941 views

Multi-locale pages 404 on subdirectories

I'm developing and running a Craft site locally through Laravel Homestead and am having issues with pages 404'ing in a multi-locale setup. I've followed this guide closely: https://craftcms.com/docs/...
3
votes
3answers
4k views

Assets (images) return a 404 on the front-end

I have the following issue which I can't seem to wrap my head around. All images assets uploaded to Craft return a 404 not found on the front-end. Everything works fine in the admin CP though (...
1
vote
1answer
698 views

Craft CMS 3 admin panel returns 404 with SSL

I'm using MAMP Pro for local development and was gong to set up my site with SSL this time around. I got a self-signed cert for local dev and I can go to my development site over https:// without any ...
1
vote
1answer
893 views

404 page redirect to homepage

Is it possible to set up a 404 page, and after x amount of time redirecting to the homepage? {% extends "_layout/_layout" %} {% set metaTitle = "404" %} {% set bodyId = "404" %} {% set ...
0
votes
1answer
459 views

Admin entries 404'ing

I've transferred a Craft site (I didn't build it) from staging to production. All the existing content is showing up on the front end but when I try to edit entries that aren't static pages, the edit ...