1

just bought the Sprout Business Collection since i've been playing around with Sprout forms during the beta periode and now needed to implement email features.

One problem i'm running into. After installation i tried to create a new notification. First screen no problem. Enter name, template, field layout. After saving the ADD NOTIFICATION ENTRY button appears. But clicking that gives me the following error (translated from dutch so possibly not exact).

The attribute "Craft\WebApp.userGroups" is not defined.

Below you'll find a link to the craft.log since it contained more detailed information about the error.

https://www.dropbox.com/s/svebqtfgppnhvug/sprout_email_error_craft.log?dl=0

Hope someone can point me in the right direction.

Bas

  • Hi Bas, Jeroen and Brad are right. This is probably an error being thrown by the option to send a notification email using the On Save User Event. We can handle that error more gracefully. We'll follow up with your support request and be in touch. – Ben Parizek May 15 '15 at 16:31
  • I've contacted Brad via email to inform him of this thread. So hopefully they will have a solution for this soon. – Bas van Ginkel May 18 '15 at 7:29
3

This issue has been resolved in Sprout Email v1.0.4

1

Looks like it needs Craft Pro and you're running either Personal or Client which don't have user groups.

  • Agree with Jeroen. Bas, I'll also add that you might want to contact the Barrel Strength folks so that they can more gracefully handle this instead of it throwing an error. – Brad Bell May 15 '15 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.