7

I just moved my site from one MediaTemple (gs) instance to another. I copied and recreated the database on the new server, moved over all the files, and updated the internal references that pointed to the old site. I even cleared out the 'craft/storage/runtime/' folder.

Whenever I am logged in, I almost instantly get logged out. Typically, this is after 30-60 seconds.

enter image description here

Whether or not I enter in the correct password, the same message comes back up. However, I can go back to the main admin page, and I'm still logged in.

Any ideas what's going on? It seems to be a caching and session issue of some sort, but there is no caching setup on our server, and I cleared my browser cache completely.

10

Most likely wherever Apache/PHP is configured to save session files doesn't exist or isn't writable.

If you've got the overridePhpSessionLocation config setting set to true, then that will be in craft/storage/runtime/sessions folder.

| improve this answer | |
  • 1
    Thank you very much. This appears to have solved the issue. I went ahead and added the overridePhpSessionLocation config setting and deleted the whole craft/storage/runtime/ folder. When I logged in again with a private browsing window, Craft recreated all the necessary runtime cache files, and I'm not getting logged out any longer. – jsilton May 7 '15 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.