0

I am totally newbie in Craft CMS so don't be harsh to me.

While coming to my problem I am getting Error : 404 while installing Craft CMS on my local server Linux Mint OS please someone guide me to install Craft CMS successfully on my local server,I followed below basic steps..

  1. Created db gave db details in db.php.
  2. Renamed htaccess to .htaccess.

My folder structure was

/var/www/html/Craftdemo/craft and public

My local server configured correctly and is working good enough to run my other sites like Wordpress/Magento and some JS files.

Thanks in advance

1

Nobody is going to be harsh here, so don't worry. The Craft community is a nice place :-)

Sounds like the site root is not pointing to the Craft public accessible folder (the one with index.php). Can you open the URL to another file in the site root? Add a test.txt file for example and try to open it in your browser.

Regarding the .htaccess file: You are using apache, right? .htaccess doesn't work for nginx. Might sound obvious, but you wouldn't be the first to make this mistake. ;-)

| improve this answer | |
  • Hey thanks for kind words my root works fine all my Magento/Wordpress and some Javascript programs will run without any error from same root and .htaccess works fine for me best example was my WP Sites. – dh47 Apr 8 '15 at 4:24
  • Did you create a virtual host for Craft (recommended way)? Or are you accessing it at something like localhost/Craftdemo? Does craftcms.stackexchange.com/questions/1485/… help? – user155 Apr 9 '15 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.