1

I'm trying to launch a basic "yiic migrate create BasicMe MyPlugin"
But every time the memory gets exhausted, whatever memory_limit I set (I even tried 8Gb).

Fatal error: Allowed memory size of 3279945728 bytes exhausted (tried to allocate 72 bytes) in /path/to/craft/app/framework/base/CComponent.php on line 266  

Any idea what's causing it ?

Nicolas

5
  • Sounds like an infinite loop somewhere eating up all the memory. Any stack trace getting logged in craft/storage/runtime/logs?
    – Brad Bell
    Apr 3, 2015 at 15:56
  • just in the phperrors.log file PHP Fatal Error If I output $name from __call function, I get "getTranslatedBrowserLanguage" Apr 3, 2015 at 16:08
  • Are you on the latest version of Craft? I vaguely recall a bug similar to this that was fixed.
    – Brad Bell
    Apr 3, 2015 at 16:11
  • "You're up to date" it says. Apr 3, 2015 at 16:43
  • If you have xDebug setup, you can set a breakpoint on yiic and step through and see where the loop is. Otherwise, if it's on a publicly accessible box and you want to throw some SSH credentials to support@buildwithcraft.com, we can look into it.
    – Brad Bell
    Apr 3, 2015 at 17:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.