0

Any help with this appreciated. A few months ago my colleague installed Craft CMS successfully on our clients server; He got the monkey and everything!

We sort of left it at that, as we had plenty of other things to do as well, but now we're ready to transfer the design into Craft.

We were getting login issues saying the db config was wrong. It transpired that the MariaDB had died on the centos server and needed to be restarted. After that was done, everything was working, but a few minutes later it died again. We did a full server reboot and again, Craft worked fine.

I ran the update to 2.3 and that apparently installed nicely.

Then I went to tweak the admin account, when I submitted the save, I received the following error:

Internal Server Error

CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 145 Table './Craft/craft_searchindex' is marked as crashed and should be repaired

We've not touched craft since the install and wondering how to go about fixing this, or if anyone else has come across this problem.

Any help much appreciated and free hugs and cookies too.

3
  • The answer here should get you sorted: craftcms.stackexchange.com/a/5314/57
    – Brad Bell
    Mar 17 '15 at 15:39
  • Oh thanks Brad, that was quick. Definitely in-line for that cookie if this works :) Hopefully be able to run the repair later. Many thanks.
    – Pathfinder
    Mar 17 '15 at 15:44
  • No worries... going to vote to close this as a duplicate just to keep things tidy. :)
    – Brad Bell
    Mar 17 '15 at 15:45

Browse other questions tagged or ask your own question.