0

I purchased the Dukt Videos plugin and when trying to connect with one of the services (Google or Vimeo) I'm met with the following fatal error:

( ! ) Fatal error: Class 'OAuth\Common\Storage\Session' not found in /home/forge/website.com/craft/plugins/oauth/providers/BaseOAuthProviderSource.php on line 51
Call Stack
#   Time    Memory  Function    Location
1   0.0001  242088  {main}( )   ../index.php:0
2   0.0002  243000  require_once( '/home/forge/website.com/craft/app/index.php' )   ../index.php:36
3   0.0392  3729440 CApplication->run( )    ../index.php:62
4   0.0392  3731160 Craft\WebApp->processRequest( ) ../CApplication.php:180
5   0.0617  4905776 Craft\WebApp->_processActionRequest( )  ../WebApp.php:263
6   0.0617  4906040 CWebApplication->runController( )   ../WebApp.php:756
7   0.0623  5054240 CController->run( ) ../CWebApplication.php:282
8   0.0625  5080680 CController->runActionWithFilters( )    ../CController.php:265
9   0.0625  5080792 CController->runAction( )   ../CController.php:286
10  0.0626  5081528 CInlineAction->runWithParams( ) ../CController.php:308
11  0.0626  5083200 Craft\OauthController->actionConnect( ) ../CInlineAction.php:49
12  0.0765  5789632 OAuthProviderSources\BaseOAuthProviderSource->initializeService( )  ../OauthController.php:120
13  0.0765  5789672 OAuthProviderSources\BaseOAuthProviderSource->getStorage( ) ../BaseOAuthProviderSource.php:124

This aspect of the plugin works on my dev env but when testing this on another separate install on my webserver this error keeps coming up.

Anyone have an idea how this can be fixed? Assuming it's not a plugin bug.

I have contacted the plugin developer about the issue but I'm concerned that I won't get a reply as I've asked him about another issue I encountered with the plugin about 2 weeks ago (with a follow up last week) and I did not get any reply. I've also seen that another member of this community had an issue with a plugin from the same developer and received no reply from the developer either. If this was a free plug in I wouldn't be expecting support but when you consider that the plugin costs €49, it's quite disappointing that there isn't a reply.

Thanks in advance!

1

Hey Daniel and sorry for the lack of response. Please get in touch at ben@dukt.net and I'll be happy to offer you the license hoping you'll accept my apologies for the huge delay in my reply.

Regarding your issue, it looks like some classes haven't been loaded (OAuth\Common\Storage\Session). Can you please check if Session.php file is present in OAuth plugin's folder under oauth/vendor/lusitanian/oauth/src/OAuth/Common/Storage.

Also, you might consider get a fresh copy of the latest release of the OAuth plugin and try to unzip/re-upload the files, I'm thinking you may just have some missing files and that could fix the problem, otherwise we'll dig further.

4
  • Thanks for replying Ben. I had tried re-downloading and reinstalling the plugins and it did not work. Following your comment however I tried it again using a different method (FTP instead of deploying with git) and it seemed to have done the trick - I'm assuming that there might have been some git ignore file that stopped all dependancies from being uploaded.. On another note did you have a look at the CSRF issue please? Mar 17 '15 at 10:02
  • @DanielParas Hey Daniel, I've just added CSRF support to all Dukt plugins :) Mar 28 '15 at 4:45
  • how do I download the update please? Mar 31 '15 at 10:23
  • @DanielParas You need to follow the link in the email you received when you purchased the plugin, it will take you to your receipt where you can download the latest version of the plugin. Let me know if you have any problem. Mar 31 '15 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.