2

We have two web servers in a load-balanced setup. Both servers are sharing a single database. The craft and public folders are rsync-ed between the two so changes on those folders in web1 propagate into web2.

We tried loading a video atom using the following twig:

{% case "video" %}
{{ atom.video(block) }}

It works on our local dev copy and on our staging server at AWS, however on our live site we get this error:

Getting an undefined method error

I tried copying the whole runtime folder from AWS over to the live web servers but that did not fix it.

Any ideas on how to get it to work? I would consider myself a novice to Craft so pardon me if there's something obvious that I'm missing.

Thanks in advance.

Update:

Already figured out that it was an error with the upload. Some macros were not properly copied over into live.

  • What is atom and video? Are they coming from a plugin? – Brad Bell Mar 2 '15 at 4:20
  • Thanks for asking this question. I went to double check both on our staging and live servers. The video atom thing is a macro that we made and it didn't exist on the live server. Must have been an issue with the upload. – Chuck Cerrillo Mar 2 '15 at 23:36
0

It is my bad. Thanks to Brad Bell, I went to check whether the macros were on both the staging and live servers. The macros existed on staging but not on live.

0

I've had this a couple of times, and have yet to figure out what causes it, but on my server deleting the compiled_templates folder (app/craft/storage/runtime/compiled_templates) fixes it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.