1

After a fresh install of Craft on my localhost, two problems occur:

1) The modal window to upgrade Craft only says "An unknown error occured."

2) Newly created singles are not editable, the edit pane stays empty with no input fields at all.

I looked into craft.log and there seems to be an issue with CHttpRequest.php, but I can't say if this is a local config problem or if it's a bug:

******************************************************************************************************
2015/02/25 13:08:35 [error] [php] Cannot modify header information - headers already sent (/Users/me/Sites/test-dev-craft/app/framework/web/CHttpRequest.php:1392)
Stack trace:
#0 /Users/me/Sites/test-dev-craft/app/framework/web/CHttpRequest.php(1329): Craft\CookieCollection->remove()
#1 /Users/me/Sites/test-dev-craft/app/services/UserSessionService.php(1170): Craft\CookieCollection->add()
#2 /Users/me/Sites/test-dev-craft/app/framework/web/auth/CWebUser.php(203): Craft\UserSessionService->renewCookie()
#3 /Users/me/Sites/test-dev-craft/app/services/UserSessionService.php(91): Craft\UserSessionService->init()
#4 /Users/me/Sites/test-dev-craft/app/framework/base/CModule.php(387): Craft\UserSessionService->init()
#5 /Users/me/Sites/test-dev-craft/app/etc/web/WebApp.php(569): Craft\WebApp->getComponent()
#6 /Users/me/Sites/test-dev-craft/app/framework/base/CModule.php(103): Craft\WebApp->getComponent()
#7 /Users/me/Sites/test-dev-craft/app/etc/web/WebApp.php(160): Craft\WebApp->__get()
#8 /Users/me/Sites/test-dev-craft/app/framework/base/CApplication.php(180): Craft\WebApp->processRequest()
#9 /Users/me/Sites/test-dev-craft/app/index.php(62): Craft\WebApp->run()
#10 /Users/me/Sites/test.dev/index.php(19): require_once()
REQUEST_URI=/test.dev/index.php/admin/actions/tasks/getRunningTaskInfo

This is my local setup:

  • Mac OS X 10.10.2
  • Apache/2.2.29 (Unix) DAV/2 mod_fastcgi/2.4.6 mod_ssl/2.2.29 OpenSSL/1.0.2
  • PHP Version 5.6.5
  • MySQL 5.6.22 - Homebrew

Any help would be highly appreciated!

  • I've also had this problem, running from localhost. Mac OS X 10.10.3 PHP 5.6.1 Mysql 5.5.38 – Chase Giunta Mar 5 '15 at 23:23
  • I'm getting this error locally too. PHP 5.6 – Sean O'Grady Mar 9 '15 at 23:30
2

I was having a similar issue and found a solution that worked for my setup: https://craftcms.stackexchange.com/a/9016/831

0

Cannot modify header information - headers already sent

That error means that something, somewhere has already started outputting to the browser before Yii/Craft/PHP expected it to happen.

99% of the time, it's some whitespace or unintended character that got added to the beginning of one of Craft's files.

Try doing a fresh upload of all of Craft's files and see if that helps.

  • Hi Brad, thanks a lot for your answer. I already tried a completely fresh install in a new folder with a fresh db etc. The only files I touched were the craft/config/db.php and the public .htaccess for the standard index.php rewrite. Any other suggestions? Maybe it's an encoding issue? – Matthias Ott Feb 25 '15 at 21:07
  • If you enable devMode, does any other helpful information get logged? – Brad Bell Feb 25 '15 at 21:14
  • DevMode did not show anything of help – as far as I can tell. The only thing that worked was setting display_errors to Off in php.ini. Not my preferred solution, but it works for now… – Matthias Ott Feb 26 '15 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.