18

I had to add an image size in the assets transforms; all my pics were previously uploaded, but when I use getUrl('headIpad'), it makes urls like this:

http://host.com/cpresources/transforms/4/

Instead of this:

http://host.com/uploads/team-photo/_headIpad/fall-back.jpg

I tried to use generateTransformsBeforePageLoad in my config but Craft generates an error:

Internal Server Error Image “fall-back.jpg” cannot be found.

Any ideas?

1
  • 1
    You should probably mark the question as answered if the solution under worked for you. It worked for me, at least.
    – peirix
    Nov 4 '14 at 14:55
17

If you simply go into your craft_assettransformindex table and empty it, that should trigger brand new transformations for everything.

2

Let me add, for those like me who just moved to a different server, before you dump the table, make sure your assets directory is writable by Craft. I did what Lindsey D suggested, and it recreated the table nicely (with no errors noted) but didn't actually create the images, because I didn't have the directory writable.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .