1

I uploaded and un-tar'ed a bunch of folders containing images under one of our local asset source folder. After triggering the "Update Asset Indexes" tool, and waiting for its completion, my asset table is still blank. Under "Assets", I can see all the new sub-folders but all are empty. I checked the file and folder permissions on disk, all are ok.

Looking into the database, the "craft_assetindexdata" show all the file path, but the "recordId" column indicate "NULL". Is there something else I need to trigger for this process to complete?

Using Craft Pro 2.3.2629

Thanks for your help.

  • Do you get an JS errors in your browser's console, or are there any relevant errors being logged in craft/storage/runtime/logs when you "Update Asset Indexes"? That should be all you need to do assuming all of your paths are correct. – Brad Bell Feb 6 '15 at 16:45
  • yep, error in jconsole... the fact that the job gave me a "checkmark" made me believe all was ok: – Mathieu P. Feb 6 '15 at 17:37
  • jquery-2.1.1.min.js?d=1423164000:4 POST cms.hopper.com/index.php?p=admin/actions/tools/performAction 504 (Gateway Time-out) jquery-2.1.1.min.js?d=1423164000:4 n.ajaxTransport.k.cors.a.crossDomain.send jquery-2.1.1.min.js?d=1423164000:4 n.extend.ajax craft.js:375 d.extend.postActionRequest settings.js:166 Craft.Tool.Garnish.Base.extend.postActionRequest settings.js:121 Craft.Tool.Garnish.Base.extend.loadAction settings.js:98 (anonymous function)jquery-2.1.1.min.js?d=1423164000:2 n.extend.proxy.n.isFunction.f velocity.min.js?d=1423164000:3 p v elocity.min.js?d=1423164000:3 c – Mathieu P. Feb 6 '15 at 17:45
  • not certain if this is related to the gateway time-out, but the baseUrl env variable for this domain is https (and the server only answer https). – Mathieu P. Feb 6 '15 at 17:59
  • hum... not sure if that was a cut-n-paste issue, but I does post to https: – Mathieu P. Feb 6 '15 at 18:19
2

Looks like you're getting an nginx gateway timeout error. Here is some info on how you can increase the time limit.

| improve this answer | |
  • Yes! that did it. I totally forgot about the fastcgi_read_timeout, I had it set to 90sec. Was too low for this job. 300 did it. Thanks!. – Mathieu P. Feb 6 '15 at 21:05
  • just so you know what stalker gives you points on a Friday -- and, I might need this sometime. Such as for Vagrant Homestead. – narration_sd Feb 7 '15 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.