4

I have created a new account and attempted to verify the account by clicking the activation link in the verification email. On doing so I get the following error.

Bad Request
Param “id” doesn’t exist.

Any ideas how I can resolve this issue.

I am running the latest version of Craft.

I have replicated the issue locally and on our staging server.

Thanks in advance

6
  • What is the URL in the browser when you click the link?
    – Brad Bell
    Jan 29, 2015 at 18:41
  • it looks like this: "/actions/users/setpassword?code=9a46516c-738c-40a7-974d-864d2d1093d6&id=ace5eb07-f6e9-461c-9f2a-df6859197b31"
    – magicspon
    Jan 30, 2015 at 9:06
  • Is that an actual garbled character in the URL or did it just copy/paste wrong? 0‌​
    – Brad Bell
    Jan 30, 2015 at 15:57
  • copy and pasted: actions/users/setpassword?code=6faaa0cd-d67d-4730-b191-0e72366fd648
    – magicspon
    Jan 30, 2015 at 16:08
  • Maybe some .htaccess rewrite rule is dropping querystring params?
    – Brad Bell
    Jan 30, 2015 at 16:58

1 Answer 1

3

I don't recall the specific version/build and my search-fu is weak today, but this was a bug in Craft that should have been fixed in a semi-recent build. Try updating to the latest and see if you still have the issue.

Update:

Every time we've been able to investigate this issue so far, it has been because of either .htaccess stripping querystring params behind the scenes (i.e. no [QSA] flag on the rewrite rule), or the equivalent in nginx-land.

4
  • I tried an update and still no luck with this issue. Any other ideas? Thanks. Feb 23, 2015 at 18:08
  • If this is on a public box and you want to send some CP/FTP credentials over to [email protected], we can further look into it and I'll update here with the results.
    – Brad Bell
    Feb 23, 2015 at 19:42
  • changing RewriteRule ^(.*)$ /index.php?/$1 [L] to RewriteRule ^(.*)$ /index.php?/$1 [L,QSA] fixes this.... thanks
    – magicspon
    Oct 12, 2016 at 10:34
  • I have the [QSA] flag set. But it still gives the id error
    – KSPR
    Nov 17, 2016 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.