4

Seems like I can't get the base install URL to work. To get Craft to show posts I have to format the URL as,

/public/index.php?p=news/2015/we-just-installed-craft

Instead of just the /news/2015/we-just-installed-craft

I think the .htaccess is getting read because after putting in garbage the server did error out when I used the /public/ URL but not sure what else I'm doing wrong or how I could troubleshoot this.

3

Try setting 'usePathInfo' => true and 'omitScriptNameInUrls' => true in your craft/config/general.php file.

| improve this answer | |
  • Got it, that worked. I moved the public files out to the my main server folder getting rid of the /public/ string, so that was the last piece I was missing. Thanks! – firedrawndagger Jan 26 '15 at 3:09
1

I was having this issue and got it fixed by doing the following

Note: I am using Ubuntu

  1. Assume apache2 is installed
  2. Run sudo a2enmod rewrite
  3. Ensure Options FollowSymLinks SymLinksIfOwnerMatch is within your virtualhost <directory> config
  4. Run sudo service apache2 restart

Hope this helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.