6

I built a site locally and moved it up to a remote host. I am getting a page that says

“Service Unavailable Our site is temporarily unavailable. Please try again later.”

It’s clearly a page coming from Craft so i know the CraftPath is set up right. I have multi-environment variables set up in config/general.php that seem to be working, i.e. it still works locally and there is a stylesheet being called properly in the error page so i think my {baseUrl} is working. I also have them in config/db.php and at least, the local connection is being made. I have devMode => true and it's not giving any hints...

So i uploaded /craft and /public and imported the database. I’m currently using an IP address because the Url is in use and will be moved later on. I had the IP set up so i get to my /index.php and it seems to go out and find /craft OK.

I don’t have to reinstall craft or anything do i?

The /craft, /public, database, and multi environment variables should do it? Is there some other thing i need to do?

Would a DB connection error be clear?

3

That error means your site is currently offline. Check in the control panel under Settings->General to see if it's set to offline there. Or maybe you're using the isSystemOn config setting and it's set to off on your production environment there.

  • Thanks, Brad. Actually turns out i had imported an older version of the DB that went with an older verison of Craft. – Bob Marteal Jan 21 '15 at 5:11
  • I am getting the same error too - cant work out what is causing it/ – user4335 Nov 12 '15 at 11:07
2

I ran into this issue a few times, turns out I had to change htaccess to .htaccess in the public_html/ folder

1

Might also be worth checking if your Craft is having issues connecting to your DB. I got the same message when I launched a new instance on another domain, but forgot to setup the config.

1

I recently ran into this issue as well for a site with multiple locales using a multi-environment configuration.

The issue turned out to be that the secondary locales did not have a multi-environment configuration setup in a way that helped identify what environment they were operating in. Updating the secondary locales index.php files to test for the environment and define the CRAFT_ENVIRONMENT variable got things working again.

1

For what it's worth I found this page after doing a web search for the error message, then realized that I had set everything up on the live server but hadn't imported the database.

Then I realized that when I updated the database password in my .env file I actually had replaced the security key.

So those are other things to check.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.