Hi got past the username etc screen for install but stuck on the 'oops' screen? I've tried again and again but same deal, checked db settings just not getting past this, assuming the oops means it can't connect to the db but if the details are correct (I have a pw with its own un and pw with privs for that) and tested with root root, any ideas – seems most people are having no probs with this, then tried logging in and ok, why would it hang do you think on oops when seems to have installed?


2 Answers 2


If Craft can't connect to the database, it will let you know. Some other error is occurring. Check your craft/storage/runtime/logs files for an [error] entry, and that will have the error message that is occurring.

Also, in between installation attempts, be sure to delete any tables that were created in the database from a previous install attempt.

  • Although I can now see the error log, I'm not certain what the error is ---- [warning] [application] Skipping record /Users/Mymac/Sites/ontherocks/craft/app/records/BaseRecord.php because it’s abstract or an interface. I went to /admin ad logged in ok, added fields etc and okay, worried my Mamp settings are wrong although seems ok for other system installs
    – Kev N
    Jan 19, 2015 at 16:39
  • That one isn't causing the problem. Are there no [error] entries being logged?
    – Brad Bell
    Jan 19, 2015 at 18:51
  • 2015/01/17 07:26:15 [error] [exception.Craft\HttpException.404] exception 'Craft\HttpException' in /Users/Mac/Sites/craft-demo/craft/app/etc/web/WebApp.php:737 Stack trace: #0 /Users/Mac/Sites/craft-demo/craft/app/etc/web/WebApp.php(176): Craft\WebApp->_processInstallRequest() #1 /Users/Mac/Sites/craft-demo/craft/app/framework/base/CApplication.php(180): Craft\WebApp->processRequest() #2 /Users/Mac/Sites/craft-demo/craft/app/index.php(62): CApplication->run() #3 /Users/Mac/Sites/craft-demo/public/index.php(19): require_once('/Users/Mac/Site...') #4 {main} REQUEST_URI=/ --- any ideas?
    – Kev N
    Jan 19, 2015 at 23:43
  • Sorry... that's just a 404. Any [error] other than a HttpException.404?
    – Brad Bell
    Jan 19, 2015 at 23:45
  • [info] [application] [Forced] Trying to write to file at /Users/Mac/Sites/craft-demo/craft/storage/runtime/cache/06d99ef33038f0014d8f3ce02e7e5d5e.bin using LOCK_EX. in /Users/Mac/Sites/craft-demo/craft/app/helpers/IOHelper.php (786) 2015/01/19 23:44:03 [info] [application] [Forced] Successfully wrote to file at /Users/Mac/Sites/craft-demo/craft/storage/runtime/cache/06d99ef33038f0014d8f3ce02e7e5d5e.bin using LOCK_EX. Saving in cache. in /Users/Mac/Sites/craft-demo/craft/app/helpers/IOHelper.php (793)
    – Kev N
    Jan 20, 2015 at 0:01

I had the same issue and after struggling for hours I found out that I had to stop MySQL server from running in System Preferences. After that the insallation was successful

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.