4

Sorry to repeat this question but not yet found a fix:

Followed the install and when I try and navigate to: site/admin

I get: "The requested URL /admin was not found on this server" Have tried moving files around/permissions as 777, and changing the $craftpath but no joy as yet. I use MAMP set up for other projects so is there an approach without changing MAMP settings? Or am I missing something obvious?

Appreciate any help albeit a very basic question as want to get started!

Cheers

6
  • What happens if you go to yourdomain.com/index.php?p=admin? – Brad Bell Jan 15 '15 at 22:58
  • Thanks, I get the "Could not find your craft/ folder…" alert – have tried various paths for $craftpath and changing directories, can't figure out what I'm doing wrong? Sorry – Kev N Jan 16 '15 at 0:54
  • When I create a new project with MAMP Pro e.g. craft/ the default index.php file MAMP creates loads fine with craft/ (i.e. craft.index.php) incase that indicates any issues or not – Kev N Jan 16 '15 at 0:58
  • Have you seen this guide to getting Craft running on MAMP? – Brad Bell Jan 16 '15 at 1:30
  • 2
    When we run local Craft installs on MAMP we run a folder called 'public' on the same level as craft/ (this is as the download comes) - this mirrors the set up on most live servers, and the default craft path and htaccess then works fine. You'd then access your admin panel at public/admin Also check the htaccess file in public is named '.htaccess' - easy to miss, as I think the default file in the downloaded public folder is named 'htaccess' (without the dot) – pumkincreative Jan 16 '15 at 10:07
5

When I'm trying to get past my initial errors, here are some of the things I try. This is assuming you have the usual directory setup, with the webroot public on the same level as craft

  • Create foo.html in public, and visit yourdomain.com/foo.html. Good for mamp problems, virtual host problems, permissions problems.
  • edit public\index.php and add die('made it to index'); right at the top (after the <php?). Visit yourdomain.com. Good for some .htaccess problems.
  • edit public\index.php and add die('index is about to require '.$path); right above the require at the bottom (and of course take out the earlier die). Make sure the craft path is right.
  • edit craft/app/index.php and add die('made it to craft/app/index'); right at the top. Can expose some php problems (open_basedir e.g.)

That's usually enough to get me started.

1
  • It was my MAMP Pro settings – needed to be Run Apache as home not www, – Kev N Jan 16 '15 at 23:14
1

Hope this video is useful for your query

https://youtu.be/rWHYTZEpa-M

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.