1

I'm trying to install the plugin "Download assets" to Craft and I get an error when trying to install.

Directory was unable to install this plugin :(
No files have been updated and the database has not been touched.

Could not find plugin folder in zip

I do have an external site and a local development site. And this happens on the external site. It does however work correctly on the local site, and it's the exact same installation. What could be the cause for this issue?

  • Do you have the downloadassets folder immediately inside of the craft/plugins folder? – Brad Bell Jan 9 '15 at 16:54
  • Yes, on my local install this is the case. On the external site though it's not there. These sites are connected via a Git, and when I publish the changes locally, it's pushed to the external site as well. And when that is complete, the downloadassets folder is in the correct place. But it still does not show up in the plugins view on the site. I just downloaded the assets manually for now though. – Kenny Bones Jan 12 '15 at 9:46
2

As Brad mentioned in his comments, make sure you have the latest version of the plugin uploaded to the craft/plugins directory on your production server. I just tried it for testing sake and it seemed to work fine for me!

If you are sure they are in the right spot, check out this answer from a different question, stating to make sure the directory names are all lowercase, so "downloadassets" and not "downloadAssets" or "DownloadAssets," as many production environments are case-sensitive.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.