1

I'm at a loss. I've set up a font-end user activation workflow that looks like this:

  1. User registers via a front end form based on Craft's example form
  2. User is redirected to a page informing them that they'll be receiving an email with an activation link
  3. User clicks the activation link and lands on a welcome page

Right now my user registration form is working. When a user registers, I can see them added to the CP user list with their email address, firstName and lastName (which I'm also collecting from the registration form). The redirect to the "you'll be receiving an email..." page is working as well.

But when I click the activation link to test, I end up on the homepage of my site, not on the uri I've specified in my config settings which look like this:

return array(
    '*' => array(
        'omitScriptNameInUrls' => true,
        'defaultImageQuality' => '65',
        'useEmailAsUsername' => true,
        'loginPath' => 'member/login',
        'logoutPath' => 'member/logout',
        'postLoginRedirect' => 'member/my-account',
        'autoLoginAfterAccountActivation' => true,
        'activateAccountFailurePath' => 'member/activation-failed',
        'activateAccountSuccessPath' => 'member/activation-success',
    ),
other settings below...

I'm making sure that when I test sign-ups, I'm logged out in a different browser. I've also tried the sequence without autoLoginAfterAccountActivation set to true but in that case, I just end up logged out on the homepage of my site rather than on the activation-success page.

The activation works, which I can verify in the CP, but I can't figure out why the site isn't respecting my config setting for activateAccountSuccessPath.

Anyone have any ideas?

  • Were you logged in with another account at the time you clicked the activation link in your email? – Brandon Kelly Jan 7 '15 at 22:58
  • I was logged in with an admin account in Safari, but going through the signup process and pasting the activation link into a fresh Chrome browser window. Also, just tried the whole process after completely logging out in all browsers and got the same result. – Adam Snetman Jan 7 '15 at 23:06
  • What version of Craft are you on? We actually just brought support for that activateAccountSuccessPath config setting back in yesterday’s update (Craft 2.3.2625). – Brandon Kelly Jan 7 '15 at 23:29
  • I'm on 2.3.2621. So I should try to update and then test the process again? – Adam Snetman Jan 7 '15 at 23:59
  • Updated to latest version of Craft and tried again and all worked as expected. Thanks Brandon. Is support for this setting likely to change in the future? Wouldn't want to break my process if I didn't read through update notes carefully enough. – Adam Snetman Jan 8 '15 at 0:48
1

The issue was solved by updating Craft to the latest version (2.3.2625), which brought back support for the activateAccountSuccessPath config setting. Thanks to Brandon Kelly for the heads up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.