4

I've installed craft on some terrible hoster (I know, under force). Because of that I had to install craft in the public folder, next to the index.php file. I've set the path to ./craft and activated the .htaccess file. Now it will show the installation page, but halfway stops with the attached errors.

The odd thing is that it searches for /garnish-0.1.min.map in the site root, while it's in the app/resources etc folder?

enter image description here (Click to enlarge)

EDIT: Placing the file garnish-0.1.min.map in the root removes the first error, apparently it's really looking for the files in that place?

  • Check the contents of your craft/storage/runtime/logs files for the actual underlying error that's causing the 500 Internal Server Error. Either that or lick on the 500 request from your browser's console and check the response. – Brad Bell Jun 27 '14 at 16:00
  • The log file got me on my way, it gave a warning that the database was already installed, apparently it freezes if that is the case. – noregt Jun 30 '14 at 9:50
4

The log file got me on my way after a tip from Brad Bell:

'CDbException' with message 'CDbCommand failed during the SQL statement: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'craft_assetfiles' already exists' in ...craft/app/framework/db/CDbCommand.php:358

Removing the database and doing a fresh install solved the issue.

1

I'm throwing out a wild guess only, but what happens if you temporarily remove the .htaccess file in the top level of the "craft" folder. It's contents (i.e. "deny from all") may be causing some problem. Could that be causing some files not to be found?

  • Thanks John, I'm afraid that won't help. Could it be that access rights interfere here (I've given 744 for the app folder and subfolders)? What is the typical setup for a shared hoster in that case? – noregt Jun 27 '14 at 13:41
  • Just did a 777, no difference – noregt Jun 27 '14 at 13:53
  • 1
    My next guess would be to remove the .htaccess file at the base of your "public" folder. Those "500" errors are typically caused by .htaccess problems in my experience. – John Morton Jun 27 '14 at 13:56
  • Bit of a dumb question maybe, but how do I install craft without the htaccess? I can only start the install with htaccess and /admin – noregt Jun 27 '14 at 14:14
  • To quick, it worked with index.php?p=admin/install. But still the same. – noregt Jun 27 '14 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.