1

Is there any reason why image transformations might not be working locally? I just get a bunch of these "http://site.dev/cpresources/transforms/7 404 (Not Found)" as error messages. The image directory has the correct permissions...

4
  • 1
    Check your craft\storage\runtime\logs files for any relevant errors? – Brad Bell Jan 6 '15 at 22:29
  • Same problem here on a local installation. Any ideas? – Nathan D Huening Aug 31 '15 at 14:47
  • Are your Asset upload paths using environment-specific values? – Michael Rog Aug 31 '15 at 15:38
  • @MichaelRog It's the default HappyLager site, so nothing environment-specific. Not a single transform works: all URLs are '/cpresources/transforms/' and I've verified that the 'assets' folder has permission of 777. Totally puzzled. – Nathan D Huening Sep 17 '15 at 2:47
1

It is very likely that your "File System Path" on the asset source is unsuitable for a local environment.

You can set the fileSystemPath in your config like this:

'environmentVariables' => array(
    'fileSystemPath' => '../../public'
)

Then you can change your asset source settings to something like the following:

craftcms asset source settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.