1

I'm in the process of installing Craft on my Ubuntu 14.04 server and ran into an issue.

When I run the installer at http://example.com/admin, I get the "Can't run Craft" error message:

Craft requires cURL in order to run

I have these packages installed using sudo apt-get install:

curl
libcurl3
libcurl3-dev
php5-curl

No clue what's going on. Could be a configuration issue? or are my packages not properly installed?

Thanks for the help!

  • Derp... I was able to install it locally on a Ubuntu 14.04 vagrant instance. Must be something wrong with Ubuntu on my VPS. – Brian Saycocie Dec 30 '14 at 15:25
2

You likely need to go to /etc/php5 and either make a link or move curl.ini from the mods-available folder to mods-enabled. (Just did this myself on Ubuntu 14.04 server)

Also, be sure to restart apache: su apache2ctl restart

|improve this answer|||||
  • I looked in /etc/php5 and I don't see a mods-enabled folder? I do see curl.ini linked in /etc/php5/apache2/conf.d/ and /etc/php5/cli/conf.d/. – Brian Saycocie Dec 30 '14 at 13:21
  • 1
    Sorry I didn't see this until now. I had that same issue, and just went ahead and created a mods-enabled folder. – Jeremiah Dec 30 '14 at 19:36
1

I re-imaged my VPS and ran a new instance of Ubuntu 14.04. Now its all working.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.