1

Hi I was trying to save the matrix field and got the error: "Internal Server Error

Undefined index: handle"

I checked out all fields' handles and they are all in place.

Is there any reason causing the error? enter image description here

Thank you!

enter image description here

  • Can you find that error in your craft/storage/runtime/logs folder and post the full stack trace leading up to it? Alternatively, you can enable devMode (buildwithcraft.com/docs/config-settings#devMode), reproduce the error and get the stack trace in your browser. – Brad Bell Dec 24 '14 at 22:10
  • Thank you for replying, I uploaded the errors with devMode on. Hope it helps to explain the problems I've got. Thank you! – Yulu Jan 5 '15 at 16:11
  • It's hard to tell which Matrix field it's complaining about from the stack trace, but can you try going through each of your Matrix field settings pages and re-saving their settings and see if the error goes away? – Brad Bell Jan 5 '15 at 16:26
  • I went inside each matrix field settings and resaved them (no errors came up), but still got the same error when save the whole matrix. – Yulu Jan 5 '15 at 16:58
  • I thought it could be the matrix fields maximum number reached, so I tried to delete one block type. And I received a "type" error on saving as newly attached in the post. – Yulu Jan 5 '15 at 17:03
2

This ended up being an environmental issue with semi-largish Matrix fields.

The three most common culprits are your php.ini file's max_input_vars, max_input_nesting_level and post_max_size would would need to be adjusted upwards, but other settings might come into play depending on your environment an Matrix configuration.

Also, if your server is running anything like mod_security or Suhosin, they have additional settings that might need to be adjusted higher that could affect this.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.