3

In my local MAMP site I'm not able to upload any files.

Gives me this error in Chrome:

http://nobel.craft.dev:8888/index.php?p=admin/actions/assets/uploadFile net::ERR_EMPTY_RESPONSE

This error in Safari

"Failed to load a resource: The network connection was lost."

Things I did

  • I've checked the asset folder path
  • makes sure folder is writable
  • nothing strange in the craft.log
  • delete cache in admin
  • download new version of craft and replaced the app folder
  • Have you tried another browser (I'm assuming you're using chrome and the first page of google results for ERR_EMPTY_RESPONSE are all chrome issues)? – Steven Vandemoortele Dec 17 '14 at 14:14
  • Yes. Tried Safari. [Error] "Failed to load a resource: The network connection was lost." (index.php, line 0) – Johannes Lamers Dec 17 '14 at 14:56
2

That usually means "something fatal happened" when trying to upload the file. The usual culprits are the php.ini max_execution_time and memory_limit settings, but if it's happening for small files too, something else could be going on.

Have also seen it happen when you're uploading an image in a format your underlying image processing library doesn't support. i.e. your server has GD installed, but you're trying to upload a 32-bit PNG. Or you're running an older version of GD or Imagick that has a bug you're hitting.

Check if you have a craft/storage/runtime/logs/phperrors.log file. Any PHP fatal errors will be logged there. If not, then check the Apache error logs to see if it's an Apache problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.