2

I keep getting this error when I go to install Craft: "Declaration of Craft\UrlManager::parseUrl() should be compatible with that of CUrlManager::parseUrl()"

I am installing on a subdomain. The database credentials are in place, the permissions are correct and the craft folder is found.

I have devmode enabled and the last stack trace item is pointing to "craft/app/etc/web/UrlManager.php(18)".

  • Maybe some files weren't copied correctly, try re-uploading the /craft/app/ folder. – Victor In Jun 26 '14 at 18:07
3

That's a bug in Craft that occurs with the specific configuration of PHP you're running. Just fixed it for the next release, though.

In the meantime, you can open up craft/app/etc/web/UrlManager.php, find the parseUrl method and change it from:

public function parseUrl(HttpRequestService $request)

to:

public function parseUrl($request)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.