3

I installed Craft CMS and all seemed great! But the pages are not loading.. So bascially /admin loads but /index.php genrates an error.

In dutch: "Interne Serverfout Craft\EntryModel en zijn behaviors hebben geen method of closure met naam "heading"."

Which translated is something like: "Craft\EntryModel and its behaviours have no method or closure with the name heading"

Any idea what's wrong? Can be server-level.. I run it on a mac mini server, but mysql, php and apache (plus php-modules) are installed, and again, admin works nicely.. best, Bart

  • Since this was identified as a bug by Brad, and fixed in the next version of Craft, we'll close this thread as a "bug report". – Lindsey D Dec 7 '14 at 8:13
2

Apparently this is a bug in the latest release. Oops!

The default homepage template on a fresh install is referencing an entry.heading that no longer exists.

Fixed it for the next release, but in the meantime, you can change line 23 of craft/templates/index.html from:

<h1>{{ entry.heading }}</h1>

to:

<h1>{{ entry.title }}</h1>
1

I don't think the there is anything wrong with your Craft install. It looks like you might have removed a field from a section but it is still being referenced in your template, but because it doesn't exist for that entry anymore Craft is throwing that error.

Look in the template that is being rendered and there will probably be a tag like {{ entry.heading }} try deleting it and refreshing the page, or alternatively add a 'heading' field to the section the entry belongs to. This should solve the issue and make the error go away.

  • it was a new bug! tot do with this entry.heading indeed (see choosen solution..) – skipx Dec 7 '14 at 9:04
  • Ahh nice glad it got fixed! At least you know why that error occurs if you see it again in the future :) – Alec Ritson Dec 7 '14 at 10:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.