1

If I want to view the PHP Error logs from craft true utils/logs I get an 403 Forbidden error.

nginx/1.6.2

../admin/utils/logs/phperrors.log

What could be wrong?

  • You can view the craft.log, craft.log.1, etc. files fine? Is it an nginx 403 or a Craft one? – Brad Bell Dec 3 '14 at 23:37
  • craft.log works. and yes it is an nginx error. – Johannes Lamers Dec 4 '14 at 9:23
  • Sounds like some weird nginx configuration/permissions issue. Strange. – Brad Bell Dec 4 '14 at 16:26
4

Had the same problem. I my case, it was the following code in my nginx config file:

location ~* (?:\.(?:bak|config|sql|fla|ini|log|sh|inc|swp|dist)|~)$ {
    deny all;
}

After removing log| from the list, the problem was solved.

| improve this answer | |
1

Sounds like a file permission issue. Make sure that phperrors.log has acceptable read permissions.

| improve this answer | |
  • Not working. Read permissions are the same as craft.log. And they work normal. Tried other permission settings. Same error. – Johannes Lamers Dec 3 '14 at 17:31
  • I also have this issue, all the files in /craft/storage/runtime/logs are: -rw-r--r-- 1 forge forge - I can access /admin/utils/logs but if I select another logfile, I get the same nginx 403. – Adam Menczykowski Feb 5 '16 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.