3

When I upload animated gif assets to a Craft site, they end up static and corrupted, as so:

Holey Seagull

(Original here.)

My guess is that what's displayed is the last frame of the animation (which only contains pixels changed from the penultimate frame).

Other image resizing functions work. The site is hosted on a dedicated Ubuntu box with PHP 5.3.10. Here's what phpinfo() says about my ImageMagick/Imagick install.

imagick module version => 3.1.0RC1
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
ImageMagick version => ImageMagick 6.6.9-7 2014-03-06 Q16 http://www.imagemagick.org

Calling convert source.gif -resize 123x123 dest.gif works on the server—the issue seems to lie in the PHP call to ImageMagick rather than in the installation itself. Answers to this question indicate that GIF issues disappear with the proper configuration, but I fail to see what's lacking in this particular setup.

  • Any chance this is a public box we could get CP/FTP access to , to see what's going on? If so, can you send some credentials over to support@buildwithcraft.com? – Brad Bell Dec 1 '14 at 22:54
2

Updating PHP on the server to at least 5.4 fixed the issue. This is apparently a known Imagick issue with PHP 5.3.

| improve this answer | |
  • 1
    Ohh... nice find! – Brad Bell Dec 2 '14 at 17:26
  • @BradBell Thanks again for the quick support offer. It makes Craft a trusty platform to build on. – louije Dec 2 '14 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.