2

We've got all the max settings set up OK as per https://craftcms.com/support/upload-troubleshooting, but we are still getting errors. The log file just shows this, nothing more:

2014/10/24 11:26:35 [error] [application] Uploaded file was empty

What else should we be looking for?

4
  • Is it just a particular file, or all files? Can you enable devMode, reproduce the problem and post the stack trace leading up to the error? Also, check and see if you have a craft/storage/runtime/logs/phperrors.log file and if anything related is getting logged there.
    – Brad Bell
    Oct 29, 2014 at 17:55
  • @RussBack, did you get this straightened out? We're attempting to round up stagnant questions and would love to know if there's something to learn here.
    – Matt Stein
    Feb 20, 2015 at 2:15
  • We haven't actually. I have a ticket update from Brad to look at - will reply today if I can.
    – Russ Back
    Feb 20, 2015 at 6:44
  • Hey guys, im actually having the same isssue, any insights you could share? Jan 12, 2016 at 18:59

1 Answer 1

1

I had the same problem and all PHP settings were set OK. I couldn't upload a 2MB file, but uploading a 20KB file was fine.

The problem was that the /tmp folder was almost completely full (because PHP stores the temporary file in /tmp before moving it to web/user space i.e. your assets folder). Freeing up space in this folder solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.