1

Can these things work together? Right now, after verification I am being redirected to the dashboard (/gistApp) instead of being routed through /actions/gistClient/loginControl where I have some user business logic. I know that /actions/gistClient/loginControl works because I can direct navigate to that URL.

Here is my general.php

return array(
 'omitScriptNameInUrls' => true,
  'loginPath' => '/gistapp/login',
  'setPasswordSuccessPath' => '/gistapp/login' ,
  'purgePendingUsersDuration' => 'P2M',
  'devMode' => true,
  'autoLoginAfterAccountActivation' => true,
  'postLoginRedirect' => '/actions/gistClient/loginControl',
  'enableCsrfProtection' => true,
  'csrfTokenName' => 'cranberryCsrfToken',
);
  • Per Brad's answer, this was a bug and has been fixed. Since this question no longer has any historical value, it will be closed as a "bug report". – Lindsey D Nov 30 '14 at 4:40
0

If the user being registered has access to the control panel, then you'll want to set the postCpLoginRedirect config setting as well.

Update:

Looks like this was a bug and the same problem as this one. Should be fixed for the next release.

Update 2:

Officially fixed in 2.2 build 2598.

| improve this answer | |
  • No CP access in the case cited above. I am building out an entire frontend experience for these users. – David A McInnis Oct 22 '14 at 0:45
  • Ahh... looks like this might be a bug. Will look into it and update the answer here. – Brad Bell Oct 22 '14 at 0:50
  • So, am I correct in assuming that the error is in 'postLoginRedirect' => '/actions/gistClient/loginControl'? I added a redirect to the login form and that works. It does not solve my problem but as a hidden input field the redirect works. – David A McInnis Oct 22 '14 at 5:29
  • Updated the answer. – Brad Bell Oct 22 '14 at 22:08
  • Is this broken again. I tested this today and after login, was redirected to the homepage. My config settings are the same as above. When I log in through the login form, I am correctly redirected to loginControl. The problem seems to be in chaining autoLoginAfterAccountActivation and postLoginRedirect – David A McInnis Nov 13 '14 at 8:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.